Manjaro Other
   872

ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости) :: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8

С последним обновлением у меня были проблемы, кто получил вот такую ошибку:
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости) :: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8

Вот решение:
bbs.archlinux.org/viewtopic.php?id=237522

Просто хотел помочь другим быстрее найти решение.

10 комментариев

avatar
Молодец! Сам нашел в инете и исправил, да и другим помог.Плюсанул.
0
avatar
Спасибо за помощь но тьфутьфу вроде обновы прошли без эксцесов вот только граб заново востанавливать --2 система сразу пропадает при старте машины
0
avatar
Здесь тоже решение написано
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
+1
avatar
Таким образом решается проблема с обновлением системы, но как теперь решить проблему со сборкой плеера bomi из aur? Нужный для работы bomi компонент ffmpeg2.8 не хочет собираться из-за просроченной PGP-подписи.
0
avatar
отредактируйте pkgbuild
Вместо :source=(«ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz»{,.asc})
надо: source=(«ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz»)
Вместо: sha256sums=('ef061d9a6cdde8628d00613d17b467fb5ad75e7404ef523dc842e192c511a116'
'SKIP')
надо: sha256sums=('ef061d9a6cdde8628d00613d17b467fb5ad75e7404ef523dc842e192c511a116')
0
avatar
все нормально собралось и с обычным ffmpeg
0
avatar
в самом конце сборки вот такая ошибка:
In file included from video/ffmpegfilters.cpp:1:
video/ffmpegfilters.hpp:9:10: фатальная ошибка: libavfilter/avfiltergraph.h:
Нет такого файла или каталога
Что делать? Простите, парни, я только учусь)
0
avatar
Нужно установить пакет ffmpeg.
0
avatar
Пакет ffmpeg стоит, если при установке не прописывать версию, а ставить просто: pacman -S ffmpeg, то обновляется уже установленная в системе версия ffmpeg-1:4.0-3. Но при сборке из aur bomi хочет именно версию ffmpeg2.8. Редактируя pkgbuild способом, описанным выше, сборка ffmpeg2.8 вроде бы начинается, но затыкается из-за отсутствия в aur компонента libdcadec. Кодек это видимо? Куда рыть дальше?
Последний раз редактировалось
0
avatar
Сам спросил — сам ответил) Бог его знает, может кому пригодится — ситуацию спасла установка из pamac версии bomi-git 0.9.11.r39.g5f0cc0a7-1
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.