Флуд
   2893

Нужно ли избавиться от не нужного софта в стабильной сборке manjaro?

В Telegram беседе разгорелся спор, на данную тему, давайте это обсудим.

Одни пользователи считают, что в стабильной версии манжаро много лишнего предустановленного софта, из-за которого система занимает много места, оперативной памяти, а также тяжелый iso-образ. Лишним называлось akonadi, pim и другие. Их мнения: «ага поставь жирный дистр и потом сиди и удаляй все г… не прще ли поставить минимум и доставить то что нужно каждому в отдельности», «я хочу, чтобы в стабильном релизном манджаро было всё что нужно но не всё при всё при всё, лишний гиг — не пустяки.»

Я являюсь приверженцем того, что полная версия манжаро необходима, так как она содержит большинство программ, которые могут пригодится обычному пользователю в использовании системы, а ненужные пользователь легко удалит, вместо того чтобы заного устанавливать и настраивать весь софт по отдельности. Для тех пользователей, которые уже не новички и знают какой софт использовать, а полная версия их не устраивает, есть минимал образ. Я выступаю против того, чтобы новички использовали минимальную систему, так как это породит множество вопросов и ошибок, с их стороны.
К примеру, для одних пользователей qt4 является лишним пакетом. Но данный пакет необходим для использования virtualbox, хоть и не входит в его зависимости.
Вот еще пример, KDE PIM. Но он необходим для работы следующих программ: Akregator, KMail, KAddressBook, KOrganizer, Konsole, Kalandar, KPilot, Kandy, KArm, KNotes, KAlarm, KNode, Kontact, KJots. Эти программы включены в поставку и удовлетворяют большинство запросов обычных пользователей.
Моя позиция такова, стандартная сборка манжаро должна содержать данные программы, их не так тяжело удалить, заменив своими любимыми программами и избежать возможных ошибок. Если вы продвинутый пользователь, вы можете воспользоваться минимальной версией. Возможно, для некоторых пользователей не помешала бы еще одна сборка манжаро, но я против «урезания» основной сборки.

Приверженцем какой точки зрения вы больше являетесь?

Не стесняйтесь высказать свое мнение в комментариях!

52 комментария

avatar
Я начал с опроса, выбрав полную комплектацию софтом, памятуя о возможности запуска в режиме live. Но мне пришел в голову третий вариант, когда в процессе установки можно выбирать, какой софт устанавливать. По-моему в каком-то дистрибутиве такое есть или было.

UPD. А вообще, лично я, как однажды скачал и поставил систему, больше к этому вопросу не возвращался. Manjaro учит чинить, а не переустанавливать, а больше мне ставить и некуда.
Последний раз редактировалось
+1
avatar
спор был о том, что в манджаро релизной версии установщик 2 гига, ичто в нём крайне много лишних приложений, которые ужны опционально единицам. Я был за то, что было бы крайне неплохо, если в рлизной версии был бы поменьше установочной диск и поменьше приложений. Только самое необходимое, браузер, видеоплеер, калькулятор, офис, графический редактор и баста. Сейчас же релизная версия попросту отпугивает своей монструозностью, установишь с 2 гигового носителя и потом еженедельно апдейтов по 500 метров прилетает, ну куда это годится?
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
После установки системы, ненужный софт можно удалить, тем самым освободив систему от ненужных апдейтов. Для тех кому не нужен тяжелый образ, есть минимальная поставка.
0
avatar
удалить 1 гигабайт ненужных пакетов и софта не всем по силам и вообще не самый простой путь
?
Свежие новости мира информационных технологий ТехноДжем
+3
avatar
Путь довольно простой, смотреть группы и удалять пачками не нужное.
0
avatar
Так как первый опрос показался manjarqo не корректным и удален, я создал новый с точной формулировкой: https://manjaro.ru/blog/how-to/opros-v-kakoj-postavke-dolzhen-byt-manjaro.html

Уже 2 опроса было удалено, я не могу создать опрос, даже во флуде.
Последний раз редактировалось
0
avatar
Второй опрос тоже показался мне не корректным, так как выражены только моя точка зрения и точка зрения Doaxan. Позднее будет создан другой опрос, на базе которого будет сформулировано обращение от русскоязычного сообщества к разработчикам
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Это был обычный опрос, те у кого другая точка зрения, могли просто высказать ее в данное обсуждение.
0
avatar
Как по мне, то нужен облегченный образ и более продвинутый в плане выбора основных пакетов установщик (по типу как у Antergos, ага), в котором можно будет навыбирать и докачать действительно необходимый софт, к примеру по предподготовленным шаблонам. Хотя бы запилить это всё в виде небольшой кнопки «Customize...» на соответствующем этапе. А для новичков по дефолту (всё равно будут жать Next/Next/...) пускай докачивается обычная часть образа со стандартной комплектацией.
+6
avatar
Да, поддерживаю, либо докачивается из сети(но многие не обладают хорошим инетом), либо пусть образ будет такой же 2-х гиговый, но устанавливаются только отмеченные чекбоксами приложения и пакеты
?
Свежие новости мира информационных технологий ТехноДжем
+5
avatar
Самое главное, что вы не пробовали данный способ сами и не знаете всех его недостатков, один из них — потеря соединения и остановка всего процесса установки.
0
avatar
Откуда уверен что он не пробовал? И я же предложил с образа пусть инсталлится, но именно то, что надо, а не всё
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Все-таки лучше когда есть дополнительно минимал…
Одно дело когда ставишь ДЕ и его родные проги…
а другое — когда нужно привычное ДЕ + ДРУГОЙ софт…
потому как иначе придется все это в куче обновлять или выпиливать ненужное…
0
avatar
Можно удалить весь ненужный софт по группам.
0
avatar
Думаю ответ на поставленный в теме вопрос может быть только положительным! А как иначе? Никому не нужен лишний софт! Нужно избавляться!
А вот теперь самое интересное! А какой софт считать ненужным? Вот тут мы никогда не придем к консенсусу.
Чебоксами и прочей ерундой проблему большого образа не решить. Ежели идти к потребителю (новичкам), то надо следовать в конве Mint и Ubuntu, т.е. предлагать максимальную комплектацию. Мне кажется, что проблема большого образа при нынешних скоростях Интернета слегка надумана. В правильном направлении идем товарищи! Будет надо — почистим.
Про самую минимальную комплектацию. Может просто arch?
Последний раз редактировалось
+1
avatar
Установка манджаро кед из релизного образа при загрузке системы потребляет около 1 гигабайта оперативки, установленная из манджаро минимал кед с установленными всеми мне необходимыми приложениями и службами, потребляет 450 мегабайт оперативной памяти. Закроем глаза на размер установщика, закроем глаза на то, что при каждом обновлении качается больше 1 гига, плюнем на то, что количество различных излишков в системе увеличивает вероятность багов в ней.
Последний раз редактировалось
?
Свежие новости мира информационных технологий ТехноДжем
+5
avatar
Когда заядлый KDE-шник в оправдание, того что не так и много потребляет Kubunta при помощи миллиона известный всем KDE-шникам настроек превратил ее в Лубунту, то он реально поразил мой разум. Зачем? Считаю, что все, кто ставит себе KDE изначально должны быть готовы к 2гигам установочного образа, 1 гигу сожратой оперативки, падениям и пр. прелестям! Религия брат! Иначе милости просим к простым смертным.
+3
avatar
Так можно сказать про любое рабочее окружение и линукс в целом. Полная ерунда и глупость. Может быть для вас и нормально, что ваше рабочее окружение потребляет много ресурсов и падает, для меня это неприемлимо.

Я Могу так же привести пример и на Крысе, релизный образ весит 1,5 гигабайт, образ минимальной сборки 800 мегабайт. Сразу после загрузки релизная версия потребляет 450 мегабайт, минимальная версия поребляет 320 мегабайт. Согласен это не такая критическая разница как в кедах. Может пользователи XFCE тоже должны быть готовы к тому, что их крыса должна жрать оперативку как бык помои, фигли оперативка нынче дешевая, можно докупить. Религия же.
?
Свежие новости мира информационных технологий ТехноДжем
+4
avatar
Конечно ерунда и глупость. Чего уж там, это всего лишь мое мнение.

Вообще что обсуждаем? Мы каждый день с утра до вечера устанавливаем любимую ось? Manjaro — роллинг, раз поставил, нужное доставил, ненужное отпилил и забыл.

Ежели крыса начнет вести себя агресивно, ну что же, есть Mate, LXQt и пр. Перейду, религия позволяет.

Считаю сейчас думать больше надо о тех кто приходит! Как привлечь их, как захватить мир? Про сохранение лояльности Manjaro еще думать рановато.
+1
avatar
Полностью согласен с вами. Те кто считает что нужна новая сборка на каждый чих, не понимают как привести систему к нужному виду.
«Только самое необходимое, браузер, видеоплеер, калькулятор, офис, графический редактор и баста. » хмм, давайте посмотрим «opera, totem, openoffice, Inkscape» вам нужна такая сборка? Возможно. Но лично мне — нет.
0
avatar
А те которые сейчас стоят тебя устраивают? с чего бы вдруг резко менять политику?
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
О какой политике идет речь? Стандатная поставка по умолчанию устраивает всех пользователей своим обилием программ. Не нравится? Удалите лишний софт сами по группам, например. Не нравится? Пожалуйста, воспользуйтесь минимальной версией, Net-Edition, или пилите свою сборку в крайнем случае.
Последний раз редактировалось
0
avatar
Это тебе все пользователи сказали, что :«Стандатная поставка по умолчанию устраивает всех пользователей своим обилием программ.»? Чего ты тут развел истерику, нравится версия где много хлама используй её, я тебя её лишаю? Ты Русский язык читать умеешь? Речь идёт о предложении добавить возможность выбора при установке? Для таких как ты «всех пользователей» оставить возможность установки всех программ и пакетов.
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Истерику я не разводил, ее развели вы, кому лень настраивать систему после установки.
Ты читаешь, что пишешь? «Я был за то, что было бы крайне неплохо, если в рлизной версии был бы поменьше установочной диск и поменьше приложений. Только самое необходимое, браузер, видеоплеер, калькулятор, офис, графический редактор и баста.»
Сейчас ты уже говоришь, абсолютно о других вещах.
0
avatar
Это я выразил свои предпочтения, а ниже я выразил свои предложения, но конечно же срач ради срача, это твой конёк, плевать на суть, лучше дергать фразы там где это удобно, лишь бы срач не прикращался никогда
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
Это уже другой вопрос, на который я ответил «Возможно, для некоторых пользователей не помешала бы еще одна сборка манжаро, но я против «урезания» основной сборки.».
Нужна новая сборка, я не против и даже готов помочь, но обычным\начинающим пользователям только официально поддерживаемую.
0
avatar
Ага, если крыса начнет выешкиваться уйду на мате, если и он начнёт, уйду на и3, если тут всё достанет, уйду на другой дистрибутив, в том то и суть, вам плевать на конкретный дистрибутив, а я заинтересован в его улучшении. Думать о тех кто приходит и захватывать мир, не смешите, вы первый кто уйдёт на другой дистрибутив после какого нибудь бага.
Последний раз редактировалось
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
А Вы, уважаемый manjarqo, я так понимаю с первого взгляда и на всю жизнь?
Посещаете курсы экстрасенсов? Уже научились предвидеть будующее? Уже видите мое бегство? Ладно, я не из обидчивых.

Баги — ерунда, с ними можно разобраться.
0
avatar
Я за минимализированную во все поля сборку, но я попадаю в категорию тех самых, которых расписали в первом посте (я уже знаю что поставить), так что какой-то «преднастрой» должен быть для тех кто еще не в курсе что им понадобится и когда, а особенно как это называется.
Тут хорошим словом вспоминается бубунтовый магазин приложений. Лучше него для тех кто выбирает софт по описаниям и скринам просто нет.
Также в какой-то из задротских сборок (вроде с опенбоксом) была чудная идея оставлять в меню команду на установку вместо какой-то тяжеленной проги. Мол хочешь либру накатить поверх нашей легенькой сборочки — будь добр погоди минут 5-10. И в таком подходе нет ничего страшного. Тот же вин обладает достаточно скудной комплектацией, да еще и скакать по офсайтам нужно чтобы установить то что хочется. И… никто не умирает от этой лишней работы, никто не ноет.
+4
avatar
В общем, задал вопрос на буржуйском форуме и получил ответ.
Он сводится к следующему:
1. Если вам нужно, что-то отличное от предлагаемого основным сообществом — делайте свою редакцию.
2. Выбор софта при установке невозможен, поскольку с появлением «живых» образов изменилась сама модель установки по сравнению с тем, что было в 90-х.
Последний раз редактировалось
+2
avatar
А технически возможно сделать живой образ, чтобы с него выбранные пакеты копировались в нужные директории, то есть не установка посредством установки, а тупое клонирование необходимых пакетов из необходимых директорий?
Последний раз редактировалось
?
Свежие новости мира информационных технологий ТехноДжем
0
avatar
модель установки по сравнению с тем, что было в 90-х
Но ведь та же Ubuntu в конце установки, как только развернула этот самый «живой» образ на диск, может докачать и дополнительно установить нужные пакеты (если выбрать include this third-party software etc. — в общем, нечто подобное), а то и вообще сразу обновить всю систему во время установки (т.е. банально выполнить apt-get update; apt-get upgrade).
Я это к чему — что вообще мешает любому установщику после разворачивания «живого» образа сгенерировать на основе чекбоксов один большой башевский скрипт и тупо в конце самой установки выполнить (а-ля oduso.com/)? По идее ничего.
0
avatar
УФ!
Ели оттер монитор от слюней.
Вопрос, поднятый в теме большинству слушавших, нужен так же как среднестатистическому жителю Папуа-Новая Гвинея
о количестве вылетов авиации России в Сирии.
+1
avatar
Минимал-стабле более востребован — кто-то пользуется PIM, кто-то нет, кому подавай голый MPV, кому-то VLC. И преимуществ куча:
— Меньший размер образа
— Увеличение скорости установки ОСи
— Меньшее потребление ресурсов
— Отсутствие хлама
Из этого следует, что нужен человек, который будет клепать образы и их сопровождать. Вот реально достаточно kde-minimal, chromium и octopi. Все остальное ставится и настраивается уже пользователем.
Последний раз редактировалось
+2
avatar
Manjaro nettinstall нет?
0
avatar
Я все конечно понимаю, все ваши высказывания про то, что опытный сможет удалить то, что ему не нужно, ну вот опытные помогите мне удалить qt4
re2sgsii@Net-PC ~]$ sudo pacman -Rs qt4
проверка зависимостей...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: attica-qt4: удаление qt4 ломает зависимость 'qt4'
:: lib32-qt4: удаление qt4 ломает зависимость 'qt4'
:: libakonadi-qt4: удаление qt4 ломает зависимость 'qt4'
:: libdbusmenu-qt4: удаление qt4 ломает зависимость 'qt4'
:: liblastfm: удаление qt4 ломает зависимость 'qt4'
:: libqzeitgeist: удаление qt4 ломает зависимость 'qt4'
:: polkit-qt4: удаление qt4 ломает зависимость 'qt4'
:: poppler-qt4: удаление qt4 ломает зависимость 'qt4'
:: prison: удаление qt4 ломает зависимость 'qt4'
:: pyqt4-common: удаление qt4 ломает зависимость 'qt4'
:: qca-qt4: удаление qt4 ломает зависимость 'qt4'
:: qimageblitz: удаление qt4 ломает зависимость 'qt4'
:: qjson: удаление qt4 ломает зависимость 'qt4'
:: qt4-gstreamer: удаление qt4 ломает зависимость 'qt4'
:: qtwebkit: удаление qt4 ломает зависимость 'qt4'
:: vlc: удаление qt4 ломает зависимость 'qt4'

К примеру мне это совсем не нужно!
Но эту программу навязывают!
Почему не сделать, как на OpenSUSE при установке выбираешь те покеты которые тебе нужны ?!
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
+1
avatar
Так аргумент s замените на n
sudo pacman -R --help
0
avatar
Вы думаете я не пробовал разные варианты!
[re2sgsii@Net-PC ~]$ sudo pacman -Rn qt4
[sudo] пароль для re2sgsii: 
проверка зависимостей...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: attica-qt4: удаление qt4 ломает зависимость 'qt4'
:: lib32-qt4: удаление qt4 ломает зависимость 'qt4'
:: libakonadi-qt4: удаление qt4 ломает зависимость 'qt4'
:: libdbusmenu-qt4: удаление qt4 ломает зависимость 'qt4'
:: liblastfm: удаление qt4 ломает зависимость 'qt4'
:: libqzeitgeist: удаление qt4 ломает зависимость 'qt4'
:: polkit-qt4: удаление qt4 ломает зависимость 'qt4'
:: poppler-qt4: удаление qt4 ломает зависимость 'qt4'
:: prison: удаление qt4 ломает зависимость 'qt4'
:: pyqt4-common: удаление qt4 ломает зависимость 'qt4'
:: qca-qt4: удаление qt4 ломает зависимость 'qt4'
:: qimageblitz: удаление qt4 ломает зависимость 'qt4'
:: qjson: удаление qt4 ломает зависимость 'qt4'
:: qt4-gstreamer: удаление qt4 ломает зависимость 'qt4'
:: qtwebkit: удаление qt4 ломает зависимость 'qt4'
:: vlc: удаление qt4 ломает зависимость 'qt4'
[re2sgsii@Net-PC ~]$ 

А вот смотрите что будет если я по другому сделаю и что удаляется при этом, я же выше написал что ее навязали
re2sgsii@Net-PC ~]$ sudo pacman -Rc qt4 
проверка зависимостей...
:: avahi опционально требует qt4: qt4 bindings
:: breeze опционально требует breeze-kde4: Breeze widget style for KDE4 applications
:: google-chrome опционально требует kdebase-kdialog: needed for file dialogs in KDE
:: hplip опционально требует python-pyqt4: for running GUI and hp-toolbox
:: libreoffice-still опционально требует kdelibs: for KDE desktop integration
:: openal опционально требует qt4: alsoft-config GUI Configurator
:: subversion опционально требует kdebase-runtime: for KWallet for auth credentials
:: xdg-utils опционально требует kdebase-runtime: for KDE4 support in xdg-open

Пакеты (64) amarok-2.8.0-8  attica-qt4-0.4.2-3  breeze-kde4-5.5.5-1
            calligra-braindump-2.9.11-2  calligra-karbon-2.9.11-2
            calligra-krita-2.9.11-2  calligra-libs-2.9.11-2
            calligra-plugins-2.9.11-2  cantata-2.0.0-3  clementine-1.2.3-10
            digikam-4.14.0-5  k3b-1:2.0.3a-5  kde-servicemenus-rootactions-2.8.5-3
            kdebase-kdepasswd-15.12.2-1  kdebase-kdialog-15.12.2-1
            kdebase-keditbookmarks-15.12.2-1  kdebase-kfind-15.12.2-1
            kdebase-lib-15.12.2-1  kdebase-runtime-15.12.2-1
            kdegraphics-mobipocket-15.12.2-1  kdegraphics-okular-15.12.2-1
            kdelibs-4.14.17-1  kdenetwork-kget-15.12.2-1  kdepimlibs4-4.14.10-7
            kfilemetadata4-4.14.3-4  kipi-plugins-4.14.0-5  konsolepart4-4.14.3-7
            lib32-libdbusmenu-qt-0.9.2-3  lib32-qt4-4.8.7-4  lib32-sni-qt-0.2.6-6
            libakonadi-qt4-1.13.0-8  libbaloo4-4.14.3-4
            libdbusmenu-qt4-0.9.3+15.10.20150604-3  libkactivities4-4.13.3-3
            libkcddb-15.12.2-1  libkdcraw4-15.08.3-2  libkexiv2_4-15.08.3-2
            libkface4-15.08.3-2  libkgeomap4-15.08.3-2  libkipi4-15.08.3-3
            libksane4-15.08.3-2  libkscreen4-1.0.5-2  libktorrent-1.3.1-4
            liblastfm-1.0.9-2  libmarble4-15.08.3-2  libmygpo-qt-1.0.8-2
            libqzeitgeist-0.8.0-6  oxygen-kde4-5.5.5-1  phonon-qt4-4.8.3-6
            polkit-qt4-0.112.0-3  poppler-qt4-0.41.0-1  prison-1.1.1-2
            pyqt4-common-4.11.4-4  python-pyqt4-4.11.4-4  qca-qt4-2.1.1-5
            qimageblitz-0.0.6-5  qjson-0.8.1-5  qt4-gstreamer-1.2.0-2
            qtscriptgenerator-0.2.0-4  qtwebkit-2.3.4-4  skype-4.3.0.37-6
            sni-qt-0.2.6-4  vlc-2.2.2-3  qt4-4.8.7-7

Будет освобождено:  816,79 MiB

:: Удалить эти пакеты? [Y/n]
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
[poly@e ~]$ sudo pacman -Rsc qt4
проверка зависимостей…
:: avahi опционально требует qt4: qt4 bindings
:: openal опционально требует qt4: alsoft-config GUI Configurator
:: virtualbox опционально требует qt4: GUI support

Пакеты (14) libdvbpsi-1:1.3.0-1 libebml-1.3.3-2 libkate-0.4.1-5
libmatroska-1.4.4-1 libmng-2.0.3-1 libtar-1.2.20-2
libtiger-0.3.4-4 libupnp-1.6.19-1 lua-5.3.2-1 sdl_image-1.2.12-3
vlc-2.2.2-3 xcb-util-keysyms-0.4.0-1 zvbi-0.2.35-1 qt4-4.8.7-7

Будет освобождено: 144,34 MiB

:: Удалить эти пакеты? [Y/n]
0
avatar
[re2sgsii@Net-PC ~]$ sudo pacman -Rsc qt4
проверка зависимостей ...
:: avahi опционально требует qt4: qt4 bindings
:: breeze опционально требует breeze-kde4: Breeze widget style for KDE4 applications
:: crossover опционально требует lib32-fontconfig: Makes it possible to find and use the system's TrueType fonts. This is strongly recommended for office-type applications.
:: crossover опционально требует lib32-v4l-utils: Lets Windows applications access video devices.
:: google-chrome опционально требует kdebase-kdialog: needed for file dialogs in KDE
:: hplip опционально требует python-pyqt4: for running GUI and hp-toolbox
:: libreoffice-still опционально требует pstoedit: translates PostScript and PDF graphics into other vector formats
:: libreoffice-still опционально требует kdelibs: for KDE desktop integration
:: openal опционально требует qt4: alsoft-config GUI Configurator
:: subversion опционально требует kdebase-runtime: for KWallet for auth credentials
:: xdg-utils опционально требует kdebase-runtime: for KDE4 support in xdg-open

Пакеты (101) amarok-2.8.0-8  attica-qt4-0.4.2-3  breeze-kde4-5.5.5-1
             calligra-braindump-2.9.11-2  calligra-filters-2.9.11-2
             calligra-karbon-2.9.11-2  calligra-krita-2.9.11-2
             calligra-libs-2.9.11-2  calligra-plugins-2.9.11-2  cantata-2.0.0-3
             chmlib-0.40-4  clementine-1.2.3-10  digikam-4.14.0-5
             djvulibre-3.5.27-2  gsl-2.1-1  gtkglext-1.2.0-10
             intel-tbb-4.4_20160128-1  k3b-1:2.0.3a-5
             kde-servicemenus-rootactions-2.8.5-3  kdebase-kdepasswd-15.12.2-1
             kdebase-kdialog-15.12.2-1  kdebase-keditbookmarks-15.12.2-1
             kdebase-kfind-15.12.2-1  kdebase-lib-15.12.2-1
             kdebase-runtime-15.12.2-1  kdegraphics-mobipocket-15.12.2-1
             kdegraphics-okular-15.12.2-1  kdelibs-4.14.17-1
             kdenetwork-kget-15.12.2-1  kdepimlibs4-4.14.10-7
             kfilemetadata4-4.14.3-4  kipi-plugins-4.14.0-5  konsolepart4-4.14.3-7
             lensfun-0.3.2-2  lib32-fontconfig-2.11.1-1
             lib32-libdbusmenu-qt-0.9.2-3  lib32-libmng-2.0.3-1
             lib32-libxss-1.2.2-2  lib32-libxv-1.0.10-1  lib32-qt4-4.8.7-4
             lib32-sni-qt-0.2.6-6  lib32-sqlite-3.11.0-1  lib32-v4l-utils-1.6.3-1
             libakonadi-qt4-1.13.0-8  libastro-15.12.2-1  libbaloo4-4.14.3-4
             libdbusmenu-qt4-0.9.3+15.10.20150604-3  libdvbpsi-1:1.3.0-1
             libgpod-0.8.3-4  libkactivities4-4.13.3-3  libkate-0.4.1-5
             libkcddb-15.12.2-1  libkdcraw4-15.08.3-2  libkexiv2_4-15.08.3-2
             libkface4-15.08.3-2  libkgeomap4-15.08.3-2  libkipi4-15.08.3-3
             libksane4-15.08.3-2  libkscreen4-1.0.5-2  libktorrent-1.3.1-4
             liblastfm-1.0.9-2  libmarble4-15.08.3-2  libmusicbrainz5-5.1.0-2
             libmygpo-qt-1.0.8-2  libpgf-6.14.12-3  libqzeitgeist-0.8.0-6
             libspectre-0.2.7-2  libspnav-0.2.3-1  libtar-1.2.20-2  libtiger-0.3.4-4
             marble-data-15.12.2-1  mutagen-1.31-1  opencolorio-1.0.9-4
             opencv-2.4.12.3-1  oxygen-icons-1:5.19.0-1  oxygen-kde4-5.5.5-1
             pangox-compat-0.0.2-2  phonon-qt4-4.8.3-6  plotutils-2.6-7
             polkit-qt4-0.112.0-3  poppler-qt4-0.41.0-1  prison-1.1.1-2
             protobuf-2.6.1-2  pstoedit-3.70-3  pyqt4-common-4.11.4-4
             python-pyqt4-4.11.4-4  python-sip-4.16.9-2  qca-qt4-2.1.1-5
             qimageblitz-0.0.6-5  qjson-0.8.1-5  qt4-gstreamer-1.2.0-2
             qtscriptgenerator-0.2.0-4  qtwebkit-2.3.4-4  sip-4.16.9-2
             skype-4.3.0.37-6  sni-qt-0.2.6-4  strigi-0.7.8-9  taglib-extras-1.0.1-4
             vlc-2.2.2-3  zvbi-0.2.35-1  qt4-4.8.7-7

Будет освобождено:  971,30 MiB

:: Удалить эти пакеты? [Y/n] 
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
Эм, может сначала удалишь весь софт написанный на qt4, а потом уже и сам qt4? К слову, ты пытаешься удалить не софт, а ui framework, который нужен для работы определенного софта и список софта на qt у тебя перед глазами. Это как пытаться удалить библиотеку на которой работает софт, перед удалением самого софта. Благо пакман не дает ломать ОСь и софт таким молодцам.
0
avatar
Так, в этом топике и пишется про, то что ненужное исключить, а выходит что при обновлении я еще и qt5 добавил так зачем это, если появится еще и qt6 то и оно добавится, вопрос зачем лишний софт, при удалении которого у опытного пользователя, еще раз повторюсь
<code>опытного пользователя</code>
и не опытного ломается вся система!
?
Всё возможно, пока не сделан выбор !
0
avatar
Программы написанные на qt ты можешь удалить в любой момент, а qt framework это прослойка при написании кода. Например в C++ нет GUI, поэтому используют framework QT.
0
avatar
А может, мне сразу всю систему удалить?
?
Всё возможно, пока не сделан выбор !
0
avatar
С таким подходом самое то, правда я ни одной системы не видел, чтобы она адекватно работала с поломанными зависимостями.
Из ряда вашей проблемы — я хочу удалить libusb, но вот что-то у меня не получается
[mazix@RedStone ~]$ sudo pacman -Rs libusb
[sudo] пароль для mazix: 
проверка зависимостей...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: ccid: удаление libusb ломает зависимость 'libusb'
:: lib32-libusb: удаление libusb ломает зависимость 'libusb'
:: libcups: удаление libusb ломает зависимость 'libusb'
:: libdc1394: удаление libusb ломает зависимость 'libusb'
:: libgphoto2: удаление libusb ломает зависимость 'libusb'
:: libgusb: удаление libusb ломает зависимость 'libusb'
:: libmtp: удаление libusb ломает зависимость 'libusb'
:: libpcap: удаление libusb ломает зависимость 'libusbx'
:: libusb-compat: удаление libusb ломает зависимость 'libusb'
:: libusbmuxd: удаление libusb ломает зависимость 'libusb'
:: upower: удаление libusb ломает зависимость 'libusb'
:: usb_modeswitch: удаление libusb ломает зависимость 'libusb'
:: usbutils: удаление libusb ломает зависимость 'libusb'
:: xboxdrv: удаление libusb ломает зависимость 'libusb'


Еще не поняли почему qt не удаляется?
Последний раз редактировалось
0
avatar
Потому что его привязали к системе намертво, такого нету ни в Kubuntu ,OpenSUSE ,Linux-Mint Kde ,Mandriva, почему здесь так?
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
Кто такую ересь сказал? загрузите в любую из ОС xboxdrv к примеру, а потом удалите libusb, у вас xboxdrv ни в одной ОС не будет работать вообще. Pacman не дает ломать софт, как раз это правильно. Если нет такой фичи в других ОС, то это печально и в этом нет никаких плюсов. Я посмотрю, как вы запустите VLC хотя бы без phonon-qt5-vlc и phonon-qt в целом. Да и о чем вы говорите? Графика KDE написана на QT, если вы удалите полностью QT из KDE, то оболочка попросту не сможет работать.
0
avatar
Ладно, я все могу понять, а причем тут среда разработки и система, при удалении которого ломается система?
Можете объяснить?
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
Какая среда разработки? Выб хоть в википедии глянули что есть это кутэ если тут ораторы непонятно объясняют ru.wikipedia.org/wiki/Qt
Qt — это библиотеки рисующие ВЕСЬ интерфейс кед. Это все кнопки все окошки все менюшки и все диалоги. За все это прикладное хозяйство отвечает библиотека Qt. Грохаем ее и кедам просто нечем будет рисовать свой интерфейс, а значит и смысла в этих кедах нет (пакетный менеджер поэтому и предлагает удалить все всед за qt к нему относящееся).
И еще раз: система при удалении qt не ломается и сломать ее этим действием невозможно. Ломаная система — это нечто нерабочее, а не нечто без кде.
В моей инсталляции манжаро вообще нет кед, qt правда есть тк пара прог на нем мне надо. Это что означат что у меня все сломано? :D
Последний раз редактировалось
0
avatar
Если удалить qt, то в вашей системе ничего ужасного не случится, просто как уже сказали кеды перестанут работать. Qt — базис для кед. И совершенно такие же кеды в перечисленных выше дистрах (за исключением патчей разве чтоли).
Можно еще в пример винду привести, там фреймворком для отрисовки элементов интерфейса является WinAPI. Вот его точно выкорчевать нельзя вообще никак. Тут у вас выбор даже есть: использовать софт писанный на qt или использовать другой удалив все с qt связанное
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.