Ядро & Оборудование
   174

ATI - проблема с переходом на open-source-drivee

в «конфигугация оборудования» нажимаю кнопку auto install open-source-drivee

выдает ошибку:
Waiting for user input...
Starting
> Using config 'video-ati' for device: 0000:02:00.0 (0300:1002:673e) Display controller ATI Technologies Inc Barts LE [Radeon HD 6790]
Error: config 'video-ati' conflicts with config(s): video-catalyst


Готово...


пробовал так:
sudo pacman -S xf86-video-ati
разрешение зависимостей...
проверка конфликтов...
:: xf86-video-ati и catalyst-server конфликтуют (xorg-server). Удалить catalyst-server? [y/N] y
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: sddm: удаление catalyst-server ломает зависимость 'xorg-server'

как будет сделать правильно?

10 комментариев

avatar
Прочитай тут Решение Проблем xf86-video-ati
Последний раз редактировалось
0
avatar
Можно залогиниться в tty и там поставить нормальный xorg-server. Catalyst-server должен будет быть удален в процессе разрешения конфликта зависимостей. Потом установить свободный драйвер.
Последний раз редактировалось
+1
avatar
Сделал так,
sudo su
pacman -S xorg libgl ati-dri xf86-video-ati
В результате при перезагрузке видеосервер не стартует
Xorg-configure
Выполняется с ошибками
xorg.conf файла нет
Последний раз редактировалось
0
avatar
В результате при перезагрузке видеосервер не стартует
startx?
Xorg-configure
Выполняется с ошибками
С какими?
xorg.conf файла нет
Его уже давно нет. Вместо него каталог /etc/X11/xorg.conf.d/.
sudo mhwd -a pci free 0300
сделайте.
Последний раз редактировалось
0
avatar
Startx
Fatal server error:
(EE) no screens found(EE)
(EE)
(EE)Server terminated with error (1). Closing log file.
Xinit: giving up
Xinit: unable to connect to X server: conection refused
Xinit: server error

Xorg -configure:
(++)using config file "/root/xorg.conf.new"
(==)using config derectory "/usr/share/X11/xorg.conf.d"
(EE)
(EE) backtrce:
(EE) 0: /usr/lib/xorg-server/Xorg (0sLookupColor+0x139) […
(EE) /usr/lib/libpthread.so.0 (funlockfile+0x50)[…
(EE) 2:?(?+0x50)[0x50]
(EE)
(EE) segmentation fault at adress 0x0
(EE) server error:
(EE) Caught signal 11 (segmentation fault). Server aborting
(EE)

sudo mhwd -a pci free 0300;
>using config 'video-ati' for device: 0000:02:00.0 (0300:1002:673e) dicplay controller ATI Technologies inc Barts LE [radeon HD 6790]
ERROR: config 'video-ati' conflicts with config(s): video-catalist
0
avatar
ERROR: config 'video-ati' conflicts with config(s): video-catalist

Так убейте конфиги котоглиста.
Последний раз редактировалось
0
avatar
<code>Так убейте конфиги котоглиста</code>
Как это сделать?
0
avatar
Доломал… Висит на загрузке
Последняя строчка:
<code>[ OK ] started TLP system startup/shutdown.
</code>
А выше были три ошибки, одинаковые…
<code>[FAILED] Failed to start Load Kernel Modules</code>
Придётся наверное переустанавливать,
а хотелось разобраться как исправлять такие ошибки…
0
avatar
Можно попробовать загрузиться в ранлевел 1: в GRUB нажимаем «Е» и редактируем пункт загрузки: добавляем в конце строки, начинающейся с linux, single либо 1.
наконец, можно взять лайвсд и поставить в него mhwd-chroot.
И вот топик со схожей проблемой с англоязычного форума manjaro.
Еще в /etc/modules-load.d/ гляньте.
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.