Manjaro KDE Edition
   1368

intel_set_pch_fifo_underrun_reporting

при загрузке Manjaro KDE 15.12 (и других дистибутивов Линукс, как на KDE так и на Xfce) появляется ошибка intel_set_pch_fifo_underrun_reporting [i915]
нашёл только одну статью 01.org/linuxgraphics/gfx-docs/drm/API-intel-set-pch-fifo-underrun-reporting.html
но из неё не очень понятно что нужно делать.

20 комментариев

avatar
Покажите вывод — cat /etc/mkinitcpio.conf
0
avatar
# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run. Advanced users may wish to specify all system modules
# in this array. For instance:
# MODULES=«piix ide_disk reiserfs»
MODULES=""

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image. This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way. This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file. The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added. Run 'mkinitcpio -H ' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
## This setup specifies all modules in the MODULES setting above.
## No raid, lvm2, or encrypted root is needed.
# HOOKS=«base»
#
## This setup will autodetect all modules for your system and should
## work as a sane default
# HOOKS=«base udev autodetect block filesystems»
#
## This setup will generate a 'full' image which supports most systems.
## No autodetection is done.
# HOOKS=«base udev block filesystems»
#
## This setup assembles a pata mdadm array with an encrypted root FS.
## Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
# HOOKS=«base udev block mdadm encrypt filesystems»
#
## This setup loads an lvm2 volume group on a usb device.
# HOOKS=«base udev block lvm2 filesystems»
#
## NOTE: If you have /usr on a separate partition, you MUST include the
# usr, fsck and shutdown hooks.
HOOKS=«base udev autodetect modconf block keyboard keymap plymouth resume filesystems fsck»

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
COMPRESSION=«gzip»
COMPRESSION=«bzip2»
COMPRESSION=«lzma»
COMPRESSION=«xz»
COMPRESSION=«lzop»
COMPRESSION=«lz4»

# COMPRESSION_OPTIONS
# Additional options for the compressor
COMPRESSION_OPTIONS=""
0
avatar
Попробуй В секцию MODULES вставь i915, должно быть так — MODULES=«i915» ( i915 — должно быть заключено в двойные кавычки) и выполнить sudo mkinitcpio -p linux
Последний раз редактировалось
0
avatar
Или поменять ядро?
+1
avatar
у меня MODULES=«i915» в /etc/mkinitcpio.conf и ядро 4.4.0-4-MANJARO и все равно такая ошибка вылезает при загрузке

Вот здесь говорят, что на ядре 4.3 ошибки нет
Последний раз редактировалось
?
ТехноДжем — вкус высоких технологий :)
0
avatar
И правильно советуют, т.к. intel_set_pch_fifo_underrun_reporting [i915] это предупреждение ядра об ошибке при загрузке.
0
avatar
Попробовать linux-lts?
0
avatar
hotdogmf
А что за карта, покажи вывод — lspci -k | grep VGA -A2
Последний раз редактировалось
0
avatar
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Subsystem: Acer Incorporated [ALI] Device 0647
Kernel driver in use: i915
— 01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev ff)
Kernel modules: nouveau
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe (rev 10)
0
avatar
Читайте, пробуйте — тыц
0
avatar
Спасибо!
Правда тема старая, многих пакетов уже нет.
Но стало понятно, что ошибка возникает из-за конфликтов дискретной видеокарты с Nvidia, причём серии М.
тема связана с manjaro.ru/blog/manjaro-xfce-edition/nvidia-error.html
Позже попробую добавить nouveau в blacklist.
0
avatar
Замена ядра на 4.3 не помогло.
Скорее всего конфликт возникает из-за драйверов которые выбрал сам Manjaro. Таже Ситуация и у Xubuntu и Kubuntu.
Последний раз редактировалось
0
avatar
На сайте Nvidia последние драйвера 352,63
www.nvidia.ru/download/driverResults.aspx/95292/ru
в системе значатся 304 и 340
0
avatar
Убери plymouth из HOOKS по default его там не должно быть.
И-sudo mkinitcpio -p linux
0
avatar
проблема в Bumblebee
на wiki.archlinux.org/index.php/Bumblebee_(Русский) указано что сейчас переключение между дискретной и интегрированной видеокартой автоматически не работает. В отличии от стационарных компьютеров, у ноутбуков Bumblebee занимается переключением видеокарт для экономии питания в режимах от сети и от батареи.
0
avatar
Позже попробую:

Использование Nvidia
Для того, чтобы Bumblebee использовал проприетарные модули Nvidia, вам нужно сначала выгрузить модуль ядра Nouveau. Для этого запустите в терминале:
# rmmod nouveau
Добавьте в /etc/modprobe.d/modprobe.conf строки, выключающие Nouveau при загрузке:
/etc/modprobe.d/modprobe.conf
blacklist nouveau
Теперь загрузите модуль Nvidia:
# modprobe nvidia
Если вы хотите, чтобы модуль был загружен при старте, добавьте Nvidia в секцию MODULES в ваш файл /etc/rc.conf:
MODULES=(… nvidia ...)
0
avatar
Для тех у кого приложения «не видят» видеокарту нужно:
Для запуска приложений, использующих графическую карту:
$ optirun [опции] <приложение> [параметры приложения]
Для просмотра списка опций optirun запустите:
$ optirun --help
Если вам нужно запустить 32-битное приложение на 64-битной системе, вы можете установить пакет библиотек 'lib32'.
Последний раз редактировалось
0
avatar
Хотелось бы узнать по этому вопросу, именно каких — Для тех у кого приложения «не видят» видеокарту нужно
0
avatar
К примеру программа Blender 3D
В настройках можно выбирать с помощью чего проводить рендеринг (CPU или GPU)
Если запускать Blender по умолчанию — то программа GPU не видит (в меню оно отсутствует). Если запускать из терминала через optirun всё ОК.
0
avatar
poly — абсолютно прав!
После замены ядра на 3.14.58-1 (LTS)
Ошибка при загрузке исчезла.

Будем надеяться что это пофиксят в будущем)
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.