Manjaro KDE Edition
   313

Не могу решить проблему с libicu

Привет.
Не так давно обнаружил, что некоторые программы (например, Spotify и Atom) требуют libicuuc.so.58. Попробовал обновить все пакеты — после ребута не запустилось KDE. Покопался, откатил несколько пакетов, в конце концов KDE запустилось, но намертво зависло при подключении к wifi (через usb-адаптер), в итоге просто переустановил систему. Сейчас опять нужно запустить прогу, которая просит libicu58. Это вообще реально?

Manjaro 16.10.3 64-bit

6 комментариев

avatar
<code>yaourt -S icu</code>
?

clock for blog
0
avatar
Если бы все было так просто… Нет, это не сработало. KDE увидело 58 версию, а ему нужна 57. Обновлять KDE — не вариант, в новой версии с вайфаем фигня.
0
avatar
yaourt -S icu57
Последний раз редактировалось
0
avatar
Так спотифаю-то нужен icu58. То есть работать может что-то одно — либо Spotify, либо KDE.
Ладно, поживу пока так. Может быть, найдётся какое-то решение.
0
avatar
sudo ln -s /usr/lib/libicuuc.so.58 /usr/lib/libicuuc.so.57
+3
avatar
Ух ты, сработало. Спасибо!
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.