Manjaro KDE Edition
   262

Ошибка GRAB при установке ядра 4.11

Решил обновить ядро на с 4.10 на 4.11 через «Параметры системы — Ядро». Ядро скачалось, но при его установке вылезла ошибка:

(2/3) Updating Grub-Bootmenu
/etc/default/grub: line 3: $'laptop\nGRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=b5584049-ade0-4e90-b53a-d7464e69e59d"\nGRUB_CMDLINE_LINUX=""\n\n# If you want to enable the save default function, uncomment the following\n# line, and set GRUB_DEFAULT to saved.\nGRUB_SAVEDEFAULT=true\n\n# Preload both GPT and MBR modules so that they are not missed\nGRUB_PRELOAD_MODULES="part_gpt part_msdos"\n\n# Uncomment to enable Hidden Menu, and optionally hide the timeout count\nGRUB_HIDDEN_TIMEOUT=5\nGRUB_HIDDEN_TIMEOUT_QUIET=true\n\n# Uncomment to use basic console\nGRUB_TERMINAL_INPUT=console\n\n# Uncomment to disable graphical terminal\nGRUB_TERMINAL_OUTPUT=console\n\n# The resolution used on graphical terminal\n# note that you can use only modes which your graphic card supports via VBE\n# you can see them in real GRUB with the command `vbeinfo': command not found
(3/3) Arming ConditionNeedsUpdate...
error: command failed to execute correctly
Готово...

Как я понял граб не смог обновиться. Как ему помочь обновиться :) и загрузиться с 4.11?

3 комментария

avatar
command `vbeinfo': command not found
Что у Вас в /etc/default/grub?
Последний раз редактировалось
0
avatar
Вот, всё стандартно, кроме названия компа:
<code>
GRUB_DEFAULT=saved
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR='My laptop'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=b5584049-ade0-4e90-b53a-d7464e69e59d"
GRUB_CMDLINE_LINUX=""
GRUB_SAVEDEFAULT=true
GRUB_PRELOAD_MODULES="part_gpt part_msdos"
GRUB_TERMINAL_INPUT=console
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_DISABLE_RECOVERY=true
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"
GRUB_BACKGROUND="/usr/share/grub/background.png"
</code>
0
avatar
Всё, снимаю вопрос — ошибка вываливалась из-за названия компа «My Laptop» — пробелы нельзя. Оставил просто лэптоп, удалил ядро в параметрах, поставил заново, перезагрузился, и пишу этот текст уже с 4.11

В любом случае, спасибо!
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.