Manjaro KDE Edition
   331

Отвалилась база Амарока

После последнего обновления (ветка testing) при запуске Амарока появляется сообщение:

The amarok database reported the following errors:
MySQLe something failed! on library initialization failed, return code 1
In most cases you will need to resolve these errors before Amarok will run properly.

И всё, коллекция не работает, пропали все рейтинги и стастистика. Что делать?

5 комментариев

avatar
Кароч, причина проблемы оказалась в обновлении libssh c 0.8.2 до 0.8.3, охренеть просто, при чём тут libssh, казалось бы? Откатился на предыдущую версию и Амарок нормально заработал.

Можно как-нибудь заблокировать этот пакет, чтобы он не обновлялся впредь?
Последний раз редактировалось
0
avatar
добавить в игнор в файле /etc/pacman.conf прописав его в IgnorePkg = libssh
либо в терминале:
sudo pacman -S --ignore libssh
Последний раз редактировалось
+1
avatar
проблема в libssh, это круто.
Вопрос: как ты откатывал версию?
Через /var/cache/pacman/pkg или со старых зеркал брал?
У меня просто система недавно переустановленная, до этого обновлений не делал == пакета предыдущей версии нет.
Если вдруг нашёл ресурс кинь плз ссылку, а ещё лучше архив libssh-0.8.2 :-)
0
avatar
С какого-то зеркала взял.

yadi.sk/d/QrNpm0xi6xYEiQ
+1
avatar
Я, кстати, вообще вынес Амарок со всеми недолговечными зависимостями в отдельный каталог, и запускаю его скриптом. Удалил из системы все kde4-пакеты, и могу теперь обновляться сколько угодно, Амарок уже не отвалится.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.