Manjaro KDE Edition
   509

портится шрифт в процессе загрузки

С некоторых пор, после очередного чудного обновления у меня в Manjaro Linux пошли глюки на этапе загрузки после меню grub2 и до логина sddm.

Grub2 меню стало отображаться только на одном мониторе, хотя раньше отображалось на обоих.

У меня отключена дурацкая заставка plymouth, чтобы видеть процесс загрузки. Но сейчас я вижу вместо букв вот это:
Manjaro KDE Edition: портится шрифт в процессе загрузки
и так до тех пор, пока в процессе загрузки экран не перерисуется и тогда шрифт возвращается.

Что это такое и как победить? На других ПК с Manjaro такого нет.

9 комментариев

avatar
дурацкая заставка plymouth
Поддерживаю. Совершенно лишняя сущность, лишенная какого бы то ни было смысла.
Посмотрите в /etc/vconsole.conf.
0
avatar
А что там смотреть?

Там только
KEYMAP=us
FONT=
FONT_MAP=
0
avatar
Добавьте
LOCALE="ru_RU.UTF-8" 

и еще можно четко указать шрифт
FONT="UniCyr_8x16" 
Последний раз редактировалось
0
avatar
Не помогло. Проблема вообще возникает до чтения этого файла. Сразу после груб2.
0
avatar
Это происки системды. Как с этим борются можно прочесть тут.
Последний раз редактировалось
0
avatar
Прочитал. понял так, что видеодрайвер стал грузиться не сразу а где-то в середине загрузки. Но что делать не понял, поясните пжл.
0
avatar
Можно включить early KMS. Делается это следующим образом:
открывавем /etc/mkinitcpio.conf и в строку MODULES вносим соответствующий видеокарте. Читать про это тут. Пересобираем образы ядер либо тупо переустанавливаем ядра, после чего все работает как надо.
    Еще можно разрулить зависимости мещду юнитами сустемды самостоятельно. Или использовать совсем уж грязный хак и добавить в GRUB к опциям язра quiet, заткнув тем самым системе рот. И даже такой вариант как воткнуть openrc в качестве инита.
Последний раз редактировалось
0
avatar
Спасибо, 1й пункт я сделал, конфиг отредактировал, но что делать дальше, как я не знаю, и из доков не понял — каждая статья отсылает к следующей.
$ mkinitcpio -p linux
/usr/bin/mkinitcpio: строка 263: /etc/mkinitcpio.d/linux.preset: Нет такого файла или каталога
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux.preset'

И что тут дальше делать я не знаю…
Последний раз редактировалось
0
avatar
Выполни:
$ mkinitcpio -P
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.