Manjaro KDE Edition
   297

[решено] Проблема с загрузкой: Xorg dumped core

Описание проблемы:

На ядре 4.9.12-1 после обновления возникает проблема во время загрузки: экран гаснет и уже не загорается.
Проблема возникает не каждую загрузку, иногда загружается нормально. Выявить закономерность не удается.

В системном журнале забито все такими сообщениями:

Кусочек журнала
фев 28 19:58:41 manjaro systemd-coredump[674]: Process 662 (Xorg) of user 0 dumped core.
Stack trace of thread 662:
0 0x00007ff1d818b04f raise (libc.so.6)
1 0x00007ff1d818c47a abort (libc.so.6)
2 0x00000000005a108e OsAbort (Xorg)
3 0x000000000047beac ddxGiveUp (Xorg)
4 0x00000000005a6b42 n/a (Xorg)
5 0x00000000005a794d FatalError (Xorg)
6 0x000000000059e9be n/a (Xorg)
7 0x00007ff1d818b0b0 __restore_rt (libc.so.6)
8 0x00007ff1d4da2bf2 swlDrmFreeSurfaces (fglrx_drv.so)
9 0x00007ff1d4d67c1d xdl_xs117_atiddxDriCloseScreen (fglrx_drv.so)
10 0x00007ff1d4d672b8 xdl_xs117_atiddxDriScreenInit (fglrx_drv.so)
11 0x00007ff1d4d60dcb xdl_xs117_atiddxScreenInit (fglrx_drv.so)
12 0x00000000004394b1 AddScreen (Xorg)
13 0x000000000047d5b2 InitOutput (Xorg)
14 0x000000000043d01c n/a (Xorg)
15 0x00007ff1d8178291 __libc_start_main (libc.so.6)
16 0x00000000004272ca _start (Xorg)
фев 28 19:58:43 manjaro systemd-coredump[695]: Process 679 (Xorg) of user 0 dumped core.
Stack trace of thread 679:
0 0x00007f942102f04f raise (libc.so.6)
1 0x00007f942103047a abort (libc.so.6)
2 0x00000000005a108e OsAbort (Xorg)
3 0x000000000047beac ddxGiveUp (Xorg)
4 0x00000000005a6b42 n/a (Xorg)
5 0x00000000005a794d FatalError (Xorg)
6 0x000000000059e9be n/a (Xorg)
7 0x00007f942102f0b0 __restore_rt (libc.so.6)
8 0x00007f941dc46bf2 swlDrmFreeSurfaces (fglrx_drv.so)
9 0x00007f941dc0bc1d xdl_xs117_atiddxDriCloseScreen (fglrx_drv.so)
10 0x00007f941dc0b2b8 xdl_xs117_atiddxDriScreenInit (fglrx_drv.so)
11 0x00007f941dc04dcb xdl_xs117_atiddxScreenInit (fglrx_drv.so)
12 0x00000000004394b1 AddScreen (Xorg)
13 0x000000000047d5b2 InitOutput (Xorg)
14 0x000000000043d01c n/a (Xorg)
15 0x00007f942101c291 __libc_start_main (libc.so.6)
16 0x00000000004272ca _start (Xorg)
фев 28 19:58:43 manjaro sddm-greeter[693]: QXcbConnection: Could not connect to display
фев 28 19:58:43 manjaro sddm-greeter[701]: QXcbConnection: Could not connect to display
фев 28 19:58:44 manjaro systemd-coredump[711]: Process 693 (sddm-greeter) of user 995 dumped core.


Железо: AMD Radeon R5
Catalyst

Работающее (вроде бы) решение:
1. nomodeset в строку GRUB_CMDLINE_LINUX_DEFAULT в /etc/default/grub (помним про sudo grub-update)
После этого загрузка вроде идёт без проблем, но в журнале ряд сообщений, центральное из которых:
[drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

поэтому добавил amdgpu модуль в black list:
2.
su -c 'echo "blacklist amdgpu" > /etc/modprobe.d/amdgpu.conf'

Подозреваю, что и второе действие без первого сработало бы, но экспериментировать лень.

P.S. проблема проявлялась без закономерности, есть вероятность что это не решение, а просто совпадение. Если возобновится, отпишусь.
Спасибо всем, кто помогал советами!

9 комментариев

avatar
Если стоит kde, то по умолчанию выключение системы вроде как через systemctl происходит. Попробуй в консоли
sudo poweroff
либо
sudo systemctl poweroff
Есть разница?
0
avatar
Идея интересная, спасибо! Пока проблема перестала воспроизводиться (см. UPD в топике), если возникнет опробую!
В systemd можно без sudo, кстати )
0
avatar
Проблема всё же возникает. Попробовал sudo shutdown now, эффекта нет :((
0
avatar
экран гаснет и уже не загорается.
в какой момент? попробуйте физически вытащить провод видео и вставить обратно. (DVI или D-Sub ?)

если гаснет «на загрузке» (до sddm) — ctrl+alt+F2(3,4) и обратно ctrl+alt+F1
0
avatar
В момент загрузки до приветствия sddm есть момент, когда экран в норме ненадолго гаснет (видимо меняется видеорежим). При ошибке он просто больше не загорается.
Выдернуть не могу, это ноут))

Переключение консоли по ctrl+alt+Fx не работает.
Последний раз редактировалось
0
avatar
до приветствия sddm есть момент, когда экран в норме ненадолго гаснет
да. недавно видел такое на старой нвидии+4.9. дрова опенсурс.
помогало ctrl+alt+Fx

попробуйте посмотреть/написать на
https://bugs.manjaro.org/
https://bugs.archlinux.org/

(как вариант «посмотреть» в testing)

upd. в теории…
Your text to link...
radeon.dpm=0
может при смене режима он роняет иксы.
Последний раз редактировалось
0
avatar
Простите, с английским не очень, не разобрался в какой конфиг нужно это прописать?
0
avatar
вам надо "...add the parameter radeon.dpm=0 to the kernel parameters.
0
avatar
Не помогло :(
Добавил nomodeset, пару раз загрузился нормально, но не факт что проблема пофикшена, наблюдаю.

Кстати, на 4.10 ядре вообще не загружается система, выдает какие-то ошибки чтения/записи файловой системы. Странно как-то.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.