Manjaro KDE Edition
   2428

РЕШЕНО teamviewer 13 beta

Приветствую всех. Установил новый teamviewer-beta 13.0.6634-1 посмотреть как работает запускаю вроде запускается, но не подключается к интернету пишет не готов проверьте подключение, в терминале запускаю пишет
[useruser-pc ~]$ /opt/teamviewer/tv_bin/script/teamviewer

Init…
CheckCPU: SSE2 support: yes
Checking setup…
Launching TeamViewer…
Starting network process (no daemon)
Network process already started (or error)
Launching TeamViewer GUI…

Походу не находит Network process и его демон. Ни кто с таким не сталкивался?

16 комментариев

avatar
Забыл добавить рабочий стол kde и сейчас попробовал скачал с официального сайта распаковал запустил, первый раз подключилось к интернету, а последующий раз уже не подключаеться к интернету.
0
avatar
а вот это делали?
sudo systemctl enable teamviewerd.service

sudo systemctl start teamviewerd.service
Последний раз редактировалось
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
+1
avatar
НЕ это в предыдущих версиях нужно было, а в этой разобрался, удалил версию из аура и скачал с официального сайта последнюю версию, распаковал в хом папку и через double commander от рута изменил атрибуты этой папки то есть дал полные права на запись чтение пока так, теперь все подключается.
+1
avatar
НЕ это в предыдущих версиях нужно было
нет. Вам написали правильно. и запускайте из меню kde
0
avatar
Так программа сама запускается, только к сети не подключалась зачем мне его сервисы запускать если они и так запущены?
0
avatar
ну, я давал совет, потому что сам имел такую же проблему на стационарнике и буке и эти 2 команды мою проблему решили. =)
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
0
avatar
Понятно будем про бывать, спасибо.
0
avatar
Сталкивался с той же проблемой вот на днях, но на XFCE, по сети подключается, а по интернету нет (не готов), решение не нашёл — нужно было срочно отдавать компьютер, пришлось поставить 12 версию, которая кстати запустилась лишь после команд указанных AlexLuckbox. На Debian9 TeamViewer 13 встал и работает без лишних движений. Подскажите если найдёте решение — TeamViewer 13 на qt5 нравиться больше, чем 12 версия под wine.
0
avatar
Вот я про это выше и писал эти комманды для версий 11 и 12, а для 13 я написал выше, что я сделал и теперь она работает, удалил версию из аура и скачал с официального сайта последнюю версию, распаковал в хом папку и через double commander от рута изменил атрибуты этой папки то есть дал полные права на запись чтение пока так, теперь все подключается.Видимо ей не хватает прав для полноценной работы. Пока я эти комманды не пробывал применять к 13 версии, работает и ладно.
Последний раз редактировалось
0
avatar
только что проверил на чистой 17.1.2 cinnamon. сразу, после установки, такая же ошибка, но после вышеупомянутых команд всё заработало. могу на виртуалку поставь xfce и поэкспериментировать.
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
0
avatar
Сейчас поставил по новой из аура и ввел команды, которые ты подсказал и тоже работает благодарю, но опять же согласись если бы не кто мне не подсказал, то временное решение я нашел.
0
avatar
Если что-то из АУРа не работает или не устанавливается, полезно посетить страницу пакета на АУРе.
Как правило решение проблемы известно и искать его нужно именно там, в комментариях.
aur.archlinux.org/packages/teamviewer-beta
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Ну извини не все в английском спецы, можно как то и здесь по русски продублировать. А если на русскоязычном форуме, то до сих пор не решили — archlinux.org.ru/forum/topic/17886/?page=10post-198737
Последний раз редактировалось
0
avatar
Чтобы поставить в браузер плагин онлайн-перевода спецом быть не нужно. Не думаю что на русскоязычных ресурсах решение появится быстрее чем на англоязычных — просто в силу того что англофонов в разы больше. А как решат где-то — решение и в коментах на ауре появится, а затем и в локальных форумах.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Бинарник teamviewer-beta из репа archlinuxcn у меня установился и запустился без лишних танцев с бубном, хотя в конце установки предупреждал, что перед первым запуском нужно выполнить
systemctl enable teamviewerd
Последний раз редактировалось
0
avatar
Итак, проблема: По какой-то неясной причине ТВ не стартует адекватно под арчподобными дистрибутивами (у меня арч).
Для запуска требует включить свою службу, которая должна быть еще и в автостарте. И даже это не помогает.
Мое решение на костыле (скрипте) — служба запускается и выгружается по закрытию ТВ. Можно сделать ярлык запуска для скрипта и положить его в ~/.local/share/applications/ — тогда он будет доступен из главного меню. Кому будет интересно, пишите письма ))
====
Решение:
Скрипт запуска проверен на 13 версии и бета — включительно.
Скрипт кидаем в удобное место и даем права на выполнение. Для работы ТВ нужны права рут: вряд ли это кого то должно смутить, учитывая предусмотренную разработчиками автозапуск службы в дефолте ))
Собственно, сам скрипт запуска:
###############
#!/bin/sh
sudo systemctl start teamviewerd #запускает службу
sudo /opt/teamviewer/tv_bin/TeamViewer #запускает приложение
sudo systemctl stop teamviewerd #останавливает службу
echo «bye»
##############
Все гениальное — просто.
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.