Manjaro XFCE Edition
   434

Как установить среду программирования(с++)?

Привет, котятки: з
Сильно не ругайтесь(но в гугле похожих тем нет). Собственно главный вопрос это установить хоть какую-нибудь среду программирования, чтобы там поддерживался С++.
Я нашла инструкцию для Arch, но это ж не то) На официальных страницах некоторых сред(Kdevelop IDE, Code::Blocks, на NetBeans вообще нет ни Arch, ни Manjaro).
Еще установку Kdevelop IDE через терминал, вылезало что у вас нет доступа root, через sudo выходило что неизвестная команда. Я мало времени на Manjaro, так что меня можно простить....)

17 комментариев

avatar
Я нашла инструкцию для Arch, но это ж не то)
то)
sudo pacman -S kdevelop codeblocks netbeans
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Попробую)
0
avatar
sudo pacman -S qtcreator
sudo pacman -S codeblocks
и другие.
Также можно просто скачать CLion www.jetbrains.com/clion/download/#section=linux и распаковать в домашнюю папку
0
avatar
CLion можно и через AUR поставить.
0
avatar
[lina@lina-pc ~]$ sudo pacman -S netbeans
предупреждение: database file for 'core' does not exist (use '-Sy' to download)
предупреждение: database file for 'extra' does not exist (use '-Sy' to download)
предупреждение: database file for 'community' does not exist (use '-Sy' to download)
предупреждение: database file for 'multilib' does not exist (use '-Sy' to download)
ошибка: не найдена цель: netbeans
[lina@lina-pc ~]$

Как-то так…
0
avatar
Не упорствуйте в своём заблуждении о «нестабильности арча» и «обновления могут сломать систему». Пользуйтесь утилитой «Установка и удаление программ» (она же Pamac). Её специально для начинающих написали, в терминале через sudo Вы сломаете систему с гораздо большей вероятностью.
И, пожалуйста, если система сообщает что нуждается в обновлении- не спорьте с нею, обновитесь.
Иначе зачем Вам вообще роллинговая система?
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Еще установку Kdevelop IDE через терминал, вылезало что у вас нет доступа root, через sudo выходило что неизвестная команда.
А здесь желательно разобраться, что за команда такая?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Открываешь Pamac, ищешь там нужный пакет, нажимаешь «Установить»
0
avatar
Я знаю только про «Установка и удаление программ», там ещё разные репозитории. Везде написано «ничего не найдено».
У меня Manjaro xfce 18.0 — в «Обновления» я ничего не устанавливала, ибо боюсь что система рухнет, всё-таки стабильность Arch…
0
avatar
А Вы не бойтесь. Во-первых, нестабильность Арча сильно преувеличена. Во-вторых, это не Арч
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Я знаю только про «Установка и удаление программ»
Это оно и есть.

Везде написано «ничего не найдено»
Вы что-то делаете не так. Для начала, обновите кэш пакетов (кнопка-бутерброд справа, пункт «Обновить базы» или как-то так)
У меня Manjaro xfce 18.0 — в «Обновления» я ничего не устанавливала, ибо боюсь что система рухнет, всё-таки стабильность Arch
Установить конкретный дистрибутив, чтобы потом бояться обновить его — это что-то с чем-то XD Обновите систему, потом ставьте нужный пакет. Арч к Манджаро имеет весьма отдалённое отношение.
0
avatar
Чтобы не быть голословным, вот kdevelop:



вот code::blocks:

0
avatar
И ещё anjuta
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
И Qt Creator есть ещё
0
avatar
Geany туда же. В репах есть, легковесно.
Последний раз редактировалось
0
avatar
Нужно было «Обновить базы», уже скачала code::blocks. Спасибо
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.