Manjaro XFCE Edition
   439

Manjaro 17.1.1 Snap acestreamplayer

В манжаро 17.03 ставил:sudo pacman -S snapd>sudo systemctl enable --now snapd.socket>sudo snap install acestreamplayer всё нармально запускалось.После чистой установки манжаро 17.1.1 acestreamplayer через снап ставится но не запускается.Что делать может кто сталкивался???

15 комментариев

avatar
что говорит
snap run hello

?
скорее всего вам сюда
приблизительно опишу порядок действий:
1. отмонтируем ядро снап
sudo umount /snap/core/2381

чтобы узнать какое у вас ядро, воспользуйтесь командой
ls /snap/core/

2. удаляем ядро и hello:
sudo snap remove core hello

3. устанавливаем hello, ядро подтянется автоматом:
sudo snap install hello

4. перезапуск snapd.socket:
systemctl restart snapd.socket

5. проверяем:
snap run hello
Последний раз редактировалось
?

clock for blog
0
avatar
snap run hello
cannot locate the core or legacy core snap (current symlink missing?): No such file or directory
0
avatar
Была такая же проблема.Поставил snapd из AUR, все заработало.
0
avatar
Поставил snapd из AUR
Всё так-же в меню acestreamplayer есть но не запускается
0
avatar
аналогичная проблема, только у меня после обновления до 17.1.1 acestreamplayer отказался работать.
ЗЫ acestream отвалился на 3-х DE — KDE, Cinnamon, MATE.
Последний раз редактировалось
0
avatar
в общем пока сработало только полное удаление snap пакета и установка acestream-engine из оф.реп.
0
avatar
Что за «оф.реп..».Прошу ответить так-как сижу на винде и не могу перейти обратно на манжаро только из-за айсрима.
0
avatar
извиняюсь за сокращения, из официальных репозиториев устанавливается acestream-engine и в любом браузере можно смотреть торрент тв. разумеется предварительно запустив клиент в консоли acestreamengine --client-console. полностью собирать весь пакет, который, кстати, есть в AUR, не советую, слишком долго и не увенчается успехом.
Последний раз редактировалось
0
avatar
Полностью удаляйте acestreamplayer и snapd, в ArchWiki написано как.Ставьте snapd 2.30.4 из AUR.Запускайте демон.На KDE MINIMAL 17.1.1 все работает.Или на чистую 17.1.1.Еще поставил пакет snapd-xdg-open-git из AUR, чтоб плеер открывался из браузера.
0
avatar
sudo yaourt -S snapd
разрешение зависимостей…
проверка конфликтов…
Пакеты (2) squashfs-tools-4.3-4 snapd-2.30-1
Будет загружено: 10,31 MiB
Будет установлено: 45,16 MiB
:: Приступить к установке? [Y/n]
0
avatar
В OCTOPI в AUR версия 2.30-4.Обновите AUR.
0
avatar
sudo pacman -Syu && sudo yaourt -Syu
Тоже самое.
0
avatar
пробуйте сейчас удалить полностью snap и установить новый 2.30-3. после переустановите acestream. у меня все заработало на всех DE.

umount $(mount | grep snap | awk '{print $3}')
rm -rf /var/lib/snapd
rm -rf /snap
find /etc/systemd/system -name "snap-*.mount" -delete
find /etc/systemd/system -name "snap.*.service" -delete
find /etc/systemd/system/multi-user.target.wants -name "snap-*.mount" -delete
find /etc/systemd/system/multi-user.target.wants -name "snap.*.service" -delete

разумеется все с sudo. ну а дальше все, как и раньше.
Последний раз редактировалось
0
avatar
sudo yaourt -S snapd
предупреждение: откат версии пакета snapd (2.30-4 => 2.30-1)
Такую штуку рисует.Видать удалили пакет из AUR.
0
avatar
Проблема решилась сама «новым обновлением».
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.