Manjaro XFCE Edition
   636

Не работает Wi-Fi. Помогите починить.

Manjaro XFCE x64 установлена на настольный компьютер. С момента установки к компьютеру был подключен USB-адаптер TL-WN822N на чипе rtl8192cu.
Сразу после установки, адаптер работал не очень хорошо: уровень сигнала был невысоким, связь с интернетом часто прерывалась. Знакомый гуру посоветовал поставить патченный драйвер 8192cu-dkms. С ним картина резко изменилась: уровень сигнала вырос до максимального, связь перестала прерываться.
После очередного обновления системы, беспроводной интерфейс упал, и больше не поднимается:
$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether f0:79:59:60:5b:15 brd ff:ff:ff:ff:ff:ff
3: enp0s29u1u1: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether c0:4a:00:1c:74:c0 brd ff:ff:ff:ff:ff:ff

Команда
$ sudo ip link set up enp0s29u1u1
тоже не помогает.
Пока работаю по кабелю.

Как починить интерфейс?

Дополнение: dmesg -w постоянно пишет эту строку:
[23380.567594] IPv6: ADDRCONF(NETDEV_UP): enp0s26u1u1: link is not ready

15 комментариев

avatar
Вы читали это
?
Всё возможно, пока не сделан выбор !
0
avatar
По обеим указанным там ссылкам интерфейс поднимается по ip link set up. В моём случае даже этого не происходит.
0
avatar
А какое ядро у вас?
uname -a   

Вот здесь ,здесь и здесь почитай
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
<code>$ uname -a  
Linux oleg-pc 4.4.28-2-MANJARO <a class="inline-tag" href="https://manjaro.ru/tag/1/">1</a> SMP PREEMPT Sun Oct 30 10:28:10 UTC 2016 x86_64 GNU/Linux
</code>
0
avatar
Вот здесь почитайте комментарии ,здесь и здесь почитай
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
+1
avatar
Добавил строчку в NetworkManager.conf, как сказано в комментарии по первой ссылке. Перезагрузился. Светодиод на устройстве замигал постоянно. В апплете NetworkManager появилась моя wifi-сеть:

При клике по ней, добавляется строчка в dmesg:
[  282.156662] IPv6: ADDRCONF(NETDEV_UP): enp0s29u1u2: link is not ready
(раньше она появлялась ежесекундно).
В NetworkManager, в управлении сетями, ввёл пароль для доступа к точке. Не помогло. При попытке подключиться, несколько секунд бегает колечко на апплете NetworkManager, и ничего больше не происходит.
Интерфейс по команде ip link set up так и не поднимается.
Что смотреть дальше?
Последний раз редактировалось
0
avatar
Попробуй удалить 8192cu-dkms установить ядро 4.7.10-1, перезагрузиться и установить заново 8192cu-dkms и установить раннюю версию NetworkManager
?
Всё возможно, пока не сделан выбор !
+2
avatar
Ядро какой командой установить?
yaourt linux
, и выбрать нужное?
Последний раз редактировалось
0
avatar
echo "options rtl8192cu fwlps=0 swlps=0" | sudo tee  /etc/modprobe.d/rtl8192cu.conf

sudo reboot
Последний раз редактировалось
?
Debian (8.7), LMDE2, LM (18.1 Mate, 17.3 Xfce), Antergos 17.2, Manjaro17, Netrunner 17.3.
+1
avatar
А что делает эта команда? Я её выполнил. Но параллельно я удалил пакет 8192cu-dkms и установил ядро 4.8.5-2-MANJARO. После перезагрузки всё работает.
0
avatar
Эта команда запускает драйвер с опцией не «засыпать» при бездействии. Это так, в общих словах.
?
Debian (8.7), LMDE2, LM (18.1 Mate, 17.3 Xfce), Antergos 17.2, Manjaro17, Netrunner 17.3.
0
avatar
Пошаговая инструкция Archwiki.
0
avatar
Я читал её. Эта инструкция подразумевает, что интерфейс поднимается. В моём же случае этого не происходит.
0
avatar
Дело сейчас обстоит так. Со штатным драйвером связь работает. Но скорость соединения составляет 5 мегабит/с. Тогда как по кабелю — 23. Снова установил драйвер 8192cu-dkms. Теперь интерфейс снова не поднимается. Вернулся к этой ситуации.
0
avatar
а чего там в логе IPv6 мелькает? Настораживает как-то
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.