Manjaro XFCE Edition
   535

проблемы с smplayer

manjaro, правда x86, после обновления от 02.04.18 не запускается smplayer:

smplayer: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory

файла действительно нет по пути /usr/lib/libicui18n.so.60
вместо него стал libicui18n.so.61
где поправить, чтобы он искал libicui18n.so.61?
  • 0
  • 0

16 комментариев

avatar
Ссылку с нужным именем создайте

sudo ln -s /usr/lib/libicui18n.so.61 /usr/lib/libicui18n.so.60
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
похоже, что так просто не выйдет, сначала сделал тот же трюк с
sudo ln -s /usr/lib/libicuuc.so.61 /usr/lib/libicuuc.so.60
но при запуске smplayer
smplayer: symbol lookup error: /usr/lib/libQt5Core.so.5: undefined symbol: ucal_getDSTSavings_60

smplayer переустанавливал, обновления перепроверил
Последний раз редактировалось
0
avatar
[mmk@tal02 ~]$ smplayer 
qt5ct: using qt5ct plugin
SMPlayer v. 18.3.0 (ревизия 8959) запущен в Linux

Работает, ошибки нет.
qt5ct установлен? в переменных прописан?
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
так все работало до обновления, qt5ct установлен, переустановил, но
smplayer: symbol lookup error: /usr/lib/libQt5Core.so.5: undefined symbol: ucal_getDSTSavings_60
осталось. Установил VLC пока подожду, мож че с обновлениями не так, x86 всетаки…
огромное спасибо за помощь!!! (я конечно понимаю, что сухая благодарность не принимается, но тем не менее...)
0
avatar
пишет делать больше нечего
только что обратил внимание
Система: Manjaro 18.0-alpha-1 Illyria, мож тут че
Последний раз редактировалось
0
avatar
Так Вы используете нестабильную ветку. В ней баги не исключаются, потому она так и называется… Можно перейти на стабильную, вам решать.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
спасибо еще раз, завтра попробую!
0
avatar
пытался перейти на stable, но screenfetch выдает
Система: Manjaro 18.0-alpha-1 Illyria
делал по инструкции с manjaro32.org
pacman-mirrors -c all -b {stable,testing,unstable}
pacman -Syy archlinux32-keyring-transition
pacman -S archlinux32-keyring # accept removal of archlinux32-transition-keyring
pacman -Syu
потом руками поправил в pacman-mirror.conf Branch = stable
обновился, нашлись куча пакетов новее, чем в репозиториях. Что я еще не сделал?
0
avatar
Если хотите откатить все пакеты на стабильные- сделайте
sudo pacman -Syyuu
Но можно и не морочится, если работает нормально. Со временем всё выровняется.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
спасибо, намек понял, но smplayer так и не запустился, меня смущает manjaro 18.0, подождем очередных обновлений, еще раз спасибо!
0
avatar
Если дело только в нем- переустановите его, вместе с зависимостями.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
извиняюсь, не понял, как переустановить?
0
avatar
Ну просто переустановите, версии пакетов при этом заменятся на стабильные. А то у вас ветка-то сменилась, а пакеты по-прежнему остались из нестабильной, они «новее чем в репозиториях».
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
огромное человеческое спасибо, завтра сделаю!
0
avatar
sudo pacman -Syyuu помогло, спасибо, вопрос с плеером решен!
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.