Manjaro MATE
   331

Ошибка при установке пакета

Всем здрасте.
Только что установил систему, и банально начал устанавливать нужный софт, но что-то не так…

Текст с ошибкой из терминала

$ yaourt -S google-chrome --noconfirm

==> Загрузка PKGBUILD google-chrome из AUR...
x .SRCINFO
x PKGBUILD
x eula_text.html
x google-chrome-stable.sh
x google-chrome.install
Det commented on 2017-10-01 00:35			 
The final vote. “What should be the pkgdesc of AUR/google-chrome?” With 82 votes:

● "One fast, simple, and secure browser for all your devices (Stable Channel)" - 17 votes (21%)
● "The popular and trusted web browser by Google (Stable Channel)" - 65 votes (79%)

Now, my deciding vote of 49 votes will be cast and the winner is...










..no, I’m kidding, I’m kidding. Pkgdesc changed. ^^

ruhly commented on 2017-10-06 21:45			 
it would be useful to add gtk3-print-backends as an optional dependency for printing

Det commented on 2017-10-07 12:59			 
I dunno. Looks like I don't need to add it, but can do anyway: https://bugs.archlinux.org/task/54909, https://bbs.archlinux.org/viewtopic.php?id=227734

horosgrisa commented on 2017-10-10 20:33			 
file /usr/bin/google-chrome-stable have a bug. Please add a space between "$HERE/chrome" and "$CHROMIUM_USER_FLAGS" at line 49.

Det commented on 2017-10-11 00:37			 
I'm assuming you mean /opt/google/chrome/google-chrome, but my line 49 says:

exec -a "$0" "$HERE/chrome" "$@"

google-chrome 62.0.3202.62-1  (2017-10-17 21:28)
( Неподдерживаемый пакет: Потенциально опасен ! )
==> зависимости google-chrome:
 - alsa-lib (уже установлен)
 - gconf (уже установлен)
 - gtk3 (уже установлен)
 - libcups (уже установлен)
 - libxss (уже установлен)
 - libxtst (уже установлен)
 - nss (уже установлен)


==> Продолжить сборку google-chrome ? Да/нет [Y/n]
==> ----------------------------------------------
==> 
==> Сборка и установка пакета
==> Сборка пакета google-chrome 62.0.3202.62-1 (Вс окт 22 23:06:42 +07 2017)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Загрузка google-chrome-stable_62.0.3202.62_amd64.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 46.2M  100 46.2M    0     0  9472k      0  0:00:05  0:00:05 --:--:-- 9503k
  -> Найден eula_text.html
  -> Найден google-chrome-stable.sh
==> Проверка файлов source с использованием md5sums...
    google-chrome-stable_62.0.3202.62_amd64.deb ... Готово
    eula_text.html ... Готово
    google-chrome-stable.sh ... Готово
==> Распаковка исходных файлов...
  -> Распаковка 'google-chrome-stable_62.0.3202.62_amd64.deb' с помощью bsdtar
==> Вход в окружение fakeroot...
/usr/bin/makepkg: строка 170: fakeroot: команда не найдена
==> ОШИБКА: Makepkg не смог собрать google-chrome.



В других сборках дистрибутива(Deepin, KDE, и т.д) таких проблем никогда не было.
Примерно полчаса провел в гугле и на форумах, но решение так и не нашел.
Заранее спасибо и надеюсь на помощь)

5 комментариев

avatar
sudo pacman -S base-devel
?

clock for blog
+2
avatar
Можно воспользоваться китайским репом. В нем многие ауровские пакеты в бинарном виде. В том числе google-chrome.
Добавить в /etc/pacman.conf
[archlinuxcn]
Server = https://cdn.repo.archlinuxcn.org/$arch

Выполнить
sudo pacman -Syy && sudo pacman -S archlinuxcn-keyring

Последний раз редактировалось
+2
avatar
jacobtey
Не по теме но все же-интересная репа, есть еще какие-то репозитории интересны в этом плане?
Например, download.opensuse.org/repositories/home:/metakcahura/Arch_Extra/x86_64/
archive.virtapi.org/packages/
нашел сегодня.
Последний раз редактировалось
0
avatar
Спасибо! Посмотрю.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.