Уголок новичка
   1031

Экран загрузки Manjaro

Здравствуйте, знатоки Manjaro. Помогите пожалуйста, может кто встречался c такой проблемой. Когда происходит загрузка системы, появляется слово Manjaro и чуть ниже точки загрузки. Все отображается изначально хорошо, но потом происходит искажение. На данном дистрибутиве недавно, поэтому строго не судите. Дистрибутив очень нравиться, проблема не существенна, но хочеться исправить. Заранее спасибо
Уголок новичка: Экран загрузки Manjaro

8 комментариев

avatar
Предоставьте информацию о вашем железе, после данного искажения система работает нормально?
0
avatar
Система работает нормально. Вывод inxi -F
System: Host: brutrace-pc Kernel: 4.6.6-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.7.3
Distro: Manjaro Linux
Machine: System: Apple (portable) product: MacBookPro8 1 v: 1.0
Mobo: Apple model: Mac-94245B3640C91C81 v: MacBookPro8 1
Bios: Apple v: MBP81.88Z.0047.B2C.1510261540 date: 10/26/15
Battery BAT0: charge: 33.7 Wh 67.3% condition: 50.1/57.7 Wh (87%)
CPU: Dual core Intel Core i5-2415M (-HT-MCP-) cache: 3072 KB
clock speeds: max: 2900 MHz 1: 1236 MHz 2: 914 MHz 3: 1398 MHz 4: 1087 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.17.4 driver: intel Resolution: 1280x800@60.22hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 12.0.1
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.6.6-1-MANJARO
Network: Card-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
IF: enp2s0f0 state: down mac: 3c:07:54:0d:04:35
Card-2: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge
IF: wlp3s0b1 state: down mac: 28:cf:da:dc:dc:c4
Drives: HDD Total Size: 750.2GB (1.6% used) ID-1: /dev/sda model: ST750LM022_HN size: 750.2GB
Partition: ID-1: / size: 41G used: 7.4G (20%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 363G used: 263M (1%) fs: ext4 dev: /dev/sda7
ID-3: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 65.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 161 Uptime: 31 min Memory: 1148.6/7900.5MB Client: Shell (bash) inxi: 2.3.0
0
avatar
попробуйте выполнить команду
<code># mkinitcpio -p [name of your kernel preset]</code>
[name of your kernel preset] — ваше ядро, например linux46
?

clock for blog
0
avatar
Вывод команды mkinitcpio -p linux46:

==> Building image from preset: /etc/mkinitcpio.d/linux46.preset: 'default'
-> -k /boot/vmlinuz-4.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.6-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-4.6-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux46.preset: 'fallback'
-> -k /boot/vmlinuz-4.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.6-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-4.6-x86_64-fallback.img
0
avatar
команду надо выполнять от рута(об этом намекает значек '#' перед командой, простите, скопировал с арчвики и не поправил):
<code>sudo mkinitcpio -p linux46</code>
?

clock for blog
+1
avatar
Да ничего, это я плохо посмотрел(не увидел #)
sudo mkinitcpio -p linux46
[sudo] пароль для brutrace:
==> Building image from preset: /etc/mkinitcpio.d/linux46.preset: 'default'
-> -k /boot/vmlinuz-4.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.6-x86_64.img
==> Starting build: 4.6.6-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [plymouth]
-> Running build hook: [resume]
-> Running build hook: [filesystems]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.6-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux46.preset: 'fallback'
-> -k /boot/vmlinuz-4.6-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.6-x86_64-fallback.img -S autodetect
==> Starting build: 4.6.6-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [plymouth]
-> Running build hook: [resume]
-> Running build hook: [filesystems]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.6-x86_64-fallback.img
==> Image generation successful

Поcле перезагрузил машину, ничего не изменилось :(
Последний раз редактировалось
0
avatar
посмотрите здесь есть ли у вас в /etc/default/grub quiet splash
почитайте тут.
попробуйте поменять plymouth на другой, и посмотрите как будет вести себя он например этот:
# plymouth-set-default-theme spinfinity
Последний раз редактировалось
?

clock for blog
+1
avatar
Проблему решил. Заставив KMS принудительно запускаться раньше добавив в MODULES i915(для видеокарт Intel) (/etc/mkinitcpio.conf) и «i915.modeset=1»(для видеокарт Intel) в GRUB_CMDLINE_LINUX_DEFAULT (etc\default\grub).Спасибо Agafron'у за ссылку тут. По мимо искажения в plymouth(скриншот выше), также наблюдались в tty (квадратики) проблема с кирилицой. Решил по этой ссылке Квадратики в tty
Последний раз редактировалось
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.