Уголок новичка
   646

Manjaro KDE 17.1.10 низкая скорость интернета через lan, провод

Здравствуйте форумчане.
Решил я поставить manjaro, в целом система устраивает, но не могу понять почему сейчас через провод низкая скорость входящей сети.
Для примера решил на speedtest.net проверить(приблизительную скорость хоть показывает).
На нём входящая скорость ~8-10Mbps, исходящая ~95Mbps,
это на рабочем компе, ограничений тут никаких нет в сети, точно не у меня.
Дома я поставил тоже manjaro такую же версию, была такая проблема, но потом не помню как решил скорость стала нормальной.
Помогите найти причину ограничения скорости.
Спасибо.
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.5.0.90 netmask 255.255.255.0 broadcast 10.5.0.255
inet6 fe80::96de:etdr:ehg3:ba prefixlen 64 scopeid 0x20ether 94:de:80:b2:00:ba txqueuelen 1000 (Ethernet)
RX packets 102779 bytes 51514205 (49.1 MiB)
RX errors 11563 dropped 103 overruns 0 frame 8659
TX packets 221570 bytes 269556622 (257.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16

10 комментариев

avatar
Уверены, что на других системах (например, загрузиться с live-cd) на этом же железе и канале скорость лучше?
RX errors 11563 dropped 103 — за какое время?
Провайдерский UTP идет сразу в комп или есть рутеры и т.п.?
0
avatar
да, проверил на том же live cd, скорость нормальная.
uptime 9 часов, и сейчас проверил RX errors 176196 dropped 212 overruns 0 frame 158672
это рабочий комп, тут роутер, но сеть нормальная, тут я что то сделал, видимо пока настраивал темы, обновлял пакеты.
Вот и хочу попытатся выяснить что режет скорость.
Последний раз редактировалось
0
avatar
гляньте, что у вас тут.
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
+1
avatar
Да, вот ещё это не сказал.
В mhwd сетевого адаптера нет, есть два графических адаптера.

Сетевой адаптер:
03:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)
        Subsystem: Gigabyte Technology Co., Ltd AR8161 Gigabit Ethernet

Скажу ещё, что я ставил два пакета sstp-client и networkmanager-sstp
но я пробовал удалять эти пакеты и переустанавливать networkmanager.
0
avatar
чессгря, при таком количестве ошибок именно на входящем, я бы грешил на кабель, но… если нет просадок в live, то даже не знаю на что грешить. тупо кабель другой подкинуть нет возможности?
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
0
avatar
Спасибо, кабель литой(т.е. не переобжатый). Попробую его заменить и на крайний случай у меня есть в сетевуха realtek вроде, можно через неё попробовать.
0
avatar
Проверил, поставил другой адаптер, скорость нормальная стала.
Card-2: Realtek RTL8169 PCI Gigabit Ethernet driver: r8169 v: 2.3LK-NAPI 
port: c000 bus ID: 05:00.0 
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 

Видимо ядро неправильно работает с Qualcomm Atheros AR8161, может ошибка в драйвере.
Card-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx v: kernel port: d000 
bus ID: 03:00.0 
IF: enp3s0 state: down mac: <filter> 

Вот ещё вопрос, в manjaro где можно править sysctl, на дебиане например я изменял сам /etc/sysctl.conf, а тут правильнее создавать и изменять конфиги в /etc/sysctl.d/*.conf?
0
avatar
Видимо ядро неправильно работает с Qualcomm Atheros AR8161, может ошибка в драйвере.
Так и есть. Внесите в /etc/modprobe.d/ r8169. Будет использоваться нормально работающий r8168.
Вот ещё вопрос, в manjaro где можно править sysctl, на дебиане например я изменял сам /etc/sysctl.conf, а тут правильнее создавать и изменять конфиги в /etc/sysctl.d/*.conf?
Да.
Последний раз редактировалось
0
avatar
В арче было такое недавно. Вроде исправили
0
avatar
Спасибо. Если есть, можете ссылку найти на эту тему?
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.