Уголок новичка
   431

Не могу обновить Manjaro Deepin

Не могу обновить Manjaro Deepin

Выходит такая ошибка: pacman: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

Перелопатил форумы но толком ничего не нашел…

6 комментариев

avatar
Скачайте с репов /core пакет openssl 1.1.0.f-1
разархивируйте, положите файл libcrypto.so.1.1 в /usr/lib
Когда сможете запустить pacman —
первым делом переустановите openssl,
потом ПЕРЕУСТАНОВИТЕ САМ PACMAN,
ПОТОМ pacman -Syyuu
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Выходит ошибка

pacman: symbol lookup error: /usr/lib/libcurl.so.4: undefined symbol: SSL_load_error_strings
0
avatar
curl что-ли снесли? Восстанавливайте вручную, тем де способом. качайте curl с репов, кладите файлы на место.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Проблему решил. Теперь я расскажу всю историю, просто до этого не мог много писать.

Я скачал редакцию Manjaro Deepin 17.0.1. После установки я не мог обновить систему из-за сообщения о том, что установлена неправильная версия gcc. Немного побродив в интернете я нашел «решение». Оно заключалось в переустановки самого пакмана. Но после этого и появилась ошибка с пакетом openssl.

Пока я решал одну ошибку — система сносила кучу других пакетов.

Решил прибегнуть к решению проблем, как на винде, ведь я так и так систему только-только установил. После переустановки системы я попросу установил ту версию gcc, что требовал пакман и не более того. После этого я смог обновить всю систему. И во время обновления уже установились все нужные пакеты. И пока система работает на ура. Надуюсь, что так и останется.
0
avatar
:))) Вот и Вас позвала дорога приключений. И Вы прострелили себе колено…
?
Правильные ответы начинаются с правильных вопросов.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.