Уголок новичка
   461

Обновление 06.06.17

Здравствуйте!
Не получается установить последние обновления (Manjaro DEEPIN). Пишет, что «ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости) :: gcc-fortran: требует gcc=7.1.1-2»
Пробовал обновиться через —Syyuu — та же история.
Пробовал поставить gcc=7.1.1-2 вручную. Пишет: «ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости) :: gcc-fortran: удаление gcc-multilib ломает зависимость 'gcc=6.3.1-2'»
Замкнутый круг какой-то. Не подскажете, что делать?

5 комментариев

avatar
Может, нужен пакет gcc-fortran-multilib?
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Пишет, что «ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости) :: gcc-fortran: требует gcc=7.1.1-2»
Покажи полностью команду, которой обновляешься, и её вывод.
0
avatar
Нужно сначала удалить пакеты gcc и gcc-fortran, установив вместо них gcc-multilib и gcc-fortran-multilib. После этого запустить полное обновление.
+4
avatar
Все проблему решил удалением gcc. Спасибо vasco!!!
0
avatar
Похожая история и на Синнамоне. Спасибо vasco
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.