Уголок новичка
   438

Ошибки обновления 16.10.3 до 17.0.1 KDE Edition

Бодрого времени суток,

есть ноутбук с 16.10.3 KDE Edition, всё работает всё хорошо. При обновлении и через терминал, и через Octopi выдаёт кучу ошибок на невозможность заменить файлы из-за зависимостей, и обновление не проходит.

Уголок новичка: Ошибки обновления 16.10.3 до 17.0.1 KDE Edition

Уголок новичка: Ошибки обновления 16.10.3 до 17.0.1 KDE Edition

Как обновить систему?

14 комментариев

avatar
О, с версии 16.10.3 многое изменилось, было несколько критических обновлений. Так что курите раздел «Новости» за прошлые периоды.
Думаю, в Вашем случае прежде всего нужно прочесть январский пост: manjaro.ru/blog/news/stabilnoe-obnovlenie-2017-01-17-python-xorg-ruby-gcc-inkscape.html

Обратите особое внимание на Вашу версию ядра, поддержка 4.8 прекращена.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Спасибо конечно за ответ, но что делать то? Как обновлять ноутбук? Попытался переставить с USB-флешки 17.0.1. там не видит wi-fi broadcom при установке. Да к тому же на текущей версии уже многое установлено, всё работает, удалять переустановкой не правильно. Есть способ поэтапного обновления с 16.10.3 на более поздние по шагам? Сначала одни завсисимости, затем другие… а?
0
avatar
Спасибо конечно за ответ, но что делать то? Как обновлять ноутбук?
Дык, как обычно. Запустил sudo pacman -Syu, словил ошибку, покурил «Новости» (поиск тоже рулит), Запустил sudo pacman -Syu, устранил/обошел ошибку, словил новую, покурил «Новости»… и так до победы. Это и есть поэтапный способ.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Ок, если грохнуть xf86-input-acecad, который везде конфликтует, то конфликт уйдёт по идеи?

Как его кстати грохнуть, где искать, можете подсказать?
0
avatar
По идее да. Как грохнуть? да как угодно, хоть через октопи, хоть sudo pacman -R xf86-input-acecad
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Спасибо, друх :) вечером попробую поудалять конфликты
0
avatar
Он же тебя при обновлении русским языком спрашивает: «Удалить xf86-input-acecad?»
0
avatar
Так я везде и нажимаю Y, а потом та ошибка что и на скриншоте.
0
avatar
Я тоже как-то вручную удалял. Бывает автоматом не делается.
0
avatar
Я не вижу на скриншоте напечатанной «Y». Обновляться через PACMAN.
0
avatar
Попробовал:
sudo pacman -Syu
и везде Y.

Ошибка всё равно, теперь другая.
ошибка: не удалось завершить транзакцию (конфликтующие файлы)
xorg-server: '/usr/lib/xorg/modules/extensions/libglx.so' существует в файловой системе
Обнаружены ошибки, пакеты не обновлены.


Крупным планом habrastorage.org/files/00d/ee9/1b2/00dee91b25cd4adb80c375edf2c4b4b1.png

Как её теперь побороть?
Последний раз редактировалось
0
avatar
Удалить или переименовать /usr/lib/xorg/modules/extensions/libglx.so
От рута.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Проверь, какому пакету принадлежит данный файл:
<code>$ pacman -Qo /usr/lib/xorg/modules/extensions/libglx.so</code>
Если никакому, то его можно удалить и после повторить обновление. Насколько я помню, у меня в одном из обновлений был такой же конфликт файлов.
0
avatar
Спасибо! Помогло, обновился и узнал много нового в Линукс :)
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.