Уголок новичка
   721

падает Libre office writer

Привет, падает Libre office writer на manjaro 32 Если через консоль:
[nnn-pc ~]$ libreoffice --writer --backtrace
Error: Can't find the tool «gdb», --backtrace option will be ignored.

13 комментариев

avatar
sudo pacman -S gdb
Последний раз редактировалось
0
avatar
спасибо сейчас так:
[nnnfnn@nnnfnn-pc ~]$ libreoffice --writer --backtrace
GNU gdb (GDB) 8.0.1
Copyright © 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type «show copying»
and «show warranty» for details.
This GDB was configured as «i686-pc-linux-gnu».
Type «show configuration» for configuration details.
For bug reporting instructions, please see:
<www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<www.gnu.org/software/gdb/documentation/>.
For help, type «help».
Type «apropos word» to search for commands related to «word»…
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
log will be saved as gdbtrace.log, this will take some time, patience…

(soffice:6395): IBUS-WARNING **: The owner of /home/nnnfnn/.config/ibus/bus is not nnnfnn!
0
avatar
Запустите программу: libreoffice ( без: --writer --backtrace ).

gdb
1) Почитайте как пользоваться gdb.
2) Это нужно для отладки ( когда у многих такая-же проблема ). А это скорее всего единичный случай как у Вас.

Попробуйте удалить программу и все настройки и потом заново установить, может быть откатиться на старую версию.
0
avatar
спасибо. --writer --backtrace это мне раньше посоветовали для вывода, падает только writer — заставка и пропадает, другие приложения libreoffice работают, у меня сейчас manjaro i686, на 64 — manjaro такой проблемы нет
gdb как то сложно показалось)))
пока установил wps office
может проблема решится обновлениями
спасибо
0
avatar
Так для manjaro i686 deprecated же, не?
0
avatar
i686 сейчас поддерживается сообществом, приходят обновления, хотя не так быстро вполне можно использовать, сейчас версия 17.1.5
0
avatar
a если попробовать поставить libreoffice 6.0.1.1 snap пакетом snapcraft.io/store?
Правда не знаю поддерживает ли х32 snap.
Последний раз редактировалось
0
avatar
спасибо, как я понял snap это для ubuntu? нет?
0
avatar
blog.iteducenter.ua/sysadmin-basics/chto-takoe-snap-pakety/
wiki.archlinux.org/index.php/Snapd
Последний раз редактировалось
0
avatar
snap пакет чтото не удается установить нажимаю install -перебрасывает на страницу snap://libreoffice с ошибкой The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (snap) isn’t associated with any program or is not allowed in this context.
You might need to install other software to open this address.
0
avatar
но Вы меня натолкнули на мысль)) я установил libreoffice 6 development branch из AUR, всё заработало, спасибо
0
avatar
ну значит все ок!
для установки snap пакетов нужен snapd, установка и удаление прог по второй ссылке wiki.archlinux.org/index.php/Snapd
Поэтому и выдало:
Firefox не знает, как открыть этот адрес, потому что один из следующих протоколов (snap) не связан с какой-либо программой или не разрешен в этом контексте.
Для открытия этого адреса вам может потребоваться установить другое программное обеспечение.

Это так, на всякий случай написал, может и захочется когда-то попробовать, ну если честно-лучше с aur.
Последний раз редактировалось
0
avatar
спасибо, попробовал, правда libreoffice snap только для 64, но я установил telegram))) спасибо буду знать способ
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.