Уголок новичка
   232

Проблема с установкой MAPI Plugin для Evolution

Доброго времени суток. Помогите разобраться с проблемой: не могу установить MAPI Plugin (evolution-mapi) для почтового клиента Evolution. Когда установка плагина доходит до сборки и установки пакета python2-webhelpers выскакивает ошибка:

ошибка: не найдена цель: setuptools
==> Перезапустить сборку python2-webhelpers? да/Нет [y/N]

После чего установка прерывается.

При попытке отдельной установки python2-webhelpers командой

sudo yaourt -S python2-webhelpers   

консоль выдает следующее предупреждение:

==> ОШИБКА: Запуск makepkg от имени суперпользователя не разрешён,
т. к. это может причинить катастрофический вред системе.
==> ОШИБКА: An unknown error has occurred. Exiting…
Невозможно прочитать PKGBUILD

Хелп!

7 комментариев

avatar
Доброго времени суток!
Иногда PKGBUILD`ы не содержат всех пакетов, предоставляющих программы для сборки.
Поиск в репах по «setuptools» даст Вам список пакетов

Спойлер!
python-setuptools
python2-setuptools

Из которых судя по названию "python2-webhelpers", Вам нужен второй пакет

Кроме того, yaourt не нужно запускать с повышенными правами. Когда ему будет нужно, он попросит их через sudo сам.
Скорее всего, в Вашем случае стоит сделать так:
yaourt -S evolution-mapi

Если ошибка повторится, то:
yaourt -S python2-setuptools

yaourt -S evolution-mapi


P.S: Только что проверил, УМВР без танцев с бубном
Последний раз редактировалось
0
avatar
Установка python2-setuptools проходит успешно. После последующего ввода команды

yaourt -S evolution-mapi


снова отображается ошибка:

ошибка: не найдена цель: setuptools
==> Перезапустить сборку python2-webhelpers? да/Нет [y/N]
Последний раз редактировалось
0
avatar
Попробуйте при установке python2-pylons отредактировать PKGBUILD, убрав из зависимостей python2-webhelpers. Зависимость опциональная, на юзабильность повлиять особо не должна. На ауре этот пакет мертвый.
Можно еще почитать комментарии к пакетам из аура тут
0
avatar
Попробовал. После удаления из зависимостей python2-webhelpers получилось без проблем установить python2-pylons. При последующей установке evolution-mapi командой

<code>yaourt -S evolution-mapi</code>

в списке зависимостей пакет python2-pylons отобразился как уже установленный. Но установка не завершилась, появилось следующее сообщение об ошибке:

make: *** [Makefile:125: mapiproxy/dcesrv_mapiproxy.po] Ошибка 1
==> ОШИБКА: Произошел сбой в build().
Прерывание…
==> ОШИБКА: Makepkg не смог собрать openchange.
==> Перезапустить сборку openchange? да/Нет [y/N]
==> ----------------------------------------------
0
avatar
Действительно :( быть может это связано с обновленными версиями чего-нибудь? А для чего Вам нужен этот пакет? для обмена по типу MS Exchange? Есть пакет evolution-ews, он вроде рабочий.

P.S: при сборке выплывают варнинги и ошибки компиляции — наверное пакет очень старый
Последний раз редактировалось
0
avatar
Пакет требуется для подключения рабочей почты именно через MS Exchange. Уже предпринимал попытки настройки evolution-ews: перечитал 2 тонны статей, но так и не получил желаемого результата, т.к. подключение осуществить не удалось. Что еще можно попробовать?
Последний раз редактировалось
0
avatar
Другой почтовый клиент?)
Например слышал как-то про citadel(правда он тоже в aur).
а вообще linux MS Exchange, может найдете для себя альтернативу…
Удачи :)
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.