Уголок новичка
   835

Проблема с установкой (UEFI)

Комрады, выручайте,

так получилось, что убил рабочую систему на ноутбуке Lenovo G700 c UEFI.

Пытаюсь переустановить уже 3 день, после перезагрузки выдаёт уже известную ошибку:
#error file /boot/grub/i386-pc/normal.mod not found manjaro

Пробовал загрузиться с установочной флешки и сделать:

sudo grub-install /dev/sda, но он и тут ругается
#grub-install error cannot find efi directory

При установке делал всё как обычно:
512 Мб fat32 для /boot/efi c флагами esp и boot, пробовал уже и без флагов, пробовал ставить флаг /boot в Calamares на корневой /.

Ошибка не меняется — #error file /boot/grub/i386-pc/normal.mod not found manjaro

Что делаю не так? Как заставить загрузиться?

9 комментариев

avatar
посмотри тут: UEFI: Manjaro is missing, может еще найдешь что-то полезное
0
avatar
А не пробовали воспользоваться пунктом «Installed BIOS-System on hd0,msdos2» — последним в загрузочном меню?

?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Нет такого пункта у меня при загрузке, зато есть пункт «Detect EFI bootloaders» — выбираю его и система говорит, что «No EFI files detected»
0
avatar
дык если в UEFI устанавливалось, то и grub устанавливать чуток иначе нужно
если EFI раздела нет, то
sudo mkdir /boot/efi

потом
sudo mount /dev/sdXY /boot/efi

где ХY заменить на правильные букву и цифирь
ну и устанавливаем сам grub
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

запускаем
sudo update-grub

и пробуем перегружаться.
?
Ален нови, ностра алис! Что означает — ежели один человек построил, другой завсегда разобрать может.
0
avatar
Сделал, как Вы и написали. Выдаёт ошибку: #grub-install: error failed to get canonical path of overlay
0
avatar
при установке выбираете язык системы русский? если да то попробуйте английский
?
Хочешь оформить кредит, кредитную или дебетовую карту? Спроси меня как!
0
avatar
английский выбираю при загрузки с флешки, только в каламарес выбираю русский
0
avatar
Не знаю, что произошло, зашёл ещё раз в биос, поставил в настройках загрузки uefi, вместо legacy support, ещё раз поставил систему, но на этот раз не стал выбирать страну и город, удалил раздел под uefi, заново его создал, поставил ещё раз флаги boot и esp, презагрузился, всё ок. Хотя делал всё тоже самое уже раз 10 за последние 3 дня. Магия, Дэвид Блейм.

Всем спасибо за помощь!
0
avatar
поговаривают что если при установке указать систему на русском то есть бага такой одибки как у вас и надо ставить в англицком и потом настраивать, но это не точно
?
Хочешь оформить кредит, кредитную или дебетовую карту? Спроси меня как!
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.