Уголок новичка
   1064

Создание загрузочной флешки. Не запускается установка манджаро с флешки

Вобщем скачал последнюю версию manjaro-kde-17.1.10-stable-x86_64. записал при помощи ультраисо (на винде) и при начале установки выдает

ipic.su/img/img7/fs/20180525_215337.1527278357.jpg
Уголок новичка: Создание загрузочной флешки. Не запускается установка манджаро с флешки
Перезаписывал на разные флешки. также записывал при помощи unetbootin и Universal USB Installer
1.9.8.1
но все тоеж самое. ноут hp 630

можно ли как-то решить проблему?

25 комментариев

avatar
Для винды:
Проверить контрольные суммы manjaro-kde-17.1.10-stable-x86_64 с помощью программы HashTab hashtab.ru/files/HashTab_v6.0.0.34_Setup.exe
Запись:
rufus rufus.akeo.ie/downloads/rufus-2.18.exe
rosaimagewriter wiki.rosalab.ru/ru/images/6/62/RosaImageWriter-2.6.2-win.zip
Последний раз редактировалось
+1
avatar
Поддержку предыдущий комментарий. Образ Linux писать rufus. И надо помнить, что файловая система флешки должна быть FAT32.
+1
avatar
Я, если такое вдруг необходимо сделать из Windows, пишу руфусом и обязательно в режиме «dd»

Моё видео с инструкцией
Последний раз редактировалось
?
СкаженЭ КотЭ в кедах =(^_^)=
KDE-Minimal Setting-Up
0
avatar
Надеюсь, не нарушу правил…

Сделал флешку, загружаю лайв систему М 18 КДЕ, графическая установка обрывается с ошибкой:
Установка завершилась неудачей
Bad source
source="/run/miso/bootmnt/manjaro/x86_64/rootfs.sfs"
Контрольные суммы сходятся. Пробовал версию 17 с такими же симптомами. Уефи, легаси отключен, виндовс 10 и минт 18 живут рядом, манджаро третья.

В текстовом режиме ставится, но граб не встает, загрузчик рефайнд ставится нормально. При этом в меню загрузки не появляется пункт Манджаро. После обновления граба из Минт он появляется, но грузит несколько секунд и кернел паник (initrd /boot/intel-ucode.img). Пробовал второй вариант загрузки Манджаро (initrd / boot / initramfs-4. 19-x86 64-fallback.img) в убунту-подобных это режим восстановления, здесь не разобрался пока, что это, граб — манджаро — дополнительные варианты — вторая строка) — грузится, изменения сохраняет, но работает «не быстро».

С установкой загрузчика я не уверен, как нужно правильно делать, кроме граба ничего не использовал раньше, так что текстовый режим, возможно, не хочет из-за моей неграмотности, а графический загрузчик вызывает недоумение. Сделан, чтобы было просто, как у всех дистров, но просто выходит не у всех (есть примеры в гугле) и решения найти не смог. Нет отдельного компа для частых экспериментов, поэтому нужна инструкция…

Если кто в силах, — помогите, пожалуйста. Если решения нет — так и скажите.

Заранее благодарю.
Последний раз редактировалось
0
avatar
Решение наверняка есть. По загрузчику инструкций (даже здесь) полно. Но они разные, и не все подойдут именно Вам. Инструкции проверять нужно.
А для экспериментов использовать виртуалбокс.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Я надеялся на простой рецепт, неочевидный для меня, типа того, что надо грузиться в английскую версию для установки. С загрузчиком я разберусь, больше волнует, почему графический установщик не хочет. А виртуалке можно воспроизвести все условия (уефи и железо моего ноута)?
Последний раз редактировалось
0
avatar
Я надеялся на простой рецепт
Да ей 10 дней отроду нет, откуда простые рецепты возьмутся? Пока разбираемся :)
все условия (уефи и железо моего ноута)?
UEFI можно. ВСЁ железо конечно нет, но этого и не требуется. Поставьте VirtualBox, сами всё увидите.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
ей 10 дней отроду нет, откуда простые рецепты возьмутся?
прошлую версию точно так же не мог установить из каламариса
0
avatar
А вот это очень странно. Её установили много тысяч раз, и там нет никаких особенных секретов. Я сам дня три назад устанавливал и 17.1.12 и 17.0.5 — самым обычным способом. Значит, дело именно в Вашем железе или настройках, и поэтому готовые рецепты Вам не помогут.
ЗЫ: А английскую версию- что ж, попробуйте. Действительно, различия есть.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Решение есть и оно старо. Я очень давно пользуюсь мультизагрузочной флешкой multisystem, там заявлена поддержка и manjaro, устанавливается на флешку и лайв режим работает, кроме установки, как я уже упоминал. Не помню, чтобы multisystem меня подводила, а если не поддерживала какой дистр, то так и говорила. Короче, сделал отдельную флешку с manjaro командой «dd» в терминале, — все установилось. Где-то в глубинах образа, видимо после распаковки сквош, выползает что-то важное про установку, не заточенное под multisystem и о чем он не знает.
0
avatar
Добрый день! Вопрос от начинающего. До этого несколько раз ставил Linux Mint. Записывал флешку РУФУСом. Всё было норм.
Прочитал о замечательном дистре Manjaro Linux. Захотел попробовать. Также записал РУФУСом (образ брал здесь)
Manjaro Linux 18 XFCE. Но при загрузке получаю сообщение (что-то — "… неизвестная файловая система...).
Прочитал совет — записать не iso-образ, а dd-образ. Таким образом получилось установить Manjaro Linux 17 XFCE. Ежели загружаюсь аналогично с Manjaro Linux 18, то появляется приветственное окно, мол, начинай установку, но… Нажимаю клавишу «установка» (и в привет. окне, и в меню...) — окно установщика появляется НА 1 (одну) секунду и исчезает. Процесс установки не начинается… Хотелось бы установить сразу Manjaro Linux 18 — понял так, что обновлением не совсем то…
Гуглил, не нашёл ответа.
0
avatar
Точно, когда я недавно ставил 18ю в виртуалке- однажды было такое, при запуске инсталлятора из окна приветствия. Однако из меню установка запускалась.
Попробуйте запустить инсталлятор из терминала командой /usr/bin/calamares_polkit
Если не запустится- выхлоп терминала в студию.
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Спасибо! Завтра попробую — сейчас на работе :(
С другой стороны, может я зря гонюсь за 18-ой? Судя по обсуждению, имеется приличное количество багов и багчиков… :)
Последний раз редактировалось
0
avatar
может я зря гонюсь за 18-ой?
Может и верно. В 18й баги не так чтоб прям БАГИ, в целом она вполне стабильна. Там лишь XFCE недоношенная. А если обновитесь с 17й, будет у Вас крыска старенькая, но зрелая и вполне ещё бодренькая. Когда родят крысоделы 4.14 версию- все равно на неё перейдём, можно и подождать.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
dimonmmk, вот что в терминале после /usr/bin/calamares_polkit



Что-то не получается нормально вставить…
Последний раз редактировалось
0
avatar
Что-то не получается нормально читать стоя на голове. Перестаньте издеваться над собой и людьми, скопируйте текст из терминала и вставьте в сообщение как обычный текст.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
/usr/bin/calamares_polkit
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
qt5ct: using qt5ct plugin
08:10:36 [2]: WARNING: the branding component "/usr/share/calamares/branding/manjaro" does not ship translations.
08:10:37 [2]: WARNING: guessLocaleConfiguration can't guess from an empty list.
08:10:37 [2]: WARNING: guessLocaleConfiguration can't guess from an empty list.
/usr/bin/calamares_polkit: строка 6: 3076 Ошибка сегментирования (стек памяти сброшен на диск) pkexec --disable-internal-agent "/usr/bin/calamares" "$@"

Скорее всего, это или похожее.
Просто у меня ровно та же проблема с установкой 18-го гнома.
0
avatar
Попробуйте запускать просто как
sudo calamares
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
sudo calamares
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
qt5ct: using qt5ct plugin
08:23:46 [2]: WARNING: the branding component "/usr/share/calamares/branding/manjaro" does not ship translations.
08:23:46 [2]: WARNING: guessLocaleConfiguration can't guess from an empty list.
08:23:47 [2]: WARNING: guessLocaleConfiguration can't guess from an empty list.
Ошибка сегментирования

Рядом видел тему с похожей проблемой. Парень ХФСЕ тоже не мог поставить, не мог, а потом как смог, говорит. Измором, вроде, взял. Раза с 10-го запустился, мол, установщик. Как-то так.
0
avatar
Прошу прощения за перевернутый снимок (именно снимок — со смартфона...). Не сообразил как скопировать из терминала…
Наверное, мне не стоит больше отнимать ваше время с этим вопросом. (тем более, не я один столкнулся...).
Установил 17 XFCE, всё норм. Обновился (аж около 935 МБ обнов...). Пока полёт нормальный.

abap01, я пытался явно больше чем 10 раз — когда мелькало окно установщика, хотел за эту секунду что-то нажать — не схватывало…
Последний раз редактировалось
0
avatar
Ну, признаюсь, я пытался повторить подвиг того парня. У меня тоже не сдался.
Лосст, например, утверждает, что при «ошибке сегментирования» при незапуске какой-либо проги, максимум что можно сделать, это безуспешно попытаться обновиться и — пожаловаться разработчику(((
0
avatar
К сожалению, не могу у себя воспроизвести эту ошибку. Но в сегодняшнем обновлении calamares обновился, можно попробовать скачать новую версию osmirror.org/manjaro/stable/extra/x86_64/calamares-3.2.2.3-1-x86_64.pkg.tar.xz
и установить её в live-систему. Может, он запустится.
Кстати, там есть и новый calamares-git-3.2.3, можно и его попробовать.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Установил 17 XFCE, всё норм. Обновился
Ну и хорошо. Вполне нормальный вариант, если бы не новый XFCE. Надеюсь, такая ситуация ненадолго и всё выровняется.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Ещё вопрос: Кто ставил ядро «реал тайм»? Работа визуально как-то отличается? (хочу попробовать для качественного воспроизведения музыки...).
0
avatar
Многие ставили. Нормально, попробуйте.
?
Правильные ответы начинаются с правильных вопросов.
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.