Уголок новичка
   824

Viber не запускается. Ошибка сегментирования

Здравствуйте.
Максимально подробно суть вопроса:
из-за невозможности установить систему с окружением Cinnamon на десктоп с внешнего носителя решил клонировать уже установленную на жд систему с XFCE посредством Clonezilla.
К клону прицепил Cinnamon, сменил ядро на 4.7 (иначе невозможно было загрузиться в клонированный раздел — GRUB всё время выбирал исходную ось) — и после этих манипуляций вайбер не захотел запускаться.
Вот вывод в терминале:

[valery@valery-pc ~]$ viber
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Ошибка сегментирования (core dumped)
При этом в исходной системе с вайбером всё гуд.
Поэтому я здесь с протянутой рукой… кто чем сможет..)

18 комментариев

avatar
Все работает
Последний раз редактировалось
?
Всё возможно, пока не сделан выбор !
0
avatar
Рад за Вас..)
вот только мне бы хотелось понять, из-за чего У МЕНЯ не работает..)
Последний раз редактировалось
0
avatar
у меня тоже viber не работает и тоже Ошибка сегментирования. еще на старом форуме задавал вопрос, а воз и ныне там, так что, как говорит Валентин стрыкало «Смирись и расслабься»©
?

clock for blog
0
avatar
Стрыкало, который Валентин, который Каплан, ровно вдвое меня младше, так что к его советам пусть юные прислушиваются, если оно им надо.
А если без флуда — я же в топике указал — в системе-исходнике, так сказать, с ядром 4.4 вайбер вполне себе так работает.
Раз уж вариантов пока не поступило — попробую откатиться на более раннюю версию ядра.
Извините за
0
avatar
Уважаемый bobakharkov, никоим образом не хотел вас обидеть, но этот viber у меня ни в одной системе вообще не заводился, поэтому я забил на поиски решения. так что если у вас получится — буду только рад. Но, увы, здесь я ничем не помогу(((
?

clock for blog
0
avatar
Agafron Да ну, дружище, какие обиды..)
странно от Вас слышать, что вайбер ни разу…
подождём… может, ещё кто подтянется с идеями..)
UPD.смена ядра не есть решение..(
Последний раз редактировалось
0
avatar
а не пробовали удалить ~/.ViberPC?
мне, конечно, не помогло, но, было однажды, что срабатывало, и я даже мог войти в свой аккаунт, до просмотра первого сообщения… А дальше core dumped
?

clock for blog
0
avatar
Воспроизвести ошибку не смог установил вайюер на 2 разных компах и все сразу стало.
Единственное могу добавить в общую копилку знаний, что эти сообщения не мешают работать:
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
static QPlatformTheme* QKdeTheme::createKdeTheme(): Unable to determine KDE dirs
з.ы.
На AURe написано что некоторых при такой ошибке вайбер запускается от рута(sudo viber)
Последний раз редактировалось
+1
avatar
таки да, от рута запустился, и даже сообщение позволил, правда зависает при отправке…

Значит какая-то проблема с правами. Спасибо, теперь есть над чем подумать.
Последний раз редактировалось
?

clock for blog
0
avatar
Monteroz, довольно таки полезно заходить и читать то что в ауре пишут люди,
$ LD_LIBRARY_PATH=/opt/viber viber

и все стартует, правда раньше у меня было что-то другое и на момент моего вопроса в старом форуме проблема еще не была решена.
bobakharkov, проверьте на своей машине.
Последний раз редактировалось
?

clock for blog
0
avatar
Agafron

После выполнения sudo LD_LIBRARY_PATH=/opt/viber viber окно вайбера открылось,
как при первом запуске — для синхронизации со смартфоном и после сканирования ку-ар-кода — Успех! — и арриведерчи..)

вот как это выглядело в терминале:

[valery@valery-pc ~]$ sudo LD_LIBRARY_PATH=/opt/viber viber
[sudo] пароль для valery:
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QSqlDatabasePrivate::removeDatabase: connection 'UserStorage_ConnectionName_82265488' is still in use, all queries will cease to work.
QSqlDatabasePrivate::removeDatabase: connection 'UserStorage_ConnectionName_82265488' is still in use, all queries will cease to work.
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Ошибка сегментирования

попробовал просто sudo viber — [valery@valery-pc ~]$ sudo viber
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Ошибка сегментирования
0
avatar
получается проблема не решилась??? А без sudo запускали?
У меня стартонуло LD_LIBRARY_PATH=/opt/viber viber без sudo и вот так sudo viber
ВЫХЛОП!
$ LD_LIBRARY_PATH=/opt/viber viber
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
Gtk-Message: Failed to load module «topmenu-gtk-module»
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
QFile::remove: Empty or null file name
?

clock for blog
0
avatar
Agafron получается, что не получается..))

[valery@valery-pc ~]$ LD_LIBRARY_PATH=/opt/viber viber
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Ошибка сегментирования (core dumped)
[valery@valery-pc ~]$ sudo viber
[sudo] пароль для valery:
/opt/viber/Viber: /usr/lib/libcurl.so.3: no version information available (required by /opt/viber/Viber)
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Ошибка сегментирования
0
avatar
а если yaourt -Rscn viber, потом делетнуть ~/.ViberPC и переустановить
?

clock for blog
0
avatar
Agafron

[valery@valery-pc ~]$ yaourt -Rscn viber
[sudo] пароль для valery:
ошибка: не найдена цель: viber
0
avatar
странно, а как же он у вас тогда установлен???(видимо это связано с операцией клонирования)
Тогда просто yaourt -S viber пусть установится для начала(может выдавать ошибки на то что файлы уже существуют, тогда попробуйте yaourt -S viber --force),
но перед этим делетнуть ~/.ViberPC
Последний раз редактировалось
?

clock for blog
0
avatar
Agafron

Странный вывод терминала объясняется так: в два часа ночи снёс вайбер-утом прочёл ваше предложение-сразу решил испробовать- про снесённый вайбер не вспомнил..))
однако, сейчас установил — снова выполнил ваши заклинания — вайбер запускается, но если первый раз он хотя бы позволял пройти процесс синхронизации, а потом исчезал, то после повторной установки — окно открывается, но синхронизации не происходит — пишет -ЧТО-ТО ПОШЛО НЕ ТАК… и т.д.

Переустановить ещё раз или подождать? хз…
Последний раз редактировалось
0
avatar
хз…
поддерживаю)
проблема синхронизации, это, возможно, что-то другое, думаю стоит подождать… А там видно будет...)
хз)
?

clock for blog
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.