Новости
   822

[СТАБИЛЬНОЕ ОБНОВЛЕНИЕ] 2017-01-17 - PYTHON, XORG, RUBY, GCC, INKSCAPE

Новости:Python обновлен до версии 3.6. По этой причине огромное количество зависящих от него пакетов требуют пересборки.

  • Пересборка может потребоваться также пакетам, установленным из AUR. Чтобы узнать это наверняка, сначала следует применить это стабильное обновление, а затем проверить директорию /usr/lib/python3.5/site-packages на наличие оставшихся в ней пакетов библиотек.

Команда
pacman -Qo /usr/lib/python3.5/site-packages
возвратит список пакетов, принадлежащих таким файлам. Если ответ будет пустым, значит волноваться не о чем — таких пакетов не осталось, и делать ничего не надо. Если же в перечне будут пакеты из AUR, необходимо переустановить их командой
yaourt -S <packagename> 

Также обновлен Xorg-server до версии 1.19. Опыт тестирования в нестабильной и тестовой ветках показал, что все собрано хорошо и проблем при обновлении не возникает.
  • Во время обновления система предложит удалить устаревшие драйвера xf86-input-acecad и xf86-input-joystick. Это предложение следует принять.

freetype2 «переименует» terminus-font в «Xos4 Terminus».
  • Нужно убедиться, что в тех настройках системы, где используется данный шрифт, он переименован в соответствии с новым названием.

Обновление harfbuzz несовместимо с infinality-bundle! Это вносит серьезные проблемы в Plasma 5 и нарушает работу kinit!

В репозиторий включен пакет набора оригинальных системных звуков для рабочих столов Mate и Cinnamon от Linuxmintcinnamon-sounds.
Появились новые версии Inkscape (0.92), ruby (2.4) и gcc (6.3.1)
Новая тема оформления сборки manjaro-KDE по умолчанию Breath от @mcder3 почти доделана: plasma5-themes-breath, breath-wallpaper, breath-icon-theme, breath-dark-icon-theme и sddm-breath-theme — не только хватает пары завершающих штрихов в наборе обоев.
Xreader отныне поддерживает epub, в Deepin-desktop внесены исправления ошибок, а также обновлены некоторые пакеты набора приложений KDE.
Все ядра 4-й серии, а также rt-ядра обновлены.

Linux48 более не будет обновляться и помечен на удаление в будущем. Необходимо перейти на ядро linux49, которое будет следующим ядром с долговременной поддержкой.

Обновления безопасности коснулись flashplugin и python-crypto.

С уважением, Philip Müller и команда разработчиков Manjaro.

Ядра с актуальной поддержкой


  • linux310 3.10.104
  • linux312 3.12.69
  • linux316 3.16.39
  • linux318 3.18.46
  • linux41 4.1.37
  • linux44 4.4.41
  • linux48 4.8.17 [EOL]
  • linux49 4.9.2
  • linux410 4.10-rc3
  • linux-RT-LTS 4.4.39_rt50
  • linux-RT 4.9_rt1

6 комментариев

avatar
мда, после того как пришлось удалить infinality шрифты стали просто ужасны
0
avatar
jacobtey, спасибо за перевод новостей от разработчиков, только сегодня прочитал. А вчера прилетели «обновки» да, и среди них новый Иксорг
Во время обновления система предложит удалить устаревшие драйвера xf86-input-acecad и xf86-input-joystick. Это предложение следует принять.
Именно так я и поступил, перезагрузил ноут после применения изменений, при входе в систему успел ввести только два символа из пароля и всё, система «озябла»: клавиатура (капс-лок на ней моргает лед-индикатором) не работает, тачпад то-же. Покумекал маленько и решил оставить до сегодня ибо поздно уже было (с июня 2016 использую Gnome, там доступен сеанс на Вайланд и насколько мне извесно, он пока ещё работает через прослойку Х, а тут новый Хорг). Вобщем не знаю, может и не в этом дело, возможно всё намного проще, так это, мысли вслух как говорится. А сегодня придя с работы, решил просто откатиться с ливе-юэсби, через timeshift к заранее созданной точке, правда староват бэкапчик — октябрьский, но лучше так чем новый «висяк» :D (о как получилось, так-то я сварщик))))
Пока мыслей никаких нет, думаю современем всё образуется, просто такая ситуёвита имеет место быть на моей машинке:
ноут
System: Host: manj_archik_gnome Kernel: 4.4.15-3-MANJARO x86_64 (64 bit) Desktop: Gnome 3.20.3
Distro: Manjaro Linux
Machine: System: Hewlett-Packard (portable) product: HP 15 Notebook PC v: 0977100000405F00000610180
Mobo: Hewlett-Packard model: 2212 v: 86.26 Bios: Insyde v: F.16 date: 04/24/2014
Battery BAT1: charge: 10.6 Wh 46.9% condition: 22.5/22.5 Wh (100%)
CPU: Dual core Intel Core i5-4210U (-HT-MCP-) speed/max: 1834/2700 MHz
Graphics: Card-1: Intel Haswell-ULT Integrated Graphics Controller
Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
Display Server: X.Org 1.17.4 driver: N/A Resolution: 1366x768@60.03hz
GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 12.0.1
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
Card-2: ASUSTek N10 Nano 802.11n Network Adapter [Realtek RTL8192CU] driver: rtl8192cu
Drives: HDD Total Size: 1000.2GB (14.7% used)
Info: Processes: 166 Uptime: 5:30 Memory: 1076.3/7924.9MB Client: Shell (bash) inxi: 2.3.0
0
avatar
Да уж.Новый xorg и hurfbuzz поднагадили. Перед новым годом перешел на stable ветку, так сказать, чтобы встретить НГ стабильно, ибо праздничные возлияния чреваты собственноручной поломкой системы. Как оказалось, сделал я это зря. После новости от KDE о скором выходе Plasma 5.9, решил вернуться на unstable. А в нем меня ждали более 350 новых пакетов. Само собой с установленными пакетами infinality меня ждал крах kinit. Пришлось с телефона лезть на забугорный форум и искать решение. Поэтому, как только новость о стабильном обновлении появилась в англоязычном анонсе, я поспешил разместить перевод здесь, т.к. пользователей ждало много подводных камней. Так вот и задумаешься, насколько полезнее сидеть на нестабильной ветке и применять обновления небольшими порциями, чем пытаться разобраться с лавиной новых пакетов в стабильной.
0
avatar
Так вот и задумаешься, насколько полезнее сидеть на нестабильной ветке и применять обновления небольшими порциями, чем пытаться разобраться с лавиной новых пакетов в стабильной.
В предверии праздничных возлияний Вам пришла в голову полезная мысль, но… «что у трезвого на уме, то пьяному по колено». Я так понимаю, со stable веткой проблем не было, они начались когда Вы вернулись на unstable, где и словили без предупреждений и анонсов «лавину новых пакетов». Вот и задумайтесь, что на самом деле полезнее. ;)
Зы: А за хороший и оперативный перевод анонса- спасибо. :)
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Да, ладно, что уж там. Что нас не убивает, то делает сильнее.
Не смог я смириться с оригинальным фритайпом. Мои шрифты получались вырвиглаз. И удерживать хафбаз как-то не камильфо. Пришлось качать инфайнелити с гита, собирать и помещать обновленные пакеты себе в локальный реп.
Последний раз редактировалось
0
avatar
Да, спасибо за перевод, а то еще из-за питона и caffeine-ng отвалился )
А вы не занете, в AUR появился freetype2-infinality 2.7.1-1, если его поставить, будет гуд?
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.