Управление пакетами
   785

Ломает зависимость Pacman (РЕШЕНО)

Всем привет!
С Manjaro опыта нету, только поставил систему, и немогу ничего абсолютно установить, как я понимаю проблема в конфликте зависимостей pacman, такая ошибка выходит при например установке yaourt

[vladimir@mpc ~]$ sudo pacman -S yaourt
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: pamac: установка pacman (5.1.0-2) ломает зависимость 'pacman<5.1'
[vladimir@mpc ~]$ sudo pacman -S pkgbrowser
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: pamac: установка pacman (5.1.0-2) ломает зависимость 'pacman<5.1'

Система Majaro 17 XFCE, 32 bit для I686 процессоров!
Расскажите пожё на пальцах как решить проблему!

9 комментариев

avatar
пробовал обновить
[vladimir@mpc ~]$ sudo pacman -Sy pacman-5.1
:: Обновление баз данных пакетов…
core не устарел
extra не устарел
community не устарел
ошибка: не найдена цель: pacman-5.1
0
avatar
обновите вначале всю систему
sudo pacman -Syuu
0
avatar
и зачем вы дублируете вопросы?
0
avatar
пардон затупил
0
avatar
удалил дубль
0
avatar
Система Majaro 17 XFCE, 32 bit для I686 процессоров!
Где Вы это откопали? Поддержку i686 прекратили еще в 17.1.0.
Последний раз редактировалось
+1
avatar
forum.manjaro.org/t/stable-update-i686-2018-06-07-pacman-5-1-kernels-chromium-qt5/49198
это форум по manjaro x32, ищи тут, правда на птичьем языке. Короче надо сначала обновиться без ошибок.
Последний раз редактировалось
0
avatar
СПАСИБО БОГИ Majaro, Я справился
помогло мне это
sudo pacman -Sy archlinux32-keyring
sudo pacman -Syu

If you still get the same error, run:

sudo pacman-key --refresh-keys
0
avatar
добавь в заголовке РЕШЕНО
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.