Управление пакетами
   120

(Решено)не могу установить brackets,

При сборке пaкета brackets, выводит ошибку Makepkg не смог собрать gcc5. В интернете тишина как будто нет таких проблем. Что мне делать? Отдельно установка gcc5 через yaourt тоже не идет, больше не где не было замечено проблем с пакетами.
build/genattrtab.o build/rtl.o build/read-rtl.o build/ggc-none.o build/vec.o build/min-insn-modes.o build/gensupport.o build/print-rtl.o build/read-md.o build/errors.o .././libiberty/libiberty.a build/genattrtab /tmp/yaourt-tmp-dexp/aur-gcc5/src/gcc-5.5.0/gcc/common.md /tmp/yaourt-tmp-dexp/aur-gcc5/src/gcc-5.5.0/gcc/config/i386/i386.md insn-conditions.md \ -Atmp-attrtab.c -Dtmp-dfatab.c -Ltmp-latencytab.c make[3]: *** [Makefile:2156: s-attrtab] Убито make[3]: выход из каталога «/tmp/yaourt-tmp-dexp/aur-gcc5/src/gcc-build/gcc» make[2]: *** [Makefile:4414: all-stage2-gcc] Ошибка 2 make[2]: выход из каталога «/tmp/yaourt-tmp-dexp/aur-gcc5/src/gcc-build» make[1]: *** [Makefile:23022: stage2-bubble] Ошибка 2 make[1]: выход из каталога «/tmp/yaourt-tmp-dexp/aur-gcc5/src/gcc-build» make: *** [Makefile:905: all] Ошибка 2 ==> ОШИБКА: Произошел сбой в build(). Прерывание… ==> ОШИБКА: Makepkg не смог собрать gcc5. ==> Перезапустить сборку gcc5? да/Нет [y/N] t=«терминал»

6 комментариев

avatar
Есть же выбор. brackets-bin, brackets-git итд.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Дело не в самом брекетс, а в gcc5, брекетс то устанавливается, и ярлык появляется, только не запускается ни какой, даже который в исходниках
0
avatar
Действительно, brackets поломали. Работает только brackets-extract, но он древний, да еще и глючный.
А в новой версии 1.11- ошибки.
Выход — действовать по принципу «Суслика видишь? А он ЕСТЬ!» :)
Ставьте версию 1.10. Её тоже как-бы нету в АУРе, но…

1) сперва ставьте libgcrypt15, обычным способом. Возможно, понадобится что-то еще из зависимостей brackets-bin, поставьте тоже.
2) потом в терминале запустите установку brackets-bin следующим образом:

yaourt --m-arg "--skipchecksums --skippgpcheck" -Sb brackets-bin

3) отредактируйте PKGBUILD (в 6й строке замените pkgver=1.11 на pkgver=1.10)

У меня все поставилось и заработало.

4) внесите brackets-bin в список игнорируемых при обновлении пакетов.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+2
avatar
Спасибо, заработало. К стати gcc5 перестало выводить ошибку, не уверен почему, но до этого я переустановил base base-devel
0
avatar
На здоровье. А gcc5 больше не нужен. Можно удалить. Сейчас уже gcc7 актуален.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Держите gcc5
archive.virtapi.org/packages/g/gcc5/
Отсюда качается brackets-bin
mirror.jkanetwork.com/Arch-repository/repo/jkanetwork/
Установку не проверял, не надо мне пока этих прог.Удачи!
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.