Софт
   589

Престали запускаться некоторые программы

Престали запускаться некоторые программы. Думаю, это как-то связано с python.
<spoiler hided t=«caffeine» >
$ /usr/bin/caffeine
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 635, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 943, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 834, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (setproctitle 1.1.10 (/usr/lib/python3.5/site-packages), Requirement.parse('setproctitle==1.1.9'), {'caffeine-ng'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/caffeine", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2927, in <module>
    @_call_aside
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2913, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 637, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 650, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 829, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'setproctitle==1.1.9' distribution was not found and is required by caffeine-ng



my-weather-indicator
$ /opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

(my-weather-indicator:9156): Gtk-WARNING **: GTK+ module libtopmenu-gtk-module.so cannot be loaded.
GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
Gtk-Message: Failed to load module "topmenu-gtk-module"
<gettext.GNUTranslations object at 0x7f52b8060908>
#####################################################
System: Linux
Machine: x86_64
Node: manjaro
Release: 4.6.0-1-MANJARO
Version: 1 SMP PREEMPT Mon May 9 18:20:06 UTC 2016
Platform: Linux-4.6.0-1-MANJARO-x86_64-with-glibc2.3.4
My-Weather-Indicator version: 0.8.1-0extras16.04.1
#####################################################

****** Requesting timezone identificacion
Traceback (most recent call last):
  File "/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator", line 69, in <module>
    mwi = MWI()
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py", line 143, in __init__
    self.load_preferences()
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/myweatherindicator.py", line 360, in load_preferences
    self.indicators[i], i)
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/weatherwidget.py", line 88, in __init__
    self.load_preferences()
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/weatherwidget.py", line 187, in load_preferences
    self.is_set_keep_above(configuration.get('onwidget1top'))
  File "/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/weatherwidget.py", line 173, in is_set_keep_above
    os.path.join(comun.IMAGESDIR, 'pinup.svg'), 36, 36, 1))
GLib.Error: gdk-pixbuf-error-quark: Couldn't recognize the image file format for file '/opt/extras.ubuntu.com/my-weather-indicator/share/my-weather-indicator/images/pinup.svg' (3)

но че за прикол понять не осилил. ueuk говорит что-то невнятное или я просто не понял по каким ключевым словам гуглить.

1 комментарий

avatar
с my-weather-indicator проблема исчезла после решения этой проблемы. С caffein`ом вопрос остается открытым(
?

clock for blog
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.