Софт
   1540

Устанавливаем Bomi

Разработчик Bomi обещал вернуться и возобновить работу над плеером. Но пока он пакует чемоданы, пользователи Archlinux и Arch-based систем не могут скомпилировать плеер из-за зависимостей старых библиотек. Но выход есть…

Софт: Устанавливаем Bomi
Будем ставить бинарник, да пусть не труъ и не по-человечески, но зато работает.
PKGBUILD (для x86_64):
pkgname=bomi
pkgver=0.9.11
pkgrel=5.37
pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv"
arch=('x86_64')
url="http://$pkgname-player.github.io"
license=('GPL')
provides=('cmplayer')
depends=('qt5-base' 'qt5-declarative' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-svg'
         'libdvdread' 'libdvdnav' 'libcdio-paranoia' 'libcdio' 'smbclient'
         'alsa-lib' 'libpulse' 'jack' 'libbluray'
         'libva' 'libvdpau' 'libgl' 'fribidi' 'libass' 'ffmpeg')
optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
            'mesa-vdpau: hardware acceleration support for AMD/NVIDIA opensource driver'
            'youtube-dl: streaming website support including YouTube'
            'libaacs: AACS decryption for Blu-ray support'
            'libbdplus: BD+ decryption for Blu-ray support')
source_x86_64=('http://mirror.karneval.cz/pub/linux/packman/suse/openSUSE_Factory/Multimedia/x86_64/bomi-'$pkgver'-'$pkgrel'.x86_64.rpm'
               'http://packman.links2linux.org/download/libchardet/2086560/libchardet1-1.0.4-4.1.x86_64.rpm')
md5sums_x86_64=('SKIP'
                'SKIP')
package() {

	cd "$srcdir/"
	# Creating needed directories
	mkdir -p "$pkgdir/usr/bin"
	mkdir -p "$pkgdir/usr/share"
	mkdir -p "$pkgdir/usr/lib"

	# Copy files
	cp -r "$srcdir/usr/bin" "$pkgdir/usr"
	cp -r "$srcdir/usr/share" "$pkgdir/usr"
	cp "$srcdir/usr/lib64/libchardet.so.1.0.0" "$pkgdir/usr/lib"
	
	# Create symlink libchardet
	cd "$pkgdir/usr/lib"
	ln -s "libchardet.so.1.0.0" "libchardet.so.1"
}

Сохраняем код в документ, к примеру ~/Загрузки/bomi/PKGBUILD
Открываем директорию в терминале и собираем пакет:
makepkg

Устанавливаем:
sudo pacman -U bomi-*.tar

Пользуемся :)

Альтернативный вариант, уже собранный пакет: yadi.sk/d/WQL3NE78qmiVT

Установка из AUR:
yaourt -S bomi-fresh

12 комментариев

avatar
Спасибо, лучший видеоплеер из всех что я видел
?
Свежие новости мира информационных технологий ТехноДжем
+1
avatar
=> Сборка пакета bomi 0.9.11-5.35 (Пн апр 4 14:32:55 UTC 2016)
==> Проверка зависимостей для запуска…
==> Проверка зависимостей для сборки…
==> Получение исходных файлов…
-> Загрузка bomi-0.9.11-5.35.x86_64.rpm…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 2426k 100 2426k 0 0 1488k 0 0:00:01 0:00:01 --:--:-- 1487k
-> Загрузка libchardet1-1.0.4-4.99.x86_64.rpm…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (22) The requested URL returned error: 404 Not Found
==> ОШИБКА: Ошибка при загрузке 'http://packman.links2linux.org/download/libchardet/2464668/libchardet1-1.0.4-4.99.x86_64.rpm'
Прерывание…
чет не пошло как та
0
avatar
Удалили libchardet из репозитория. Ссылка поправлена, сохраните PKGBUILD заново и соберите.
0
avatar
Если пакет опять по каким-то причинaм пропадет, то можете сами подменить ссылку из packman.links2linux.org/package/libchardet/
Версия: 1.0.4
0
avatar
все спасибо подменил ссылку все встало как надо
0
avatar

Вот такое выдает.
0
avatar
Поправил PKGBUILD и команду установки
0
avatar
Большое спасибо!
0
avatar
Ребята, можете сами поменять ссылку на пакет.
bomi:
mirror.karneval.cz/pub/linux/packman/suse/openSUSE_Factory/Multimedia/x86_64/
libchardet:
packman.links2linux.org/package/libchardet/
Смысл в том, что это репозиторий OpenSUSE Factory — где постоянно обновляются пакеты, а потому нужно фиксить pkgrel в PKGBUILD
Хотел указать ссылки из OpenSuse 13.2, но плеер там собран со старыми зависимостями и ругается на libcdio_paranoia.so.1. Подходят версии пока только с репозитория Factory.
0
avatar
Ссылки постоянно бьются, добавил уже собранный пакет в шапку. Ставим через sudo pacman -U packagename
0
avatar
ваша сборка с яндекса не запускается, из yaourt устанавливается только fresh, как я понял скомпиленная сборка новее, как тогда?
0
avatar
Самая последняя версия в AUR bomi-fresh, более новой нет, и есть подозрения что не будет
?
Свежие новости мира информационных технологий ТехноДжем
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.