avatar
привел сеть к виду
Роутер — 192.168.0.1
на первой сетевой 192.168.0.2 шлюз 192.168.0.1
на второй сетевой 192.168.10.1 шлюз пустой ( 0.0.0.0)
на тв 192.168.10.4 шлюз 192.168.10.1
маска 255.255.255.0 везде.
Установить iptables и включить форвардинг:
файл /etc/sysctl.d/30-ipforward.conf
Строка «net.ipv4.ip_forward=1»
полностью выглядит так:
net.ipv4.ip_forward=1
net.ipv6.conf.default.forwarding=1
net.ipv6.conf.all.forwarding=1
командой sysctl net.ipv4.ip_forward=1 пытаюсь включить фордвартинг-результат:sysctl:
permission denied on key 'net.ipv4.ip_forward' что означает отказано в доступе к ключу net.ipv4.ip_forward
прошу подсказать как обойти блокировку.
Спасибо
Последний раз редактировалось
0
avatar
0
avatar
Совсем не понял что вы делаете (но продолжайте).
Рекомендую при ручной настройке IP не использовать IP вначале пула, т.е. 192.168.0.1 -> 0.20. Пусть к ним цепляются автоматом телефоны планшеты — а для ручной настройки лучше использовать например 192.168.0.21,22,23.
0
avatar
Для начала добейтесь чтобы хотя-бы NAT заработал.
А вообще-то для таких задач (резка рекламы для всей подсети) обычно используют что-то вроде squid redirector
Последний раз редактировалось
+1
avatar
попробую позже, при таких настройках когда шлюзом будет IP роутера разве будет возможно использовать Телевизором hosts лист на ПК?
файл /etc/sysctl.d/30-ipforward.conf создал
Строка «net.ipv4.ip_forward=1» вписал
Последний раз редактировалось
0
avatar
вечером попробую поменять адреса второй сетевой (изменить третью триаду). спасибо
Последний раз редактировалось
0
avatar
Значит, где-то ошиблись. Начните сначала, будьте внимательнее.
У Вас две подсети, у них не может быть у обеих одинаковых значений в третьей триаде.
Последний раз редактировалось
+1
avatar
по совету dimonmmk в настройках ТВ шлюз изменил на IP первой сетевой ---результата нет (на IP роутера ----результата тоже нет). пакеты iptables и dhcp установлены
При этих настройках:
3 байта информации 192.168.0. совпадают, т.е на первой сетевой 192.168.0.2 шлюз 192.168.0.1
на второй сетевой 192.168.0.3 шлюз 192.168.0.2
на тв 192.168.0.4 шлюз 192.168.0.3
маска 255.255.255.0 везде
DNS не прописывал
пропала связь с роутером, интернет по первой сетевой есть
Последний раз редактировалось
0
avatar
Роутер — 192.168.0.1
на первой сетевой 192.168.0.2 шлюз 192.168.0.1
на второй сетевой 192.168.10.1 шлюз пустой
на тв 192.168.10.4 шлюз 192.168.10.1
маска 255.255.255.0 везде.
Установить iptables и включить форвардинг:
файл /etc/sysctl.d/30-ipforward.conf
Строка «net.ipv4.ip_forward=1» Если нет, или нет самого файла- создать.

Вообще-то лучше настроить выдачу адресов внутренней подсети через DHCP, это просто.

Похожий случай: forum.manjaro.ru/viewtopic.php?f=23&t=75&p=340&hilit=dimonmmk#p324
Последний раз редактировалось
+1
avatar
ТВ пишет что сеть между ПК и ТВ есть, затык идет на уровне DNS. прописал 8.8.8.8 на ТВ и сетевой карте №2 ПК результат нулевой.
0
avatar
попробовал, сети на тв нет,
В «основные параметры» ставлю галки (подкл. автоматич.) и (все пользователи могут подкл. к этой сети) на 2 картах
3 байта информации 192.168.0. совпадают, т.е на первой сетевой 192.168.0.2 шлюз 192.168.0.1
на второй сетевой 192.168.0.3 шлюз 192.168.0.2
на тв 192.168.0.4 шлюз 192.168.0.3
маска 255.255.255.0 везде
DNS не прописывал
для этого соединения требуется ip4 галки нет на 2 сетевых
идеи кончились. прошу помощи.
Спасибо.
Последний раз редактировалось
0
avatar
спасибо попробую
0
avatar
По идее да.
0
avatar
на ТВ.
Вручную и прописываю IP 192.168.0.3
маску подсети 255.255.255.0 и шлюз (IP второй сетевой 192.168.0.2 )
Так?
Последний раз редактировалось
0
avatar
то есть на ТВ и второй сетевой 192.168.0.2 в одной сети одинаковые значения IP?

Должно быть На ТВ Шлюз = IP второй сетевой (она же раздает?). И IP не должны быть одинаковые, меняйте только последние цифры.
Последний раз редактировалось
0
avatar
Даже если минус добавлю и относительный знак, все равно тоже самое будет. Ошибок нету.
0
avatar
  1. Минусов в два раза меньше чем надо.
  2. Нет вопросительного знака в конце.
Судя по картинке утилита по какой-то причине не отрабатывает.
При загрузке какие-нибудь ошибки есть?
 
По поводу WiFi. Гугление показало что у Вас BCM43142. Есть в репах, находится по названию.
Последний раз редактировалось
0
avatar
0
avatar
Я в недоумении.
Если в системе нет mhwd, то будет ругаться шелл словами вроде
zsh: command not found: mhwd

Если же оно в системе есть, то даст соответствующий выхлоп — для --help это список возможных опций и описание синтаксиса.
Можете выложить скриншот с результатом выполнения нижеследующей команды?
mhwd --help || echo $?
Последний раз редактировалось
0
avatar
Да.Вообще пустая строчка. Ничего не показывает.
Так же при mhwd --help тоже на новую строку покидает, а ничего не показывает
Последний раз редактировалось
0