Manjaro GNOME
   541

Проблема с фотоаппаратом canon.

Всем доброго вечера! Столкнулся с проблемой и не знаю в чем дело. При подключении фотоаппарата к ноутбуку он не отображается не в nautilus не в gThumb и я не могу импортировать фотографии но Darktable его успешно видит и импортирует фотографии, Как такое возможно? может кто сталкивался с такой проблемой и как-то решил?

6 комментариев

avatar
попробуй
lsusb
потом
sudo usb_modeswitch -v VVVV -p PPPP
где VVVV — это vid, а PPPP — pid нужного устройства
у меня так видеорегистратор заводится
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Попробовал но к сожалению не помогло.
lsusb
Bus 003 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 04f2:b3f6 Chicony Electronics Co., Ltd HD WebCam (Acer)
Bus 001 Device 004: ID 04f3:0261 Elan Microelectronics Corp.
Bus 001 Device 006: ID 0489:e05f Foxconn / Hon Hai
Bus 001 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 009: ID 04a9:3217 Canon, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo usb_modeswitch -v 04a9 -p 3217
Look for default devices…
Found devices in default mode (1)
Access device 012 on bus 001
Get the current device configuration…
Current configuration number is 1
Use interface number 0
with class 6
Warning: no switching method given. See documentation
-> Run lsusb to note any changes. Bye!
0
avatar
Я подозреваю, что ваш фотоаппарат не умеет работать в режиме «передачи файлов», а работает в режиме «сканер/камера», это абсолютно нормально для многих моделей. Если в фотоаппарате нет настройки режимов подключения к компьютеру, то сохраняйте фотографии через darktable.
0
avatar
В xfce его nautilus и gthumb видели, все нормально было. А gnome не видит почему то.
0
avatar
gvfs-gphoto2 на месте?
+2
avatar
Спасибо большое! действительно почему то отсутствовал gvfs-gphoto2 пакет. Теперь все хорошо. Спасибо всем откликнувшимся!
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.