Ядро & Оборудование
   250

Как в Manjaro посмотреть версию Bluetooth?

Имеется желание приобрести bluetooth-наушники, а хорошие bluetooth-наушники требуют версию bluetooth от 4.2 и выше. К сожалению, я не знаю какая именно версия bluetooth у меня на компьютере.

P. S. Неактуально, нашел решение. В общем, нужно поставить пакет hciconfig из AUR и выполнить в консоли:
hciconfig -a

В выводе будет нечто подобное:
hci0:   Type: Primary  Bus: USB
        BD Address: 10:63:C8:4E:0F:FC  ACL MTU: 1024:8  SCO MTU: 50:8
        UP RUNNING 
        RX bytes:1286 acl:0 sco:0 events:77 errors:0
        TX bytes:1112 acl:0 sco:0 commands:77 errors:0
        Features: 0xff 0xfe 0x8f 0xfe 0xd8 0x3f 0x5b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
        Link policy: RSWITCH HOLD SNIFF 
        Link mode: SLAVE ACCEPT 
        Name: 'ideapad'
        Class: 0x3c010c
        Service Classes: Rendering, Capturing, Object Transfer, Audio
        Device Class: Computer, Laptop
        HCI Version: 4.1 (0x7)  Revision: 0x0
        LMP Version: 4.1 (0x7)  Subversion: 0x25a
        Manufacturer: Qualcomm (29)

Значение HCI Version и есть версия Bluetooth, у меня например она 4.1, а значит нормального звука в наушниках мне не видать. В скобках можно видеть цифровой код (0x7) и по этому коду также можно расшифровать версию Bluetooth:
| HCI version | Bluetooth version |
|-------------|-------------------|
| 0 (0x0)     | 1.0b              |
| 1 (0x1)     | 1.1               |
| 2 (0x2)     | 1.2               |
| 3 (0x3)     | 2.0               |
| 4 (0x4)     | 2.1               |
| 5 (0x5)     | 3.0               |
| 6 (0x6)     | 4.0               |
| 7 (0x7)     | 4.1               |
| 8 (0x8)     | 4.2               |
| 9 (0x9)     | 5.0               |
| 10 (0xa)    | 5.1               |

7 комментариев

avatar
Версия Bluetooth в основном влияет на скорость и энергосбережение. Да и в принципе это технология передачи данных.
Всё дело в кодеках. У меня на 4.0 прекрасно работает AptX.
А вам какой кодек надо?
Последний раз редактировалось
0
avatar
А фиг его знает) Просто большинство наушников на рынке требуют блютуз пятой версии, на крайняк 4.2, но никак не 4.1 как у меня. Еле нашел нормальные уши для блютуз 4.1, как приедет буду тестить.
Последний раз редактировалось
0
avatar
Они не могут требовать какую-то версию.
Наушники/колонки ПОДДЕРЖИВАЮТ работу с какой-то версией протокола, но есть обратная совместимость вплоть до bluetooth 2.0, так как блютуз 1 версии не обеспечивает скорость для передачи звука нормального качества.
Далее — наушники поддерживают аппаратно кодеки звука, типа AAC, AptX, SBC и прочие.
Например Realmi Buds Q способны декодировать AAC и работают с версией протокола 5.0, но они также подключаются к блютуз 4.0 и декодируют тот же AAC.
Повторюсь — версия блютуз отвечает за скорость передачи, дальность и энергосбережение. Качество же звука зависит от поддерживаемого кодека.
+1
avatar
Если на наушниках написано Bluetooth 5, а на компе у меня стоит 4.1, то уши все равно смогут коннектится и никаких проблем? Это прям 100%? Просто боюсь пролететь с покупкой.
Последний раз редактировалось
0
avatar
100%
0
avatar
Спасибо за ответы. Честно, я не знал этого.
0
avatar
Многие не знают.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.