Ядро & Оборудование
   2642

Обновление mhwd-nvidia ломает систему

Здравствуйте!

Собственно, проблема изложена в заголовке.
Пакеты:
mhwd-nvidia
mhwd-nvidia-470xx
nvidia-utils
opencl-nvidia

если их обновить, система перестает грузиться.
Выдает ошибку при запуске LightDM Display Manager

видеоадаптер GT218 (GeForce 210)

видеодрайвер свободный
video-linux и video-modesetting (обе галки стоят)

Как от этого избавиться?
Снести эти пакеты на…
Или пусть болтаются в необновлённых?

46 комментариев

avatar
неплохо бы увидеть скрин ошибки
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Мне бы тоже…
При загрузке быстро пролетает что-то похожее на журнал, много, а затем экран гаснет, и остается то, что я на писал
0
avatar
Alt+Ctrl+F2 логин+пароль вывод lspci -k | grep nv и inxi -SGxxx
видеодрайвер свободный
video-linux и video-modesetting (обе галки стоят)
? загрузки не мешают
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
+1
avatar
inxi
<code>
System:
  Host: tester Kernel: 5.16.0-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 Console: tty 2 DM: LightDM 1.30.0 Distro: Manjaro Linux
    base: Arch Linux
Graphics:
  Device-1: NVIDIA GT218 [GeForce 210] vendor: Gigabyte driver: N/A
    bus-ID: 01:00.0 chip-ID: 10de:0a65 class-ID: 0300
  Display: server: X.org 1.21.1.1 driver: loaded: nouveau
    unloaded: modesetting alternate: fbdev,nv,vesa tty: 80x30
  Message: Unable to show advanced data. Required tool glxinfo missing.

</code>

lspci
<code>
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
</code>





Вот как-то так…
0
avatar
Да, и ещё:
В журнале есть запись примерно:
ошибка при загрузке модуля nvidia-uvm

а позже про lightdm ошибка с кодом 1
0
avatar
Карта у меня другая, но тоже из древних.Подобное встретил при загрузки последнего образа с не свободными драйверами manjaro mate. Поэтому установил со свободными, обновил систему, поставил в моем случае mhwd-nvidia-390xx
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
У меня две похожих машины с одинаковой видеокартой. Но вторая работает и обновляется без проблем.
Что мне делать-то?
Сейчас пропускаю обновления.
0
avatar
Привет покажите выводы с обоих машин
inxi -Gxxx
и
pacman -Qi  mhwd-nvidia-340xx 
Что мне делать-то?
пробовать удалить через памак вот это перезагрузится если со свободными драйверами графика не взлетела, вернуть через tty2 пакет mhwd
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Показываю.
Проблемная машина:
<code>
[tester@tester ~]$ inxi -Gxxx
Graphics:
  Device-1: NVIDIA GT218 [GeForce 210] vendor: Gigabyte driver: nouveau
    v: kernel bus-ID: 01:00.0 chip-ID: 10de:0a65 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: 1280x1024~60Hz
    s-dpi: 96
  OpenGL: renderer: NVA8 v: 3.3 Mesa 21.2.5 direct render: Yes


[tester@tester ~]$ pacman -Qi mhwd-nvidia-340xx
Название             : mhwd-nvidia-340xx
Версия               : 340.108-1
Описание             : MHWD module-ids for nvidia 340.108
Архитектура          : any
URL                  : http://www.nvidia.com/
Лицензии             : custom
Группы               : Нет
Предоставляет        : Нет
Зависит от           : Нет
Доп. зависимости     : Нет
Требуется            : Нет
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 2,42 KiB
Сборщик              : Philip Mueller <philm<a href="https://manjaro.ru/profile/manjaro/" class="ls-user">manjaro</a>.org>
Дата сборки          : Чт 26 дек 2019 12:17:38
Дата установки       : Пн 30 дек 2019 09:23:36
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : Подпись
</code>

Контрольный образец
<code>
lexa1@W360 ~ $ inxi -Gxxx
Graphics:
  Device-1: NVIDIA GT218 [GeForce 210] vendor: Gigabyte driver: nouveau
    v: kernel bus-ID: 02:00.0 chip-ID: 10de:0a65 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: 1280x1024~60Hz
    s-dpi: 96
  OpenGL: renderer: NVA8 v: 3.3 Mesa 21.2.5 direct render: Yes


lexa1@W360 ~ $ pacman -Qi  mhwd-nvidia-340xx
Название             : mhwd-nvidia-340xx
Версия               : 340.108-1
Описание             : MHWD module-ids for nvidia 340.108
Архитектура          : any
URL                  : http://www.nvidia.com/
Лицензии             : custom
Группы               : Нет
Предоставляет        : Нет
Зависит от           : Нет
Доп. зависимости     : Нет
Требуется            : Нет
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 2,42 KiB
Сборщик              : Philip Mueller <philm<a href="https://manjaro.ru/profile/manjaro/" class="ls-user">manjaro</a>.org>
Дата сборки          : Чт 26 дек 2019 12:17:38
Дата установки       : Пн 30 дек 2019 09:17:46
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : Подпись
</code>

Похоже, что обновление пакетов nvidia ставит драйвер nouveau вместо свободного
0
avatar
Прошу прощения за мою невнимательность выше не заметил что у Вас ядро
Kernel: 5.16.0-1-MANJARO x86_64 bits
отчего и
driver: loaded: nouveau
, с другой стороны на nouveau иксы должны работать и на Kernel: 5.16. советую понизить ядро
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Уточняю.
Ситуация началась с ядром 5.15. Попытки загрузить более ранние ядра не изменили ситуацию. И обновление ядра ситуацию не меняет.
Без обновления указанных пакетов работает номально на всех версиях ядра.
0
avatar
Без обновления указанных пакетов работает номально на всех версиях ядра.
Остаются три пути 1 заполнить существующие строки в etc/pacman.conf
Спойлер!
2 путь полностью отказаться от обновлений системы и 3-свободный драйвер nouveau.
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
И как пойти по третьему пути?
0
avatar
Раз не охота посмотреть Вики делаем так обратить внимание на
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Обижаешь, начальник!
На скриншоте (моём) выше видно, что у меня нет строки video-nvidia.
Что делать-то?
0
avatar
И как пойти по третьему пути?
давайте на Вашем примере попробуем раз графически вызывает трудности
Просто покажите
mhwd -li -d --pci 
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
Вот, пожалуйста:
<code>
[tester@tester ~]$ mhwd -li -d --pci
   NAME:	video-modesetting
   ATTACHED:	PCI
   VERSION:	2020.01.13
   INFO:	X.org modesetting video driver.
   PRIORITY:	1
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 
   VENDORIDS:	* 

   NAME:	video-linux
   ATTACHED:	PCI
   VERSION:	2018.05.04
   INFO:	Standard open source drivers.
   PRIORITY:	2
   FREEDRIVER:	true
   DEPENDS:	-
   CONFLICTS:	-
   CLASSIDS:	0300 0380 0302 
   VENDORIDS:	1002 8086 10de 

</code>
0
avatar
И как пойти по третьему пути?
А теперь посмотрите какой драйвер Вы используете
lspci -k | grep -A 2 -E "(VGA|3D)"
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
А пожалуйста!
Пациент:

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
	Subsystem: Gigabyte Technology Co., Ltd Device 3530
	Kernel driver in use: nouveau
	Kernel modules: nouveau


Контрольный экземпляр:

02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
	Subsystem: Gigabyte Technology Co., Ltd Device 3530
	Kernel driver in use: nouveau
	Kernel modules: nouveau

Вроде одинаково…
Последний раз редактировалось
0
avatar
и 3-свободный драйвер nouveau.
о чем было сказано выше
Kernel driver in use: nouveau
Ваша реальность
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
И как это решает мою проблему?
0
avatar
пусть болтаются в необновлённых
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
То есть проблема неразрешима?
0
avatar
Ну почему-же
Вот
Тута
inxi -SGxxx --no-host  ✔
System:
Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: Cinnamon 5.0.7 tk: GTK 3.24.30 vt: 7 dm: LightDM 1.30.0
Distro: Manjaro Linux base: Arch Linux
Graphics:
Device-1: NVIDIA GF108 [GeForce GT 440] vendor: Gigabyte driver: nvidia
v: 340.108 bus-ID: 01:00.0 chip-ID: 10de:0de0 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 driver: loaded: nvidia
s-res: 1920x1080 s-dpi: 96
OpenGL: renderer: GeForce GT 440/PCIe/SSE2 v: 4.4.0 NVIDIA 340.108
direct render: Yes

pacman -Qs nvidia-340xx
local/nvidia-340xx-dkms 340.108-26
NVIDIA driver sources for linux, 340xx legacy branch
local/nvidia-340xx-utils 340.108-1
NVIDIA drivers utilities
pacman -Qs mhwd
пусто
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
И что сделать-то?
Это команды вывода информации
0
avatar
И что сделать-то?
Можете установить свободные драйвера с помощью mhwd, можете установить nvidia-340xx-dkms в этом случае пакеты
mhwd-nvidia
mhwd-nvidia-470xx
nvidia-utils
opencl-nvidia
будут не нужны, работать система будет как в этом примере
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
+1
avatar
Можете установить свободные
драйвера с помощью mhwd
С этого места поподробнее, пожалуйста
0
avatar
пожалуйста
или
sudo mhwd -a pci free 0300 
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
<code>
[tester tester]# mhwd -a pci free 0300
> Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:10de:0a65) Display controller nVidia Corporation GT218 [GeForce 210]
[tester tester]# 
</code>
Ииии?..
0
avatar
Ииии?..
Спойлер!
sudo mhwd -a pci free 0300  ✔
[sudo] пароль для v62:
> Using config 'video-linux' for device: 0000:01:00.0 (0300:10de:0de0) Display controller nVidia Corporation GF108 [GeForce GT 440]
> Installing video-linux…
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-linux/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0380
Processing classid: 0302
:: Обновление баз данных пакетов…
core downloading…
extra downloading…
community downloading…
multilib downloading…
разрешение зависимостей…
проверка конфликтов…
Пакеты (16) lib32-libva-2.13.0-1 lib32-libvdpau-1.4-1 libxvmc-1.0.12-3 lib32-libva-vdpau-driver-0.7.4-6 lib32-mesa-vdpau-21.2.5-1 lib32-vulkan-intel-21.2.5-1 lib32-vulkan-radeon-21.2.5-1 libva-mesa-driver-21.2.5-1 libva-vdpau-driver-0.7.4-5 mesa-vdpau-21.2.5-1 vulkan-intel-21.2.5-1 vulkan-radeon-21.2.5-1 xf86-video-amdgpu-21.0.0-2 xf86-video-ati-1:19.1.0.r9.g5eba006e-2 xf86-video-intel-1:2.99.917+916+g31486f40-2 xf86-video-nouveau-1.0.17-2
Будет загружено: 18,38 MiB
Будет установлено: 71,20 MiB
:: Приступить к установке? [Y/n]
:: Получение пакетов…
lib32-mesa-vdpau-21.2.5-1-x86_64 downloading…
mesa-vdpau-21.2.5-1-x86_64 downloading…
libva-mesa-driver-21.2.5-1-x86_64 downloading…
vulkan-intel-21.2.5-1-x86_64 downloading…
lib32-vulkan-intel-21.2.5-1-x86_64 downloading…
lib32-vulkan-radeon-21.2.5-1-x86_64 downloading…
vulkan-radeon-21.2.5-1-x86_64 downloading…
xf86-video-intel-1:2.99.917+916+g31486f40-2-x86_64 downloading…
xf86-video-ati-1:19.1.0.r9.g5eba006e-2-x86_64 downloading…
xf86-video-nouveau-1.0.17-2-x86_64 downloading…
lib32-libva-2.13.0-1-x86_64 downloading…
xf86-video-amdgpu-21.0.0-2-x86_64 downloading…
libva-vdpau-driver-0.7.4-5-x86_64 downloading…
lib32-libva-vdpau-driver-0.7.4-6-x86_64 downloading…
libxvmc-1.0.12-3-x86_64 downloading…
lib32-libvdpau-1.4-1-x86_64 downloading…
проверка связки ключей…
проверка целостности пакета…
загрузка файлов пакетов…
проверка возможных конфликтов файлов…
проверка доступного места…
:: Обработка изменений пакета…
установка xf86-video-ati…
установка xf86-video-amdgpu…
установка libxvmc…
установка xf86-video-intel…
>>> This driver now uses DRI3 as the default Direct Rendering
Infrastructure. You can try falling back to DRI2 if you run
into trouble. To do so, save a file with the following
content as /etc/X11/xorg.conf.d/20-intel.conf:
Section «Device»
Identifier «Intel Graphics»
Driver «intel»
Option «DRI» «2» # DRI3 is now default
Option «AccelMethod» «sna» # default
Option «AccelMethod» «uxa» # fallback
EndSection
Дополнительные зависимости для 'xf86-video-intel'
libxrandr: for intel-virtual-output [установлено]
libxinerama: for intel-virtual-output [установлено]
libxcursor: for intel-virtual-output [установлено]
libxtst: for intel-virtual-output [установлено]
libxss: for intel-virtual-output [установлено]
установка xf86-video-nouveau…
установка vulkan-intel…
Дополнительные зависимости для 'vulkan-intel'
vulkan-mesa-layers: additional vulkan layers
установка vulkan-radeon…
Дополнительные зависимости для 'vulkan-radeon'
vulkan-mesa-layers: additional vulkan layers
установка libva-mesa-driver…
установка libva-vdpau-driver…
установка mesa-vdpau…
установка lib32-vulkan-intel…
Дополнительные зависимости для 'lib32-vulkan-intel'
lib32-vulkan-mesa-layers: additional vulkan layers
установка lib32-vulkan-radeon…
Дополнительные зависимости для 'lib32-vulkan-radeon'
lib32-vulkan-mesa-layers: additional vulkan layers
установка lib32-libva…
Дополнительные зависимости для 'lib32-libva'
lib32-libva-vdpau-driver: vdpau back-end for nvidia [ожидание]
lib32-libva-intel-driver: back-end for intel cards
установка lib32-libvdpau…
установка lib32-libva-vdpau-driver…
установка lib32-mesa-vdpau…
:: Запуск post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…
xf86-video-ati: причина установки изменена на 'установлен явно'
xf86-video-amdgpu: причина установки изменена на 'установлен явно'
xf86-video-intel: причина установки изменена на 'установлен явно'
xf86-video-nouveau: причина установки изменена на 'установлен явно'
vulkan-intel: причина установки изменена на 'установлен явно'
vulkan-radeon: причина установки изменена на 'установлен явно'
libva-mesa-driver: причина установки изменена на 'установлен явно'
libva-vdpau-driver: причина установки изменена на 'установлен явно'
mesa-vdpau: причина установки изменена на 'установлен явно'
lib32-vulkan-intel: причина установки изменена на 'установлен явно'
lib32-vulkan-radeon: причина установки изменена на 'установлен явно'
lib32-libva-vdpau-driver: причина установки изменена на 'установлен явно'
lib32-mesa-vdpau: причина установки изменена на 'установлен явно'
> Successfully installed video-linux
   ~   ✔  42s 
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar

[tester tester]# mhwd -a pci free 0300
> Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:10de:0a65) Display controller nVidia Corporation GT218 [GeForce 210]
[tester tester]# 
вольный перевод гласит
Пропуск уже установленной конфигурации 'video-linux' для устройства: 
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Спасибо, я по-английски читаю…
Именно, что УЖЕ УСТАНОВЛЕННОЙ.
Я уже не раз здесь это говорил.

Так всё-таки, что делать-то?
0
avatar
Больше идей нет, либо я что-то не правильно понял
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
Давай ещё раз.
Если вот это обновить, система не грузится.

Наверное, от чего-то надо избавится…
0
avatar
Привет!
Наверное, от чего-то надо избавится…
от всего.
Должно работать и на
xf86-video-nouveau
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
С Новым Годом!

Работать должно, но не работает…

Так что делать-то?..
0
avatar
Привет и да с Новым Годом, взаимно
Работать должно, но не работает…
Давайте смотреть как видим работает. Теперь чтобы ответить на Ваш главный вопрос у себя смотрите
glxinfo | grep OpenGL
работа на драйвере, дальше смотрим
pacman -Qs mhwd 
и начиная сверху удаляем
sudo pacman -Rns mhwd  reboot
иксы запустились, удаляем следующий установленный локально пакет, опять
reboot
Таким образом Вы поймете обновлять, удалять, игнорировать обозначенные пакеты
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
Но mhwd мне нужен, я регулярно меняю диски вообще всякое оборудование подключаю к этой станции
0
avatar
Но mhwd мне нужен,
вот и ответ на Ваш вопрос так как mhwd-nvidia* зависит от пакета mhwd-db, который в свою очередь зависит от пакета mhwd
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
Ответа не понял, но…

Вести с полей:
Обновил mhwd-nvidia*

Остались:
nvidia-utils и opencl-nvidia
На какой пакет ставим?
0
avatar
Привет! Дайте вывод
pacman -Qi mhwd;pacman -Qi nvidia;pacman -Qs nvidia 
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
А пожалуйста:
<code>
[tester@tester ~]$ pacman -Qi mhwd
Название             : mhwd
Версия               : 0.6.5-2
Описание             : Manjaro Linux Hardware Detection library and application
Архитектура          : x86_64
URL                  : http://git.manjaro.org
Лицензии             : GPL
Группы               : Нет
Предоставляет        : Нет
Зависит от           : hwinfo  mesa  mhwd-db  v86d  pacman
Доп. зависимости     : lib32-mesa: for 32bit libgl support [установлено]
Требуется            : python-manjaro-sdk
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 247,50 KiB
Сборщик              : Philip Mueller <philm<a href="https://manjaro.ru/profile/manjaro/" class="ls-user">manjaro</a>.org>
Дата сборки          : Вт 15 сен 2020 21:45:58
Дата установки       : Пн 11 янв 2021 13:32:39
Причина установки    : Явно установлен
Установочный скрипт  : Yes
Проверен             : Подпись

[tester@tester ~]$ pacman -Qi nvidia
ошибка: пакет 'nvidia' не найден

[tester@tester ~]$ pacman -Qs nvidia
local/egl-wayland 2:1.1.9+r3+g582b2d3-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 495.44-1
    NVIDIA NV-CONTROL X extension
local/mhwd-nvidia 495.44-5
    MHWD module-ids for nvidia 495.44
local/mhwd-nvidia-340xx 340.108-1
    MHWD module-ids for nvidia 340.108
local/mhwd-nvidia-390xx 390.147-2
    MHWD module-ids for nvidia 390.147
local/mhwd-nvidia-470xx 470.94-1
    MHWD module-ids for nvidia 470.94
local/nvidia-utils 495.44-4
    NVIDIA drivers utilities
local/nvtop 1.2.2-1
    An htop like monitoring tool for NVIDIA GPUs
local/opencl-nvidia 495.44-4
    OpenCL implemention for NVIDIA
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards
</code>
0
avatar
local/nvidia-utils 495.44-4
NVIDIA drivers utilities
Не понимаю зачем это установлено, скорее всего с этим графика не стартанет, поэтому
nvidia-utils и opencl-nvidia
первое
sudo pacman -R nvidia-utils 
а второе можете удалить или пусть болтается в системе
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Привет!
Так ведь стартует графика…

Буду пробовать.
0
avatar
Буду пробовать.
тоже пробую ставлю nvidia-utils и наблюдаю (курсор), точнее квадрат Малевича с мигающим "-" в левом углу монитора
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
0
avatar
Можно вообще выкинуть mhwd из системы. Если Вы не перетыкаете железки оно не нужно.
+1
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.