Manjaro KDE Edition
   382

Невозможность обновления

Доброго времени суток. Manjaro KDE 18.1.0. Сегодня при обновлении получаю вот это — ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: unable to satisfy dependency 'pamac-common<9.0.0' required by pamac-qt
Перелистал форумы, ответа не нашел. Буду благодарен, если кто толком объяснит что делать.

7 комментариев

avatar
1) может в репозиториях забыли пакет обновить, подожди немного
2) можешь поменять pamac-qt на pamac-gtk, но не факт что ту же ошибку не получишь
3) в жопу памак. проще консоль юзать
+2
avatar
Согласен с пунктом 3. «Гуй пакетного менеджера это образовательная программа, учащая пользователя чинить поломанные зависимости и виртуозно ругаться матом.»
А разгадка, скорее всего, в отсутствии галочки «включить откат версий».
Последний раз редактировалось
+2
avatar
Это и было при обновлении через консоль.
0
avatar
Какой командой обновлялись?
0
avatar
Галочка «включить откат версий» стоит.
0
avatar
Большое спасибо всем кто откликнулся. Проблема решена путем восстановления из первой версии резервной копии и дальнейшего обновления. Отдельное спасибо PavelMilko и v-62.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.