Manjaro KDE Edition
   1740

Plasma 5.21.2 - баги оформления и локализации

Здравствуйте.

Перво-наперво прошу очень сильно не ссылаться на имеющиеся топики, ибо: ознакомился, попробовал, не помогло.
Итак.

OS: Manjaro 20.2.1 Nibia
Kernel: x86_64 Linux 5.9.16-1-MANJARO
DE: KDE 5.79.0 / Plasma 5.21.2
GPU: GeForce 315M, драйвер проприетарый (НАДО! на открытом ад полный)
Сессия на Х11
Установил сборку с минимальным КДЕ от сообщества. Реозитории ветки Stable, проблем не должно было бы быть из-за новых пакетов. В виртуалке всё ок, но на этом ноуте…

Поначалу слетало оформление приложений GTK при ребуте (касается предустановленных тем) — поставил тему, которая не слетала. Но потом КДЕ начало обновляться, и на сегодняшний день к чему всё привело:

1) постоянно при выходе-входе в систему слетает калибровка гаммы в соотв. настройке KDE. Происходит это между логином в систему и появлением десктопа. Я сделал скрипт с калибровкой гаммы черех xrandr, поместил его везде, в автозапуск и xinitrc с xprofile — всё равно сбрасывает, причём не всегда. ЗАкономерности не вижу.
2) часть надписей стало на английском. В меню копировать-вставить англофицировались, в новой оболочке настроек внешнего вида кнопки на английском, в Kde-Store (или как называется набор утилит для установки виджетов и оформлений) — тоже, в т.ч. выпадающие меню, где опции сортировки и прочее. Советы по перегенерации локали и сопутствующее — всё не помогло, как и переустановка glibc, как и переустановка КДЕ. И ещё про выпадающие менюшки:
3) у них нет фона под текстом. И у многих всплывающих подсказок в менеджере настроек КДЕ. То есть в окне самого менеджера всё нормально, но стоит войти в любую настройку, н-р, шрифтов (та у некоторых опций есть такие же подсказки) — их не видно. Светлые окна, светлые буквы, нет фона.

Где только я не гуглил, где только не спрашиваю — такое чувство, будто эти баги лишь у меня одного (про гамму на англоязычном багтрекере КЕД всё же есть, багу почти год, и у меня вылез только сейчас). Пожалуйста, помоите починить это безобразие или хотя бы разобраться, откуда растут ноги у этих проблем. Полная переустановка системы и смена окруения — не вариант, хочу починить Кеды. Нужную инфу пришлю, только скажите, что именно показать.

Сразу подмечу — с системной локалью в конфигах всё нормально. По поводу всплывающих подсказок без фона — эффекты не при чём, оформление тоже, ибо пробовал разные темы, везде этот косяк.

46 комментариев

avatar
обсуждение в чате t.me/manjarolinux/1038698

> калибровка гаммы
ээ понятия не имею. красный похож на красный вроде, но у меня монитор с уплывшими цветами, его не настроить нормально всё равно

> часть надписей стало на английском
бывает такое, на работе у меня до сих пор часть системы рус часть англ. GTK с русским по-моему, руки не доходят.
дома строго англ ставил, так и осталось
Локализуют обычно с пакетом mintlocale из аур, вроде запустить его под sudo и применить язык в этой утилите. ТАкже проконтролировать чтобы в меню настроек плазмы русский стоял вверху списка.
Ну, и может ещё что, не факт что хватит

> у них нет фона под текстом
breeze dark, всё норм.
попробуй создать нового пользователя, вроде конфиг кед под него новый создастся. Проверь как будет в нем
0
avatar
Минтлокаль, увы, не запускается, а вот артефакты типа отсутствующего фона в подсказках — это у нового юзера в порядке, благодарю. Думаю, попробую вычистить конфиги в домашнем каталоге…

UPD1 — баг с всплывающими подсказками — я решил проблему удалением /home/user/.config/kdeglobals, но придется заново настроить под себя десктоп (касается оформления), ибо сбросится на дефолт
Последний раз редактировалось
0
avatar
В общем, ничто из предложенного не починило язык. А предлагалось и переустановка glibc, и перевод всю систему на английский, а потом снова на русский — тот же баг, отсутствует русификация базовых функциональных кнопок (применить, ок, отмена), пунктов меню (копировать-вставить), почти все пункты меню дельфина и так далее. Всё то, что обновлялось с начала этого года в окружении.

Пожалуйста, кто-нибудь, скажите название пакета в репозитории Манджаро, отвечающего за русскую локализацию КДЕ
0
avatar
KDE имеет свой собственный файл настройки локализации.
Я уже писал про это на форуме несколько раз.
И периодически кеды пихают в этот самый файл всякое непотребство, которое потом не могут обработать.
Хранится это дело в ~/.config/plasma-localerc.
0
avatar
Спасибо, к сожалению тем тут много, найти тяжело — это одно. А второе — манипуляц ии с файлами из домашнего каталога не решают проблемы с локализацией. Создаем нового пользователя — всё так же, те самые кнопки и пункты меню на инглише. Удаляем этот файл — не меняется ничего.
Если там написано
[Translations]
LANGUAGE=ru:en_US
пробую менять на
[Translations]
LANGUAGE=ru:ru_RU

и тоже ничего не меняется. Потому я и предположил, что есть некий пакет, как в арче — kde-l10n-ru или как-то так. Не знаю, поскольку если в новой учётке и в старой при удалении всех конфигов проблемы никак не решаются, то проблема пришла куда-то в файлы системного каталога, трогать которые я не могу, не зная, что нужно.

Итого: ~/.config/plasma-localerc в результате моих исследований никак не влияет на данную проблему. Будут ещё идеи?)
0
avatar
Я сам кеды не использую и не знаю тонкостей их настройки.
Однако в виртуалке кеды у меня установлены и как-то русифицированы, и вот какими мыслями по этому поводу я могу с Вами поделиться.

1. При создании нового пользователя используется системная локаль. Если системная локаль английская, то и кеды по дефолту будут английскими. Русифицировать их приходится потом.

2. Локаль и русификация в кедах включаются отдельными опциями. Локаль зависит от региона.

Перевод интерфейса по умолчанию — выбирается отдельно.Предварительно требуется нужные языки добавить в список.

файл ~/.config/plasma-localerc с выбранными выше настройками выглядит так:


3. Пакет kde-l10n-ru в арче и в манжаре БЫЛ, и действительно, он и русифицировал интерфейс кед в прошлой версии. Теперь этого пакета НЕТ, ни в арче ни в манжаре. Выпилили отовсюду.

4. Интерфейс не изменяется на лету, только после перезапуска сеанса кед.

Я русифицировал кеды именно так, мышом, без правки файлов вручную. Сейчас обновлю их, посмотрю еще раз. Вдруг что-то там изменилось…
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
ЗЫ: После обновления (не обновлял давно, с тех пор как поставил (уж не помню зачем)) в виртуалку версию manjaro-kde-20.2-201203) локализация стала только лучше- в тех немногочисленных местах где до обновления интерфейс еще был английским, все стало полностью русским. По крайней мере там где я успел заметить.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Создаем нового пользователя — всё так же, те самые кнопки и пункты меню на инглише.
Тогда остается действительно предположить отсутствие пакетов l10n. Но выше говорят что его куда-то продевали.
И есть еще вариант: DM через accountsservice надругается над локалью.
Выхлоп locale что говорит?
Последний раз редактировалось
0
avatar
Отвечаю всем по очереди.
dimonmmk Про настройки в самом КДЕ — да, конечно, с ними в первую очередь всё прошерстил, у меня там всё, как положено, потому и жалуюсь)

Gambit_VKM выхлоп даёт всё русское:

LANG=ru_RU.UTF-8
LC_CTYPE=«ru_RU.UTF-8»
LC_NUMERIC=«ru_RU.UTF-8»
LC_TIME=«ru_RU.UTF-8»
LC_COLLATE=«ru_RU.UTF-8»
LC_MONETARY=«ru_RU.UTF-8»
LC_MESSAGES=«ru_RU.UTF-8»
LC_PAPER=«ru_RU.UTF-8»
LC_NAME=«ru_RU.UTF-8»
LC_ADDRESS=«ru_RU.UTF-8»
LC_TELEPHONE=«ru_RU.UTF-8»
LC_MEASUREMENT=«ru_RU.UTF-8»
LC_IDENTIFICATION=«ru_RU.UTF-8»
LC_ALL=

В том-то и дело… в том-то всё и дело..(
Выглядит всё так, будто файл локализации повреждён. Тот некий файл (или несколько файлов), в котором и лежит русский текст для всего ентого.

То есть, если кто забыл, ещё раз опишу проблему: система на русском. Но в Дельфине, например, половина надписей в менюшках русские, половина — английские. В контекстных меню на рабочем столе то же самое (cut, copy, undo...), в фирменых кедовских оболочках, через которые мы ставим всякие темы, виджеты и прочее — тоже почти всё на английском. И вот всё это изначально было русским, а потом ПОСТЕПЕННО приходили обновления и англофицировали все эти места вместе с собой.
Последний раз редактировалось
0
avatar
всё это изначально было русским, а потом ПОСТЕПЕННО приходили обновления и англофицировали все эти места вместе с собой.
Во как… А не связано ли это с версией манжаровских предустановок для плазмы?
У Вас какая версия стоит, крайняя или одна из прошлых? Почему-то в репах доступны три разных пакета.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
А ёж его знает.

У меня крайняя стоит. Хотя я ставил КДЕ Минимал (я об этом сразу сказал), но до сих пор не пойму, на что может влиять просто отсутствие стапятисот программулин из коробки. В репах настройки для КДЕ Минимал есть, но фиг их поставишь — ругаются. Сносить этот пакет я не пробовал, ибо не знаю, что он собой представляет и к чему может привести его снос. Просто переустановить всё это дело — пробовал ещё марта этак 10-го, переустановка пакета с кедами, установка сопутствующих пакетов для КДЕ, мета, которые содержали ещё стопицот ненужных прог (пришось сносить руками), все эти манипуляции ни в положительном, ни в отрицательном ключе, ВООБЩЕ НИКАК не повлияли на описанные баги, в т.ч. на локализацию…

Я форумы-то почитывал, и всё, что уже нашёл тут, пробовал… Ничего не меняет ситуацию. Баг с локализацией всегда имеется, всегда один, на обни и те же надписи. С гаммой всё так же.
Последний раз редактировалось
0
avatar
Кавычки форумный парсер изуродовал или там действительно елочки?
Попробуйте в ~/.config/plasma-localerc запихать такое:
[Formats]
LANG=en_US.UTF-8
LC_COLLATE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
useDetailed=true

[Translations]
LANGUAGE=ru:en_US

Хотя, конечно, лучше бы этот файлик у живого кедераста взять.

Также, как предлагалось выше, можно попробовать создать второго пользователя и посмотреть что у него с локалью будет.
Последний раз редактировалось
0
avatar
Это уже не имеет смысла, только что пришло обновление и сломало систему мне, вижу курсор и чёрный прямоугольник малевича.
У нового пользователя с локалью всё ТАК ЖЕ, я уже говорил и, вроде, не 1 раз.
0
avatar
Это уже не имеет смысла, только что пришло обновление и сломало систему мне, вижу курсор и чёрный прямоугольник малевича.
Зашибись. В fallback-mode то же самое?
У нового пользователя с локалью всё ТАК ЖЕ, я уже говорил
Забыл про этот момент. Приношу извинения.
Но аналогичное поведение разных пользователей с почти стопроцентным шансом исключает ошибку в конфигах юзера.
0
avatar
Как загрузиться в fallback? Никогда этого не касался и не могу нагуглить

А я кажется понял, где он. В грубе 2 строки, только при моём разрешении экрана они не отображаются полностью. Обе, какие не выбираю — результат один и тот же. Вторая, видимо, и есть фоллбэк. Так чт ответ — да, то же самое в нём
Последний раз редактировалось
0
avatar
Да, все верно.
Тогда остается LiveUSB и manjaro-chroot с него.
0
avatar
а дальше что? Как чинить-то это, откатить или что? Я не то, что полный нуб, но вот так системы поднимать не приходилось — не падали до такой степени.
0
avatar
Я бы для начала посмотрел на вывод lostfiles (если система обновилась криво там скорее всего будет насрано) и вывод smartctl (а вдруг винт помирает). Потом переставил бы ядро (неплохо иметь в системе два ядра — latest и lts: если в свежем что-нибудь вдруг отвалится, то можно выбрать долгоиграющее).

А, да, еще такой нюанс: если в GRUB в опциях ядра имеется опция quiet, то ее стоит стереть и посмотреть не матюкается ли на что сустемда при попытке загрузки.
Последний раз редактировалось
0
avatar
Винт помирает — исключено, он новый.

lostfiles — насрано там только перечислением тем SDDM-а. Мне ни о чём не говорит это.
Ядро — ну поставил 5.10 — и ничего не поменялось, кроме версии ядра. Всё тот же чёрный экран и те же условия. Щас поставлю 5.4, но не думаю, что что-то изменится. Мне тут, похоже, тотально не прёт, у всех всё работает, у одного меня падает, хотя я систему не ковырял и нубских твиков не проводил

quiet затёр — ничего не увидел в плане ругани. Грузится быстро, правда, мог не углядеть. Там можно на паузу ставить?

Вообще загружается всё, включая проприетарные нвидиа-драйвера. Потом мы видим наш курсорчик мышки, а дальше всё. Чёрный экран и курсор.
Последний раз редактировалось
0
avatar
Винт помирает — исключено, он новый.
Увы, тут никто не застрахован.
lostfiles — насрано там только перечислением тем SDDM-а. Мне ни о чём не говорит это.
Это фигня, .cache, .conf и .pacnew не в счет. Вот когда там в выводе оказываются куски zlib, ядерные модули и ли еще что-нибудь подобное, то значит что-то идет не так.

Насчет параметра quiet. У Вас раньше лог загрузки показывался?
0
avatar
не, никогда на физ. машине, или только в самом начале на свободном драйвере. Потом нет. Драйвер проприетарный из аура собирал, думаю попробовать его грохнуть и завестись на свободном, но не могу разобраться, как, ибо mhwd не помогает, она видит только свободный из репа...(((

Ещё. Я себе сделал автологин в систему. Щас попробую убрать его как-нибудь, вдруг СДДМ увижу. Вдруг он, ЗАРАЗА, решил меня на вейланд перевести, хотя как…
0
avatar
Да, вариант с видеодрайвером вполне возможен. Либо DM не может стартануть нормально.
В tty переключиться можете? Если да, проверьте systemctl status sddm.service.
quiet затёр — ничего не увидел в плане ругани. Грузится быстро, правда, мог не углядеть. Там можно на паузу ставить?
ЕМНИП, нет. Но красная надпись [FAILED] бросается в глаза если что-то идет не так.
0
avatar
sddm работает, более того — я убрал автовход и теперь могу его созерцать. Вместо выбранной мною темы вижу нечто очень древнее и стандартное, покрытое надписями о том, что мою тему загрузить ну никак нини. При попытке же войти в систему — знакомый курсор на чёрном экране. В этом месте обычно заставочка появляется, а теперь вот так… Вроде как и надежда есть. Но где бы копать, чтобы вернуть дефолт или переустановить всё это… не знаю, в общем, мозги уже не варят…


ЕЕЕЕЕЕЕЕЕ!!!

downgrade kio до 5.79.0 — вот решение проблемы. На скрине написаны симптомы частично. Я поставил xfce, оно запустилось, попробовал запускать программы из КДЕ — выдавали ошибку
www.reddit.com/r/ManjaroLinux/comments/m89w7o/kde_undefined_symbol_error/

вот моя ситуация, и вот как она решается!)

Кеды live again, а значит, будем чинить локаль, но потом, завтра… или послезавтра…
Последний раз редактировалось
+2
avatar
Баг с локализацией всегда имеется, всегда один,
Частично подтверждаю т к сие происходит только если установка системы была на аглицком языке и тд при последующей локализации на русский этот баг есть. А вот при установке системы на родном языке все хорошо
?
p5ql/epu q9300
0
avatar
Довольно странно, ибо ставил я на русском, хотя мало ли что тогда было. Интересно вот что: в файле со списком локалей нужные (английская и русская) раскомменчены были не в самом списке, а в блоке, подписанном как Calamares, то есть это несколько намекает, что я всё же на русском ставил, хотя я мог просто выбрать русский язык в процессе установки, а запустил её на английском. Но очень странно это. Ладно бы, что баг есть, но как-то же его нужно починить. Что-то снести и поставить заново, но что? Я кстати делал переустановку всех имеющихся пакетов, вот только эта процедура (не особо быстрая) ВООБЩЕ ничего не изменила…
0
avatar
Проверял по условиям топика. KDE minimal образ.Установка calamares, локаль английская, обновление, смена ядра, сразу бросается в глаза , хотя русского не должно быть.Далее смена локали и получаем баги Повторюсь при установке системы на родном языке все OK
?
p5ql/epu q9300
0
avatar
у Вас же, я так понимаю, просто после обновления переключились настройки, верно? Поэтому всё стало на английском. У меня всё на русском, кроме тех частей КДЕ, обновления к которым приходили за эти 2-3 месяца. То есть у меня не было английского языка в SDDM, не было разделения локализации, как на скрине, на английский перевод и русские форматы. У меня просто пришли компоненты новой версии и не перевелись (до сих пор) на русский. Некоторые пункты меню (причём базовые), интерфейс настройщика тем оформления, интерфейс загрузки новых тем и виджетов, многие пункты меню дельфина — вот это английское. Но остальное, как положено, русское. И как бы я не играл с настройками, как бы не менял языки, оно остаётся таким…
0
avatar
Могу предложить костыль. tcsh в качестве шелла. Оно использует свои настройки локали. И, вроде бы, если оно login-shell, то оно и применяется. Вроде бы. Как это будет работать с кедами я не в курсе, но с bspwm и крысой вроде я на подобные грабли лбом собирал.
В целом все зашибись получается, но придется жить с tcsh, который совместим исключительно с csh и вообще пришел из мира бздунов.
Повторюсь. Это не решение, а костыль (для не фанатов TENEX shell). Со спорной работоспособностью в кедах.
Последний раз редактировалось
0
avatar
Короче. Нашёл на некоем форуме гентушников внезапно проблемы с локализацией, похожие на мои, но не идентичные им. Там речь пошла о пакете ki18-n, и вот что интересно. У меня в системе установлен пакет из git, и от него зависит чуть менее, чем всё. При этом имеется в наличии в экстра-репе пакет версии 5.80.0-1. Понятно, что из-за зависимостейне могу я просто так взять и снести один, чтобы потом накатить другой. Поэтому вопрос к тем, у кого кеды — у вас какая версия стоит и почему, ответ обоснуйте?
Последний раз редактировалось
0
avatar
можно попробовать переименовать .config в домашней директории
<code>sudo mv /home/vital/.config .config1</code>
в моем случае, сбросятся все настройки ну а конфиги программ будут в переименованном файле
Короче. Нашёл на некоем форуме гентушников внезапно проблемы с локализацией
на Лоре тоже есть похожая тема именно manjaro
?
p5ql/epu q9300
0
avatar
Да это всё уже пробовал, даже юзера с нуля создал специально под этот эксперимент. Всё так выглядит, будто именно в системных файлах или пакетах, которые должны содержать локализацию, а также модулях, которые должны её обрабатывать, какие-то баги.

Про манджару — на этомсайте нашёл похожую тему, но там, ЕМНИП, проблема то ли сама собой решилась, то ли на неё забили, но чёткой инструкции ремонта я там не нашёл. А всё, что нашёл, пробовал, даже последние советы — вообще безрезультатно.

Вот я и подумал — а не прилетела ли с некими зависимостями мне кривая локализация? Или, может, у меня каким-то макаром что-то из тестинга просочилось, хотя я проверил — сижу на стэйбл. Не знаю, как именно это проверить, и что я должен буду увидеть и как интерпретировать…
А на форумах про подобное пишут, что баг, и что в более поздних кедах исправЯт или исправИЛИ, но у меня свежак, а глюк багом погоняет. К тому же у арчеров, я так понял, всё нормально. Даже kio обновился и ничего не сломал — так почему у меня сломал?..
Могу для чистоты проделать манипуляцию со своей папкой конфг в хомяке, но на 99.9% уверен, что ничего это не даст...(
0
avatar
Там речь пошла о пакете ki18-n
не об этом пакете речь кеды у меня в арче, манжаре тестинг и стабле, но подобный баг смог получить только частично как писал выше
?
p5ql/epu q9300
0
avatar
а чего вы на плазму грешите то? у меня манджаро гном и точно такая же проблема с локалями — в конфиге все верно, а система полу рус, полу англ. плюс еще и гном терминал не запускается=) энторнет советует glibc переустановить, но нифига не помогло. уже уходил с манджары на пару месяцев, сейчас вернулся, думал починили, но нифига — до первого обновления все русское, а потом все через зад опять
0
avatar
вот написал и полез на ютуб смотреть как поставить арч=))) а там совет, как поставить русскую локаль. так я на манджаре сделал — вуалябля, и у меня локаль починилась. короче, сначала исправить в /etc/vconsole.conf на KEYMAP=ru (походу в этом вся проблема и есть), а потом все как везде советуют — раскомментить ru в /etc/locale.gen и сгененрировать локаль по новой командой locale-gen. потом проверить в /etc/locale.conf наличие русской локали и удалить LC_COLLATE=C. reboot и все норм (по крайней мере, у меня)
0
avatar
Щас попробуем.

Всё по-прежнему.

cat /etc/vconsole.conf
KEYMAP=ru
LOCALE=«ru_RU.UTF-8»
CONSOLEMAP=
FONT=«ter-v16v»
USECOLOR=«yes»

Русский язык в /etc/locale.gen раскомменчен, о чём также свидетельствует
Generating locales…
ru_RU.UTF-8… done
Generation complete.

В /etc/locale.conf находится только LANG=ru_RU.UTF-8, так что удалять нечего.

Попробовал туда же дописать содержимое файла plasma-localerc из хомяка — НИКАКОЙ РАЗНИЦЫ.

НИЧТО из предложенного ДО СИХ ПОР не пролило свет ни на источник проблемы, ни на методы её решения(((
Последний раз редактировалось
0
avatar
Загляните Сюда
И еще вопрос покажите вывод
cat /etc/passwd
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
начнём с «сюда» — и там я вижу похожую фигню, НО у меня далеко не все описанные пакеты прилетели из гита, а только описанный выше пакет с локалями 18n, и ещё штук 6, и вот при попытке их удалить мне предлагается снести половину плазмы, если не всю её… Чё-то сцыкотно)

Что будет, если я попробую снести их командой, которая позволяет не удалять зависимые компоненты? Ещё хуже будет?
0
avatar
Чё-то сцыкотно)
думаю это правильно.
Что будет, если я попробую снести их командой, которая позволяет не удалять зависимые компоненты? Ещё хуже будет?
вот и проверите. Вы не дали вывод команды? Зачем спросил? Дейстия с локалью можно делать от юзера и от рута.Так вот в моих эксперементах с английской установкой manjaro при смене локали находясь в сеансе юзера согласно Вики при замене на родной язык у юзера почти ничего не изменилось а при смене сеанса на рута язык поменялся везде и в дельфине тоже полностью на русский
?
p5ql/epu q9300
0
avatar
залогинился под рутом специально, вот прям логин root, пароль (ага, щазз! шучу), сделал locale-gen да и до кучи sudo localectl set-locale LANG=ru_RU.UTF-8

Угадаете?) Никаких изменений. Cut, copy, undo… SHIT

Похоже, что дело реально в этих непонятно откуда взявшихся версиях пакетов из git, от которых непонятно почему у меня зависит чуть менее, чем всё.
Последний раз редактировалось
0
avatar
Остается посмотреть
sudo tune2fs -l $(df / | tail -1 | cut -f1 -d' ') | grep created 
ну и
lsb_release -a
картинок до кучи для сравнения
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
lsb_release -a
LSB Version: n/a
Distributor ID: ManjaroLinux
Description: Manjaro Linux
Release: 21.0
Codename: Ornara

Pacman-mirrors version 4.19.5
Local mirror status for stable branch
Mirror 1 OK 00:24 Russia mirror.truenetwork.ru/manjaro/

А что творит первая команда?
Последний раз редактировалось
0
avatar
покажет когда установлена ос меня интересует
Перво-наперво прошу очень сильно не ссылаться на имеющиеся топики, ибо: ознакомился, попробовал, не помогло.
Итак.

OS: Manjaro 20.2.1 Nibia
Последний раз редактировалось
?
p5ql/epu q9300
0
avatar
Filesystem created: Mon Jan 4 04:02:50 2021

Вообще образ был скачан раньше. После установки обновился, но тогда не было таких проблем с локализацией. То есть где-то были английские пункты, возможно, но вот видимые только после последующих обнов…

В сети испокон веков жалуются на неполную локализацию, но судя по тому, что мне отвечают (или по тому, что НЕ отвечают), траблы у единиц, а не у всех. И не могу понять, почему.
0
avatar
В сети испокон веков жалуются на неполную локализацию, но судя по тому, что мне отвечают (или по тому, что НЕ отвечают), траблы у единиц, а не у всех. И не могу понять, почему.
Возможно Вы среди этих единиц.Если есть возможность выделить раздел на диске и накатить Manjaro + обновиться для сравнения с установленной системой. Ну и посмотреть журнал событий памака где есть все действия с системой
?
p5ql/epu q9300
0
avatar
Вопрос-то в том, почему, в чём природа. Не собираем же из исходников… Глянем, да и потом попробую безопасно снести пакеты из гита и поставить более стабильные.

Но если появятся у кого ещё идеи — тема открыта, и, надеюсь, не закроется, пока решение проблемы не найдём)
0
avatar
Йо-хо-хо и фляжка пива! ЛОКАЛИЗАЦИЮ ПОЧИНИЛ! Можно потом сделать статью с инструкцией для новичков, которых испугает pamac.

Итак, неполная локализация действительно вызвана наличием пакетов КДЕ версии с git-а. Откуда они, мать их, взялись, остаётся только гадать. Гипотетически: тот образ KDE Minimal, который я ставил, мог изначально быть на ветке Testing, что я вовремя не проверил (откуда ж я б знал-то, что...?), ибо тут был блог 2015 года по настройке такого дистра (и там было указание перейти на стабильную ветку). Итак, что делаем:

1) открываем памак и смотрим, какие кедовские пакеты у нас «kblablabla-git» (понятно излагаю?), проще всего отсортировать по репозиториям и смотреть только утановленные.
2) открываем ТЕРМИНАЛ и sudo pacman -S _пишем через пробел все эти пакеты, но без "-git"_, выполняем
3) менеджер скажет, что «у нас установлено всё это от гита, и установка заменит имеющийся пакет. Фигачим?». Отвечаем ему — «без жалости!», после чего:
4) каждый из этих пакетов подвергнется данному вопросу, по умолчанию будет вариант «N», поэтому ручками всегда говорим «y», и так до самой установки.
5) перезапускаемся (вероятно, достаточно перезапуска сеанса, но я сделал ребут), и ЖИВ, ЦЕЛ, ОРЁЛ!
6) проверяем, не пропустили ли мы какой «гит» для КЕД своими запотевшими ручками, и если пропустили — повторяем.
Для новичков — НЕ ОТНОСИТСЯ к сторонним приложениям, например, игровым движкам, которые поставлены из гита (они хорошие, их не трогаем).
7) PROFIT!

Но тема ещё не зарыта, ибо не проверил, как обновление kio, ломавшее КДЕ, пройдёт теперь. Гипотетически, баг должен уйти. Как выясню, отпишусь. Ну и проблема со сбросом настроек гаммы на месте.

Также есть новый баг: в окошке выбора цветовых схем КАЖДАЯ (в области показа цвета выделения) теперь выглядит, как используемая в настоящий момент. Возможно, тут поможет сброс пользовательских параметров после замены гита на стабильность, но пока не факт.

UPD: ЖИВ-ЦЕЛ-ОРЁЛ2, с КИО всё норм, обновил и его.
Вывод: наличие пакетов окружения из git — риск напороться на баги, которых никто не видел или верного решения им не нашёл…

UPD2: баги с цветовыми темами в настройках ушли после обновления. Теперь в целом конфетка.
В итоге остался только баг со сбросом гаммы…
Последний раз редактировалось
+2
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.