Manjaro KDE Edition
   684

[РЕШЕНО] Тиринг и ̶б̶е̶з̶н̶а̶д̶е̶г̶а̶ решение

РЕШЕНИЕ:
Решение оказалось намного проще, нужно было лишь установить 430е драйвера, на них все работает нормально

Здраствуйте, возник вопрос сообществу — тиринг. Он возникает везде и всегда, вне зависимости от приложения. Моя система:
ГПУ: nvidia geforce gtx 1060 6gb (gp106)
Драйвера: проприетарные video-nvidia-435xx (т.к. 440е не работают, при их установке слетает grub с вот такой ошибкой: external-content.duckduckgo.com/iu/?u=http%3A%2F%2Fefi.lv%2Fimages%2Ffreenas_unknown_filesystem.PNG&f=1&nofb=1)
ОС: Manjaro KDE Plasma
Ядро: Linux 5.6.11
Пример при воспроизведении видео с youtube:
Manjaro KDE Edition: Тиринг и безнадега
Тема обычная, и поэтому я думал загуглить и по-быстрому решить, но ни один способ не работает. Способы, что я пробовал:
«Включить в настройках экрана "Full screen repaints" ("Полная отрисовка")»:
Manjaro KDE Edition: Включить в настройках экрана "Full screen repaints" ("Полная отрисовка")
также «Включение "Force Composition Pipeline" и "Force Full Composition Pipeline" в настройках nvidia-x-server», причем я уж не помню как, но я сделал так, чтобы эти настройки сохранялись:
Manjaro KDE Edition: Включение "Force Composition Pipeline" и "Force Full Composition Pipeline" в настройках nvidia-x-server
Если нужно предоставить еще что-то — пишите.
UPD
Вики читал, все попробовал, не помогает
Пробовал в файле /etc/X11/xorg.conf.d/90-mhwd.conf секцию Section «Device» привести к такому виду

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
	Option      "metamodes"  "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
EndSection


Также еще пробовал удалить «90-mhwd.conf» и создать «95-mhwd.conf» с параметрами выше, а также с такими:

Section "Device"
        Identifier "Nvidia Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

(как в вики)

15 комментариев

avatar
в файле /etc/X11/xorg.conf.d/90-mhwd.conf секцию Section «Device» приведи к такому виду
<code>Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
	Option      "metamodes"  "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
EndSection</code>
и ребутнись
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Я вспомнил как я сделал так, чтобы настройки nvidia-xserver'а сохранялись — создал файл 95-mhwd.conf, поместив туда то, что Вы написали, а затем удалил 90-mhwd.conf, собственно это сработало — настройки сохраняются, но проблему тиринга это не решило
0
avatar
Добавь в xorg.conf

Section «Screen»
Option «metamodes» «DFP-0: 1280x800 {ForceCompositionPipeline = On}»

Разрешение монитора допиши своё.
0
avatar
это, по-сути схоже с моим
Option «metamodes» «nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}»
Но попробую по-вашему
0
avatar
Всегда, всегда при любых вопросах прежде всего читайте вики.

Но, прежде чем приступить, уберите всё, что делали до этого (верните в первоначальное состояние).
0
avatar
Читал, пробовал все с чистого листа, не помогло, поэтому и такое название
0
avatar
у меня был тиринг на ivi.ru. сделал даунгрейд на 430 бамблби. теперь сноснее показывает!

manjaro.ru/manjaro-kde-edition/ne-zapuskaetsya-nvidia-x-config-settings_2.html
+1
avatar
Я тоже пробовал, откатывался и на 430е, и на 418е, и на 390е, везде результат одинаковый
0
avatar
Наврал, оказывается 430е не тестил, на них заработало!
+1
avatar
Manjaro xfce nvidia 730 тирринга нет из коробки проверено
0
avatar
ну так у меня kde, так еще и видеокарта — 1060, как-бы соверешенно разные конфигурации
0
avatar
То есть, если просто в работающей системе выполнить в терминале вышесоветуемую строку не перезагружаясь, то проблемы это не решает?
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

Тогда можно ещё попытаться поставить Compton.
Последний раз редактировалось
0
avatar
При вводе пишет
Gtk-Message: 11:57:35.400: Failed to load module "appmenu-gtk-module"
Последний раз редактировалось
0
avatar
В файл
sudo nano /etc/profile
дописать 2 строчки
export __GL_YIELD=«USLEEP»
export KWIN_TRIPLE_BUFFER=1
0
avatar
Попробовал, не помогло
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.