Уголок новичка
   1599

Черный экран после логина

Встречайте лолку новичка :)

Решил, что не осилю арч (и оказался прав).
Установил Манжаро. Графическим установщиком. После загрузки системы адекватно отображается в нормальном разрешении экрана окно логина. Логинюсь и курсор с картинкой замирают. Дальше всё :(

По опыту с убунту помню, что у меня проблема с дровами на 1050ti.
Полез в груб, впихивать nomodeset, но не получается. Вместо quiet splash вижу quiet cryptdev… и прочее, вследствии моего лольного шифрования, видимо.
В какое место не дописывал бы номодесен — результат один — после сохранения — вообще черный экран.

Подскажите шоделать плиз :(

63 комментария

avatar
Перед установкой, при загрузке с флешки, на самом первом экране выбирайте установку с проприетарными драйверами. Нужный драйвер встанет автоматом, в граб всё что нужно тоже пропишется.
1050Ti нормально поддерживается. Если не последней 418 версией драйверов, то уж 390-й линейкой — точно.
ЗЫ: Если что-то пойдет не так и установятся драйвера 418 версии, можно нажатием Ctrl+Alt+F2 перейти в другую консоль, залогиниться в текстовом режиме и дать команды:
sudo mhwd -r pci video-nvidia 
sudo mhwd -i pci video-nvidia-390xx
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+2
avatar
Благодарю за оперативный ответ!
Пишу с нового логина, так как форум пишет, что мой прошлый в базе спамеров :(
Не хочет меня ни манжаро, ни сообщество :(

Попробовал загрузиться с нон-фри дровами — начинает бешано крутиться вентилятор и дальше загрузка не идет, фото вывода прикрепить не могу по техн. причинам :( Хотя там вроде по хоу загрузки все пункты ок.

Попробовал из под установленной системы перейти в терминал по Ctrl+Alt+F2 — тупо черный экран :(

Есть какие-то еще варинаты у меня? :(
0
avatar
Пишу с нового логина, так как форум пишет, что мой прошлый в базе спамеров
Это бывает, обратитесь в наш Телеграм-канал, логин восстановят.
с нон-фри дровами — начинает бешано крутиться вентилятор и дальше загрузка не иде
Похоже, действительно автоматом 418й драйвер ставится, а с ним эти видеокарты несовместимы.
по Ctrl+Alt+F2 — тупо черный экран
Дак он и должен быть черный, это ж текстовый режим. Логин запрашивает или просто черный?
Есть какие-то еще варинаты у меня?
Ставить как раньше, со свободными драйверами, после перезагрузки и неудачного логина в иксы- по Ctrl+Alt+F2/3/4/5 перейти на текстовую консоль и
sudo mhwd -i pci video-nvidia-390xx
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Дак он и должен быть черный, это ж текстовый режим. Логин запрашивает или просто черный?

Да, дело в том, что он совсем черный :) Ничего не ввести :(
0
avatar
Ну в лайв-режиме-то иксы со свободным драйвером работают? Значит и в нормальном с тем же драйвером должны работать.
ЗЫ: Какую версию ставите?
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
В лайв режиме — работают. После установки — иксы с экраном логина. После ввода логина — зависон курсора и фона… и всё.

В бубунтоподобных было так же. Помогал номодесет, а дальше из под гуя ставил нвидиа дрова. А тут номодесет не пойму куда пихать, во все места уже перепробовал :) Сказывается ламерность и лолковость, сорри :( кьит сплеш нет, вместо него quiet cryptdev и в моем мозге синий экран :)

Ставлю manjaro 18 xfce…
0
avatar
Уберите quiet (чтобы видеть что происходит при загрузке) и пихайте вместо него nomodeset. Или вообще укажите там
systemd.unit=multi-user.target
, это аналог runlevel 3 в терминологии системды. В нем уже можно спокойно эксперементировать с настройками, почитывая соответствующие статьи.
Последний раз редактировалось
+1
avatar
Уберите quiet (чтобы видеть что происходит при загрузке) и пихайте вместо него nomodeset


Уверенно так начинает грузиться, а потом повисает на:
[OK] Started TLP system startup/shutdown

Или вообще укажите там
systemd.unit=multi-user.target

Грузит в обычный гуй логин и далее по старой программе — зависон курсора и фона.

/etc/default/grub

Не в состоянии разобраться даже как добраться до его редактирования :(

А, теперь же плимут… на «черном экране попробуйте нажать ctrl+alt+pause/break

Не реагирует, так же продолжает висеть чернота кромешная(
0
avatar
Не в состоянии разобраться даже как добраться до его редактирования :(
Загрузка с флешки и chroot в систеиу
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Загрузка с флешки и chroot в систеиу

Оч. извиняюсь, я оправдываю свой ник лолка :(
По логике сначала нужно примонтировать из под флешки зашифрованный диск. Потом перейти в директорию и оттуда chroot, если я правильно понял хелп по комманде. Но я настолько ламер, что не могу пригуглить как это все сделать :(
Видимо линукс не для меня :(
0
avatar
А диск что, зашифрован?
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Да. Пробовал без шифрования установить (когда не понимаешь что происходит, включаешь метод научного тыка. Неправильно да, а что делать) — все признаки те же.
0
avatar
Грузит в обычный гуй логин и далее по старой программе
Должно грузить в TTY. Возможно, очепятка?
Ладно, вернемся к нестареющей классике. Просто цифра 3 в параметрах ядра. Конечно, это не ПоттерингоУГодно, зато действенно. Если systemd-sysvcompat из базовой поставки не выкинули, то должно работать.
Последний раз редактировалось
0
avatar
Сорри, но мой уровень таков, что даже не понял куда тройку пихать.
0
avatar
Вместо quiet. Либо рядом.
0
avatar
номодесет не пойму куда пихать,
/etc/default/grub

А, теперь же плимут… на «черном экране попробуйте нажать ctrl+alt+pause/break
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
с nomodeset тоже не загружается…
Ок started network manager
Ok started tlp

Дальше не идет
0
avatar
Что ж, есть ещё вариант.
Можно попробовать поставить один из прошлых релизов, потом обновиться до текущего. Иногда так проще.
Качать отсюда: osdn.net/projects/manjaro/storage/z_release_archive/xfce/
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Попробовал 17 xfce. Картина абсолютно идентична :(
0
avatar
Скачал KDE редакцию, сверил SHA256 — ab0ab7963ffbba6956906e27f6e9e1e5da823ab25356564208f158b8ba00b1c9. Выбрал русский язык, free драйвера и спокойно загрузил систему в live-режиме. Другими словами моя видеокарта 1050Ti не стала проблемой для работы с флэшки.

Отсюда делаю вывод, что с большой долей вероятности в случае установки системы на жёсткий диск, графический ускоритель не будет источником проблемы после установки. Поскольку пару лет назад, когда эта карточка только появилась было невозможно загрузиться ни с free drivers, ни с проприетарными драйверами. Однако сумев загрузить тогда другой дистрибутив в лайв-режиме без проблем установил его на десктоп.

Видимо ошибку надо искать в другом направлении.

P.S. На рабочем столе лежит инструкция по установке на английском, но с картинками. Следуйте указаниям. Может всё получится.
Последний раз редактировалось
0
avatar
Отсюда делаю вывод, что с большой долей вероятности в случае установки системы на жёсткий диск, графический ускоритель не будет источником проблемы после установки.


Выводы преждевременные :)
Я тоже прекрасно стартую с флешки в лайв сд, чуть ли не в фулл хд разрешении :)
Так было и с бубунтоподобными. А с арчеподобными не могу сориентироваться как решать проблему эту. Сложнаааааа(
0
avatar
2560х1440 изначально подхватываются без проблем. Есть вероятность, что Вы правы. Но из достаточно большого опыта — это менее 10%. Когда уж очень специфичная или экзотическая конфигурация железа. Либо явно проблемный релиз (тогда идут массовые обращения).
Последний раз редактировалось
0
avatar
Короч не знаю.
Номодесет — черный экран до упора.
Алт + ф… тоже самое.
С параметром ядра 3 пробиваюсь в консоль, логинюсь, но комманды замены драйвера из советов выше выводят чтото непонятное и не прекращают работу.
Замучался уже, мне бы в гуй пробиться как-то и там бы уже дотарахтел и догуглил, как с убунтой учился… с мобилы пишу, ни вывод, ни фото прилепить нн могу даже((
Оч. Нужен арчеподобный дистр, выручайте плиз…
Asus tuf gaming fx705ge-ew096
Последний раз редактировалось
0
avatar
Спойлер!
Ответил в личку.

P.S. У Вас же win 10 там. Общайтесь через неё.
Последний раз редактировалось
0
avatar
С параметром ядра 3 пробиваюсь в консоль, логинюсь, но комманды замены драйвера из советов выше выводят чтото непонятное и не прекращают работу.
В консоли интернет, надеюсь, есть? Тогда ставьте LINKS
sudo pacman -S links
и гуглите, например вот здесь wiki.manjaro.org/index.php?title=Configure_Graphics_Cards — не по русски, но понятно и подробно.
выводят чтото непонятное и не прекращают работу.
Ну они не работают мгновенно- драйвера качаются, модули ядра, много чего. Хотелось бы всё-же как-то увидеть вывод этих команд. Хотя-бы фото с экрана.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Я дополню. fbgrab позволяет делать скриншоты в tty.
Залить оттуда скрины легко можно на 0x0.st или transfer.sh.
+1
avatar
Не могу с мобилы прекрепить картинку даже, верстка едет((
b.radikal.ru/b43/1904/6a/5e70aeed28a4.jpg
0
avatar
Ну уже кое что.
Покажите что скажет
mhwd -l --pci

ЗЫ: интернет на ноуте есть? пингуется что-нибудь?
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
0
avatar
Видеокарта не при чем. Похоже на ошибку в прошивке BIOS.
Обновите BIOS. www.asus.com/us/Laptops/ASUS-TUF-Gaming-FX705/HelpDesk_BIOS/
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Да, нашел обнову. Прошился. Картина не изменилась :(
0
avatar
Возможно из ядра выпилили нужные модули. Если в консольном режиме есть интернет, попробуйте поставить старое ядро 4.9
sudo mhwd-kernel -i linux49
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Сделал. Ядро встало. Картина не изменилась.
Последний раз редактировалось
0
avatar
mhwd -l --pci

inxi -G
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
uname -a
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
4.19.28-1-MANJARO #1 SMP PREEMPT Sun Mar 10 08:32:42 UTC 2019 x86_64
0
avatar
Перезагрузитесь с 4.9м ядром и покажите

mhwd -l --pci
inxi -G
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
У Вас на втором скриншоте версия ядра прописана- 4.19

Перезагрузитесь с 4.9м ядром!
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Затупил, сорри.
Вот ibb.co/Yhp7Stf
0
avatar
Во, другое дело! Значит, действительно, Вам не подходит старое ядро.
И еще у Вас две видеокарты. Гибридная графика.

Пока используйте только старое 49е ядро. Когда разберемся с графикой- можно будет пробовать новое.
Убирайте тройку и пробуйте загрузиться в графику.
Дальше гуглите в сторону Bumblebee
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
При обычной загрузке с этим ядром черный экран с мигающим _
0
avatar
Спойлер!
Предлагаю рассмотреть для публикации картинок более традиционный в сообществе хостинг вроде imgur.com/ (либо подобный), который менее загружен рекламой и всякой шелухой.
+1
avatar
Могу предложить пару: 0x0.st и transfer.sh. Оба хороши отсутствием какой бы то ни было рекламы, элементарной скриптуемостью и возможностью заливать туда любые данные.
0
avatar
Всетаки мне каж что-то с графикой.
Ведь при номодесет висит на ок started tlp…
А если грузить лайв сд с нонфри дровами то кернал паник((
Но как решить хз
0
avatar
А если грузить лайв сд с нонфри дровами то кернал паник((
Паника ядра vs Графика.
Ядро мы поменять можем? Ну, попробовать? Можем.
А с графикой в ноуте мы ничего сделать не сможем.
Вывод?
Надо попробовать поменять ядро.
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
если это поможет автору, то посоветую установить, активировать и запустить сервис haveged, меня этому когда-то давно учили на форуме минта, тогда у меня минт по пару минут грузился после ввода пароля, там что-то с дефицитом энтропии связано ))) это мне так поясняли, я не очень понимаю что это, но помогает на всех линях при такой проблеме :)
+1
avatar
Всем участникам, а особенно dimonmmk большое спасибо за то, что нянчились со мной.

dimonmmk, с параметром ядра 3 залогинился, чуть пригуглил и уже начинаю любить манжаро — mhwd -a pci nonfree 0300 само нашло что нужно поставить. Теперь я в системе как белый человек)))

Только с ядрами непонятно. Шоделать если другое ядро взбредет в голову поставить
+1
avatar
А ядро-то тут при чём? Голова виновата! :))
Если серьёзно- ставьте смело. Вы уже видели что в Манжаро могут спокойно сосуществовать несколько ядер, и при загрузке можно выбрать любое. Попробуйте напримен 414е, а то 49е уж действительно слишком старое. Для управления ядрами (а также драйверами, локалями, пользователями и т.д.) в иксах есть Manjaro Setting Manager.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
А все. Я уже опять с мобилы)) после перезагрузки не грузит гуй. Ни с одной версией ядра(
0
avatar
Ctrl+Alt+F2
Дальше знаете уже что делать.
Хотя скорее всего проблема уже не в ядре а в чем-то другом.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Нэ, дальше уже и не знаю что делать, как диагностировать. В консоль не пускает, только с парам ядра 3. Мхвд пишет что на обе карты нужные дрова стоят мол че тебе еще от меня надо то. И опять нн загрузиться((
0
avatar
И с 49м ядром не грузится? Без тройки, хотя бы в консоль?
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Не грузится. Вот что показывает теперь при загрузке с этим ядром fastpic.co/image/pt1XkO
В консоль не пускает.
0
avatar
У Вас явно что-то не то с железом…
Смотрите в Биос, верните там все к стандартным значениям. Отключите в биосе контроль напряжений и температур. Если ноут заводится без батареи- отключите её.
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Там таких настроек попросту нет(
До дефолтных сбросить я попробовал. Но так вообще не запускается. Ибо все что отличает мои настройки от дефолтных это анчи вместо рейда интеловского идизейбл секьюр бута. Больше в этом биосе настраивать просто нечего(
0
avatar
Похоже что дурит какой-то датчик — то ли температурный, то-ли по токам.
Причём дурит время от времени. Загузитесь с флешки и в установленой на диск системе отредактируйте файл /etc/sensors3.conf
Пароль рута на лайвсистеме- manjaro
Допишите в конец:
chip “power_meter-acpi-0″
    ignore power1

Рестарт.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Звучит логично, тем более, что стал включаться вентилятор на полную. Тем более, что комп не горячий.

Сделать по совету не могу. Не грузится теперь и с флешек. Ошибка на a start job is runing for livemediamhwd script

Да и хз как там расшифровывать раздел и добираться до конфига.

Короче сдаюсь. Возвращаюсь на свою беспроблемную ксубунту :(
0
avatar
Счастливо.
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
Кстати, сделал. Ничего не изменилось.
Психую уже, сорри.
0
avatar
Не, всё. Не судьба.
?
Правильные ответы начинаются с правильных вопросов.
+1
avatar
Здравствуйте всем!
У меня такая же проблема.
К всему этому я не мог загрузиться в live пока в меню загрузки не поменял драйвер на mesa. Проблема скорей всего в драйверах видеокарты стоит Nvidia 1050ti (ноутбук) и Intel 620. После установки системы и ввода пароля система зависает. При переключении в tty появляется черный экран без командной строки.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.