Уголок новичка
   1591

Manjaro KDE NVIDIA bumblebee/prime не работает

Здравствуйте, форумчане!
После непродолжительного обитания на ubuntu, решил таки перейти на manjaro и очень уж мне она понравилась.Но есть такая проблема, автоматически устанавливаемые проприетарные драйвера в системе это video-hybrid-intel-nvidia-430xx-bumblebee.Проверка стимом показала что bumblebee не работают, или работают некорректно. При этом если их пытаться удалить-они не удаляются через настройки, команды запуска не работают(пробовал разные). Сейчас переустановил джару и сижу на нативных дровах. Но хотелось бы решения проблемы, прошу сообщество помочь.

p.s.
Ноутбук Dell Inspiron 15 Gaming 7577 (шел с Убунтой)
NVIDIA® GeForce® GTX 1050 Ti с 4 Гбайт памяти GDDR5
Intel® Core(TM) i7 Processor Label
p.p.s.
Прошу прощения если повторяюсь, гугление выдало много похожих тем с моей проблемой, но все же немного не то.

13 комментариев

avatar
optirun -c :8 glxinfo | grep -i opengl

glxinfo | grep -i opengl

Сравните вывод команд
Если первое не крашнется, то запускать на нвидии так
+1
avatar
Ну или как альтернатива archblog.pro/?p=566
+1
avatar
Спасибо!
Полезная ссылка, похоже на решение. Единственное, не очень понял из статьи откуда брать именно 435.21, из AUR? В общем смысле правильно ли я понял: Ставлю нужные дрова с бамблби, далее сношу лишнее связанное с бамблби, далее просто ставлю yay -S prime прайм и всё?
0
avatar
435
Минорная версия не важна.
Дрова наоборот надо снести, и поставить nvidia-435xx. mhwd тебе поможет
+1
avatar
Спасибо, милчеловек!
Все взлетело. Итак, что я сделал(может кому поможет): ставил на чистую manjaro сразу 435, без гибридных бамблби (открытые дрова(video-linux) не трогал вообще, раньше где то по дурости прочитал что их тоже надо удалять, этого делать не надо!). Далее нашел сборку Prime уважаемого Feresey в AUR и поставил, перезагрузился(тут система почему то намертво зависла-насильно перезагрузил). Всё, теперь во всех приложениях по умолчанию используется нвидиа.
p.s.
команда yay -S prime не найдена была, этого момента я не понял.
p.p.s.
Товарищу PavelMilko (Feresey) огромное спасибо за отзывчивость и труды.
0
avatar
sudo pacman -S yay

Только вот «всё» на нвидии запускаться не должно. Только с prime в префиксе
+1
avatar
Да, в Steam и Lutris именно так. Но такое впечатление, что система стала гораздо быстрее работать (интерфейс, браузер, отклик в целом).
p.s.
Не подскажите, есть сейчас в манджаро какие то утилиты по настройке карты?
0
avatar
nvidia-settings только
Выстави там режим adaptive и сохрани настройки
+1
avatar
Спасибо!
0
avatar
Здравствуйте!
Дико извиняюсь, а почему вся та же история не работает с новыми драйверами 440 (вышли недавно)? Не успел обновиться прайм, или нужно его переустановить?
+1
avatar
Вообщем поставил свежую manjaro kyria:
Manjaro Linux
Версия KDE Plasma: 5.17.5
Версия KDE Frameworks: 5.66.0
Версия Qt: 5.14.1
Версия ядра: 5.4.23-1-MANJARO
Архитектура: 64-битная
Процессоры: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Память: 15,5 ГиБ ОЗУ

1)Первая же проблема, что на свежей jaro nvidia settings не запускаются.
2)Попробовал старый метод описанный тут: archblog.pro/?p=566 Не помогает. В steam командой игры больше не запускаются ни на 435 ни на 440 драйвере. Nvidia settings не запускаются.
3)Попробовал через установку prime описанную тут linustechtips.com/main/topic/1149518-guide-how-to-set-up-nvidia-prime-for-laptops-running-manjaro-linux/ так же не работает. Nvidia settings так же не запускаются.
Подскажите люди добрые как заставить это работать нормально, что делаю не так? Не хочу возвращаться на убунту =(

p.s.
bumblbee не ставил, пробовал с установленным video-linux и удаленным.
0
avatar
Посмотреть и по тамашнему форуму поискать
0
avatar
ТоварищЬ по не_счастью! Я пока не нашёл решение! А ты?
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.