Уголок новичка
   3891

Не могу установить Wifi драйвер rtl8723de (РЕШЕНО)

Установил Manjaro KDE. (Ноутбук HP Notebook — 15-db0007ur)
Обновил через центр обновлений, ядро не трогал (стоит 5.4)

Не работал Wifi (Вообще отсутствовал значек)
Погуглив понял, что нужно установить дрова.

Этой командой узнал номер карты:
sudo lspci | grep Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter

Далее погуглив нашел похожую проблему: https://forum.manjaro.org/t/rtl8723de-how-to-install-wifi-driver/82712

Все делал по инструкции
Подробнее
[[email protected] ~]$ sudo pacman -S git
предупреждение: git-2.26.0-1 не устарел — переустанавливается
разрешение зависимостей…
проверка конфликтов…

Пакеты (1) git-2.26.0-1

Будет установлено: 38,22 MiB
Изменение размера: 0,00 MiB

:: Приступить к установке? [Y/n] n

[idmta-pc idrinkmyteaalone]# sudo pacman -S dkms
разрешение зависимостей…
проверка конфликтов…

Пакеты (1) dkms-2.8.1-1

Будет загружено: 0,05 MiB
Будет установлено: 0,17 MiB

:: Приступить к установке? [Y/n] Y
:: Получение пакетов…
dkms-2.8.1-1-any 52,2 KiB 314 KiB/s 00:00 [###################] 100%
(1/1) проверка ключей [###################] 100%
(1/1) проверка целостности пакета [###################] 100%
(1/1) загрузка файлов пакетов [###################] 100%
(1/1) проверка конфликтов файлов [###################] 100%
(1/1) проверка доступного места [###################] 100%
:: Обработка изменений пакета…
(1/1) установка dkms [###################] 100%
Дополнительные зависимости для 'dkms'
linux-headers: build modules against the Arch kernel
linux-lts-headers: build modules against the LTS kernel
linux-zen-headers: build modules against the ZEN kernel
linux-hardened-headers: build modules against the HARDENED kernel
:: Запуск post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…

[idmta-pc idrinkmyteaalone]# sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers
разрешение зависимостей…
проверка конфликтов…

Пакеты (1) linux54-headers-5.4.28-1

Будет загружено: 9,42 MiB
Будет установлено: 47,30 MiB

:: Приступить к установке? [Y/n] y
:: Получение пакетов…
linux54-headers-… 9,4 MiB 150 KiB/s 01:04 [###################] 100%
(1/1) проверка ключей [###################] 100%
(1/1) проверка целостности пакета [###################] 100%
(1/1) загрузка файлов пакетов [###################] 100%
(1/1) проверка конфликтов файлов [###################] 100%
(1/1) проверка доступного места [###################] 100%
:: Обработка изменений пакета…
(1/1) установка linux54-headers [###################] 100%
:: Запуск post-transaction hooks…
(1/3) Arming ConditionNeedsUpdate…
(2/3) Updating module dependencies…
(3/3) Install DKMS modules

[idmta-pc idrinkmyteaalone]# git clone github.com/smlinux/rtl8723de.git -b 4.15-up
Клонирование в «rtl8723de»…
remote: Enumerating objects: 32, done.
remote: Counting objects: 100% (32/32), done.
remote: Compressing objects: 100% (29/29), done.
remote: Total 633 (delta 11), reused 12 (delta 3), pack-reused 601
Получение объектов: 100% (633/633), 2.72 MiB | 3.94 MiB/s, готово.
Определение изменений: 100% (226/226), готово.

[idmta-pc idrinkmyteaalone]# sudo dkms add ./rtl8723de

Creating symlink /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/source ->
/usr/src/rtl8723de-5.1.1.8_21285.20171026_COEX20170111-1414

DKMS: add completed.

[idmta-pc idrinkmyteaalone]# sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
Error! echo
Your kernel headers for kernel 5.4.23-1-MANJARO cannot be found at
/usr/lib/modules/5.4.23-1-MANJARO/build or /usr/lib/modules/5.4.23-1-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.

Вот сама ошибка на которой я застрял

[[email protected] ~]$ sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' all KVER=5.4.28-1-MANJARO...........(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.4.28-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log for more information.


P.S. Пожалуйста пишите подробно, я не опытный пользователь linux
P.S.S. Если есть ошибки в оформлении топика — пишите (Если есть пунктуационные и орфографические ошибки прошу прощения)

15 комментариев

avatar
Your kernel headers for kernel 5.4.23-1-MANJARO cannot be found at
/usr/lib/modules/5.4.23-1-MANJARO
Error! Bad return status for module build on kernel: 5.4.28-1-MANJARO (x86_64)
Насколько я вижу, у Вас отличаются версии ядра и его заголовочных файлов. В результате поиски идут немного не там, где надо.
uname -a что говорит?
+1
avatar

[[email protected] ~]$ uname -a
Linux idmta-pc 5.4.28-1-MANJARO #1 SMP PREEMPT Wed Mar 25 12:45:29 UTC 2020 x86_64 GNU/Linux
0
avatar
Если честно, до этого пробовал менять ядра но не дало результатов, сейчас переустановил и специально ничего не трогал
0
avatar
Концепция изменилась!
В АУРе лежит rtlwifi_new-extended-dkms, там заявлена поддержка Вашей карточки.
+5
avatar
Сработало! Спасибо большое, что не прошли мимо! Удачи!
0
avatar
Здравствствуйте! Этот же драйвер, эта же проблема. Только после команды выдайтся ошибка:
[nikitanikita-hppavilion14 ~]$ yay -S rtlwifi_new-rtw88-dkms
-> Невозможно найти все требуемые пакеты:
rtlwifi_new-rtw88-dkms (цель)
Подскажите, пожалуйста, что нужно сделать
0
avatar
rtlwifi_new-rtw88-dkms
Откуда Вы взяли это название?
0
avatar
Хороший вопрос. Как решу проблему с загрузчиком попробую правильное
0
avatar
Взял отсюда: manjaro.ru/newby-corner/ustanovka-drayvera-dlya-adaptera-wi-fi-rtl8723de-otvalilsya-posle-perezagruzki.html

Но с приведенным здесь названием та же ошибка:
[nikitanikita-hppavilion15 yay-bin]$ yay -S rtlwifi_new-extended-dkms
-> Невозможно найти все требуемые пакеты:
rtlwifi_new-extended-dkms (цель)
0
avatar
Пользуйтесь поиском по AUR. Теперь оно зовется rtw88-dkms-git.
Последний раз редактировалось
0
avatar
Спасибо, но все равно не сработало.
Нашел на AUR: yay -S rtl8723de-dkms-git
вроде бы без ошибок, но адаптер не работает выдаёт до 8 мбит

Кат сделать спойлер?
Спойлер!
[nikitanikita-hppavilion15 ~]$ yay -S rtl8723de-dkms-git
:: Проверка конфликтов…
:: Проверка внутренних конфликтов…
[Aur:1] rtl8723de-dkms-git-7b7fc22-1

1 rtl8723de-dkms-git (установлено) (файлы сборки существуют)
==> Пакеты, для которых требуется очистить кэш сборки?
==> [N]Нет [A]Все [Ab]Прервать [I]Установленные [No]Неустановленные или (1 2 3, 1-3, ^4)
==> n
:: PKGBUILD обновлён, пропуск (1/1): rtl8723de-dkms-git
1 rtl8723de-dkms-git (установлено) (файлы сборки существуют)
==> Показать изменения?
==> [N]Нет [A]Все [Ab]Прервать [I]Установленные [No]Неустановленные или (1 2 3, 1-3, ^4)
==> n
:: (1/1) Анализ SRCINFO: rtl8723de-dkms-git
==> Сборка пакета rtl8723de-dkms-git 7b7fc22-1 (Вс 25 июл 2021 20:35:36)
==> Получение исходных файлов…
-> Обновление репозитория 'rtl8723de' (git)…
Извлечение из origin
-> Найден dkms.conf
==> Проверка файлов source с использованием md5sums…
rtl8723de… Пропущено
dkms.conf… Готово
==> Сборка пакета rtl8723de-dkms-git 7b7fc22-1 (Вс 25 июл 2021 20:35:39)
==> Проверка зависимостей для запуска…
==> Проверка зависимостей для сборки…
==> Получение исходных файлов…
-> Обновление репозитория 'rtl8723de' (git)…
Извлечение из origin
-> Найден dkms.conf
==> Проверка файлов source с использованием md5sums…
rtl8723de… Пропущено
dkms.conf… Готово
==> Удаление директории '$srcdir/'…
==> Распаковка исходных файлов…
-> Создание рабочей копии репозитория 'rtl8723de' (git)…
Клонирование в «rtl8723de»…
готово.
==> Исходные файлы готовы.
==> Сборка пакета rtl8723de-dkms-git 7b7fc22-1 (Вс 25 июл 2021 20:35:45)
==> Проверка зависимостей для запуска…
==> Проверка зависимостей для сборки…
==> ВНИМАНИЕ: Использование существующего дерева исходных файлов в '$srcdir/'
==> Исходные файлы готовы.
-> rtl8723de-dkms-git-7b7fc22-1 уже собран — пропуск сборки
-> Найден git-репозиторий: github.com/smlinux/rtl8723de
[sudo] пароль для nikita:
загрузка пакетов…
предупреждение: rtl8723de-dkms-git-7b7fc22-1 не устарел — переустанавливается
разрешение зависимостей…
проверка конфликтов…

Пакеты (1) rtl8723de-dkms-git-7b7fc22-1

Будет установлено: 12,63 MiB
Изменение размера: 0,00 MiB

:: Приступить к установке? [Y/n]
(1/1) проверка ключей [#######################################################################################] 100%
(1/1) проверка целостности пакета [#######################################################################################] 100%
(1/1) загрузка файлов пакетов [#######################################################################################] 100%
(1/1) проверка конфликтов файлов [#######################################################################################] 100%
(1/1) проверка доступного места [#######################################################################################] 100%
:: Запуск pre-transaction hooks…
(1/1) Remove upgraded DKMS modules
==> Unable to remove module rtl8723de-5.1.1.8_21285.20171026_COEX20170111/1414 for kernel *: Not found in dkms status output.
:: Обработка изменений пакета…
(1/1) переустановка rtl8723de-dkms-git [#######################################################################################] 100%
:: Запуск post-transaction hooks…
(1/2) Arming ConditionNeedsUpdate…
(2/2) Install DKMS modules
==> Unable to install module rtl8723de-5.1.1.8_21285.20171026_COEX20170111/1414 for kernel *: Missing kernel headers.
Последний раз редактировалось
0
avatar
Кат сделать спойлер?
Самая правая кнопка над формой поста. С надписью «spoiler».
Последний раз редактировалось
0
avatar
Посмотрите, пожалуйста, пост выше под спойлером. Что я не так делаю? Вроде бы всё установилось, wifi всё равно тормозит.
Похоже не на этом компе…
0
avatar
==> Unable to install module rtl8723de-5.1.1.8_21285.20171026_COEX20170111/1414 for kernel *: Missing kernel headers.
проверьте-покажите
pacman -Qs linux-headers
pacman -Qs dkms
Последний раз редактировалось
?
p5ql/epu q9300
+1
avatar
Manjaro работает прекрасно на другом компе. А на этом и с сетевухой проблемы и GRUB minimal-BASH — с командной строки можно зайти, но по этому рецепту
espressocode.top/how-to-fix-minimal-bash-like-line-editing-is-supported-grub-error-in-linux/
не лечится.
В общем с этим компом я решил более не воевать.
Спасибо всем за участие.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.