Уголок новичка
   1157

Недостающие зависимости pacaur

При сборке пакета pacaur выдает такую ошибку:

==> Сборка пакета pacaur 4.8.4-1 (Пт 01 мар 2019 10:50:22)
==> Проверка зависимостей для запуска...
==> Недостающие зависимости:
  -> auracle-git
  -> jq
==> Проверка зависимостей для сборки...
==> ОШИБКА: Не удалось разрешить все зависимости.


Где взять эти недостающие пакеты? В штатном репе не нашел.

8 комментариев

avatar
Чем собираем?
Зависимости лежат в AUR.

Соберите другой аналогичный пакет, без aur зависимостей. Потом уже, если захотите, поставите pacaur.
Вот хороший кандидат.
Последний раз редактировалось
0
avatar
Вот хороший кандидат.
По хорошему кандидату есть пара вопросов:
— он умеет подсвечивать разными цветами(installed, Out of Date, пр.) как yaourt? если да, где это включить?
— есть русификация?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Состояние пакета оно умеет вот так





При обновлении предупреждает, какие из установленных aur пакетов «out-of-date»

Не совсем понял, русификация чего) Pacman и makepkg вроде работают на системном языке.
Настройки в ~/.config/yay/config.json Создать придется руками, этот момент как-то не проработан. По крайней мере я не нашел его в системе. Однако есть документация.
0
avatar
Состояние пакета оно умеет вот так
у меня почему-то не подсвечивает, какой пункт за это отвечает?


и почему-то русский не включается
Спойлер!
yaourt -Syua
[sudo] пароль для ypp: 
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
 sublime-text не устарел
  glass : Нет ответственного 
  pkgbuild-introspection : Нет ответственного 
  silly : Нет ответственного 
  wine-valve-git : Нет ответственного 
 Другие пакеты: - 170 / 170
Ошибок баз данных не найдено!
[ypp@ypp-pc ~]$ yay -Syua
:: Searching AUR for updates...
 -> glass: local (8-1) is newer than AUR (0.4-2)
 -> gxneur: local (0.21.0-1) is newer than AUR (0.20.0-2)
 -> lib32-libtxc_dxtn: local (1.0.1-5) is newer than AUR (1.0.1-1)
 -> libtxc_dxtn: local (1.0.1-6) is newer than AUR (1.0.1-1)
 -> qt5-quick1: local (5.9.2-1) is newer than AUR (5.7-1)
 -> xneur: local (0.21.0-1) is newer than AUR (0.20.0-1)
 -> Missing AUR Packages:  archlinuxcn-keyring  black  borealis-ubuntu  codelobsteride  deepin-font-installer  deepin-help  deepin-qml-widgets  deepin-wallpapers-extra  fekete  gegl02  gimp-script-smart-remove  js  libnm-gtk  libtracker-sparql  nvidia-390xx-linux-lqx-420  ollifri-icons  pcmciautils  photopea-desktop  prelink  pysdm  qmlsaver  qshutdown  r8168-linux-lqx-420  t4g  ttf-adobe-fonts  undistract-me-bzr  vte  webamp-desktop  winusb  zvvanekdotes
 -> Orphaned AUR Packages:  glass  pkgbuild-introspection  silly  wine-valve-git
 -> Out Of Date AUR Packages:  conky-cairo  directfb  gxneur  jaxx  proton  wine-valve-git  xneur
 there is nothing to do
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
/etc/pacman.conf надо раскоментировать/добавить 'Color' в районе '#Misc options'. Это yay подхватывает из настроек пакмана.

Понял, о какой Вы русификации. На сколько я знаю, пока нельзя :)
+1
avatar
ага, цвет появился, спасибо, пообкатываю, вроде по синтаксису от yaourt не сильно отличается)
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
+1
avatar
Не знаю откуда вы собираете pacaur, но он есть в репозитории extra.
Репозиторий          : extra
Название             : pacaur
Версия               : 4.7.90-1
Описание             : An AUR helper that minimizes user interaction
Архитектура          : any
URL                  : https://github.com/rmarquis/pacaur
Лицензии             : ISC
Группы               : Нет
Предоставляет        : manjaro-aur
Зависит от           : cower  expac  sudo  git
Доп. зависимости     : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Размер загрузки      : 78,36 KiB
Установленный размер : 633,00 KiB
Сборщик              : Stefano Capitani <stefano@manjaro.org>
Дата сборки          : Чт 31 мая 2018 19:38:50
Проверен             : MD5  SHA-256  Подпись
+1
avatar
Спасибо. Подключил extra с зеркала где есть pacaur, все ок.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.