Уголок новичка
   668

nvidia и кривые руки

Всем привет! Задумал поиграть в Тундру, но она указала что нет нужных драйверов. Соответственно начала искать и ставить обновления. Но ожидаемо сделал только хуже. Теперь в Manjaro Settings Manager вообще никаких драйверов не видно
Уголок новичка: пустой MSM
так же nVidia X Server кажется пустоват
Уголок новичка: nVidia
При этом Тундра дико тормозит, но запускается. Раньше стабильно выдавал 50 фпс. В интернетах чаще всего указывается как обновить/поменять драйвер через MSM. Но по моей ситуации ничего не могу найти.
Как исправить ситуацию?
System:    Kernel: 5.13.1-3-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.3 Distro: Manjaro Linux 
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 470.42.01 
           Device-3: Chicony HD WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia unloaded: intel,nouveau 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.4

4 комментария

avatar
На верхнем скрине внизу слева — показать все устройства, попробуй нажать и посмотреть. У меня при нажатии этой клавиши отображаются все устройства компьютера, в том числе и видеокарта.
0
avatar
Там нет возможности управления драйверами. Это скорее список устройств, не более.
0
avatar
Ситуация разрешилась. Заранее извиняюсь за отсутствие подробностей.
Система неожиданно выдала сообщение о наличии неподдерживаемого ядра. Зайдя в MSM, было помечено несколько драйверов(с буквами -rt- в названии) как без поддержки. Для их удаления пришлось удалить несколько элементов Nvidia(система указала какие надо удалить). Остались только эти


Затем обновил драйвера видюхи под используемое ядро. Скорее всего установил ещё что-то лишнее. Вот что сейчас



Теперь можно включать драйвера, осталось разобраться какие надо включить)
Последний раз редактировалось
0
avatar
Ещё добавлю. В MSM не устанавливался закрытый драйвер нажатие кнопки «автоустановка проприетарно драйвера» так же не работала. Появлялось окно с сообщением в конце списка "… готово", хотя если выше пролистать, то там были указаны ошибки и их причины. Методом тыка нашел что мешает «nvidia-390xx-utils». У меня было два таких компонента, после их удаление все стало нормально работать.
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.