Уголок новичка
   769

Ошибка при обновлении pamac

При очередном обновлении пишет такое

не удалось удовлетворить зависимости:
установка pamac-common (9.1.0-2) нарушает зависимость 'pamac-common<9.1.0', необходимую для pamac-qt

Раньше такова не было и обновлялось все хорошо. Пробовал из консоли обновлять — тоже самое. Как лечить?..

33 комментария

avatar
yay -S pamac
sudo pacman -Syu
Последний раз редактировалось
0
avatar
bash: yay: команда не найдена
0
avatar
sudo pacman -S yay
0
avatar
Все равно конфликт с обновлением не решен.
0
avatar
если речь о подобном, то sudo pacman -Syu обновить
0
avatar
ошибка не такая а такая

предупреждение: fontconfig: установленная версия (2:2.13.1+12+g5f5ec56-2) новее, чем в extra (2:2.13.1+12+g5f5ec56-1)
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing pamac-common (9.1.0-2) breaks dependency 'pamac-common<9.1.0' requ
0
avatar
а что говорит
sudo pacman -S pamac-common
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
разрешение зависимостей…
проверка конфликтов…
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing pamac-common (9.1.0-2) breaks dependency 'pamac-common<9.1.0' required by pamac-qt
0
avatar
просто pamac-qt не обновлен до новой версии и требует старый pamac-common, тут есть несколько вариантов:
1. подождать
2. поставить pamac-qt-git(не уверен, что сработает)
3. удалить pamac-qt и юзать pamac-gtk
4. что-то еще…
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
+1
avatar
0
avatar
У меня не хочет ничего ставить говорит все есть.

предупреждение: pamac-gtk-9.1.0-2 не устарел — переустанавливается
разрешение зависимостей…
проверка конфликтов…

Пакеты (1) pamac-gtk-9.1.0-2

Будет установлено: 0,51 MiB
Изменение размера: 0,00 MiB

Переустанавливал, все равно конфликтует с обновами.
0
avatar
покажи pacman -Ss pamac
0
avatar
extra/pamac-cli 9.1.0-2 [установлен: 9.0.2-2]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-common 9.1.0-2 [установлен: 9.0.2-2]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-gtk 9.1.0-2 [установлен]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-qt 0.3.0-3 [установлен]
A QT5 frontend for libalpm — early preview version
extra/pamac-snap-plugin 9.1.0-2
Snap plugin for Pamac
extra/pamac-tray-appindicator 9.1.0-2
Tray icon using appindicator which fits better in KDE
0
avatar
Спойлер!
RAM: 777MiB / 7957MiB
[vit@v-62 ~]$ pacman -Ss pamac
extra/pamac-cli 9.1.0-2 [установлен]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-common 9.1.0-2 [установлен]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-gtk 9.1.0-2 [установлен]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-qt 0.3.0-3
A QT5 frontend for libalpm — early preview version
extra/pamac-snap-plugin 9.1.0-2
Snap plugin for Pamac
extra/pamac-tray-appindicator 9.1.0-2
Tray icon using appindicator which fits better in KDE
[vit@v-62 ~]$

сравни
0
avatar
Вроде все тоже самое.
0
avatar
extra/pamac-qt 0.3.0-3 [установлен]
пробуй pacman -Rsn pamac-qt
0
avatar
— sudo pacman -R pamac-qt
— sudo pacman -Syyuu

GG
0
avatar
Удалось обновиться но после ребута система не загружается!.. Пишет что то про tlp system. Ребята помогите восстановить систему пожалуйста!.. Просто у меня там все настроено а так как у меня интернет ограничен доступом до марта я не смогу все заново настроить!.. Пробовал startx но иксы не стартуют.
0
avatar
Пишет что то про tlp system.


проделал на своей машинке удалил linux53-nvidia-390xx
перезагрузил и получил стоп на tlp system перешел в консоль Ctrl+Alt+F2 получил это посмотрел это дальше
Последний раз редактировалось
0
avatar
sudo pacman -S linux53-nvidia-390xx и
reboot
графика у меня восскресла
0
avatar
хотя нет. там две красные ошибки в стартовом логе терминала 1. Я в него зашел а как прокрутить вверх до ошибок не знаю.
0
avatar
grep /var/log/Xorg.0.log -e EE -e WW
0
avatar


видеокарта 1060
Последний раз редактировалось
0
avatar
Ребят помогите плиз. Я знаю что у вас тут новичков много и всем надо помогать но плиз не оставьте меня в беде.
0
avatar
с какого момента произошел фэйл? что говорит startx?, вангую проблему с дровами, какое железо(конкретно видео)?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Ну после обновления. Я написал к скриншоту что видеокарта 1060 6гб. Дрова стояли 430. Стартх говорит что не может запустить сервер. Я ошибку сфоткаю позже немного.
0
avatar
пробуй pacman -Rsn pamac-qt
если выполнял это.
давай пробовать проверить интерне ping -c 4 8.8.8.8
sudo pacmac -S qt5-base xorg-drivers xorg-xinit
startx
Последний раз редактировалось
0
avatar
Интернет работает пинг идет. Да, после того как я удалил pamac-qt и обновился, система не стартанула. Команду попробую спасибо. А я смогу потом дрова нвидиа снова поставить?..
Последний раз редактировалось
0
avatar
хотелось бы посмотреть и 1. nano ~/.xinitrc
2. glxinfo | grep OpenGL
3. lspci -k | grep -A 2 -E "(VGA|3D)"
Последний раз редактировалось
0
avatar
Спасибо ребят но я решил переустановить все таки. Так быстрее и легче немного. Спасибо за помощь
0
avatar
Печаль, вы пошли самым легким путем.
А «дрова» ставятся и из консоли, скорее всего они там и были.
Если бы посмотрели glxinfo | grep OpenGL и lspci -k | grep -A 2 -E "(VGA|3D)"
0
avatar
Папку /etc сохраните. Ну и home/юзернэйм по возможности. (Всю)
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.