Уголок новичка
   622

Половина экрана отличается по цвету GNOME, 4K

Доброго времени суток!

Столкнулся с такой проблемой, что при установке системы (и после тоже) половина экрана на 4К мониторе отображается с несколько иными цветами. Сначала думал, что это ночной режим, но он не влияет на это. Облазил все меню и настройки GNOME, но так и не нашел ничего, что влияло бы на это. При этом, если поставить рабоее окружение Cinnamon, то там такой проблемы нет. В Windows монитор тоже работает как положено. Видеокарта: GTX 1080Ti; Монитор: Dell UltraSharp UP3216Q
Монитор достаточно капризный, но даже для него такое поведение странно.

Подскажите, пожалуйста, в каком направлении копать :) Что может быть не так.
  • 0
  • 0

18 комментариев

avatar
Забыл добавить. Версия системы 21.1.5 все доступные обновления установлены.
Выглядит это примерно вот так
Последний раз редактировалось
0
avatar
Примерно как? Не вижу на скрине не фига
0
avatar
Упс! Не дошло до меня. Скриншот не захватывает этот глюк же :)
Извиняюсь за качество: пришлось на телефон снимать.



т.е. половина экрана имеет не белый фон, а чуть с зеленым.
Последний раз редактировалось
0
avatar
Пробуй изменить в System Settings > Display and Monitor > Compositor с OpenGL 2 на другие
0
avatar
Для меня Manjaro пока вновинку, поэтому я не сильно ориентируюсь в настройках. Если я правильно понял, то речь идет про утилиту ToolBox или я не прав?
Я просто не могу найти что-то у себя таких настроек… это точно валидно для GNOME?
Последний раз редактировалось
0
avatar
Wayland?
?
p5ql/epu q9300 hackintosh,mint,arch,manjaro,clover
0
avatar
К сожалению, нет. Видяха NVIDIA — так что не судьба.
0
avatar
Если на скрине этого «бага» нет — то он на твоем мониторе.
Лезь в настройки монитора, проверяй пресеты.
Обычно эта фича называется «презентация» — когда половина экрана отображается под текущим пресетом, а другая — под выбранным.
+4
avatar
Спасибо за совет!
Однако, в настройках монитора ничего не нашел :( Сбросил до заводских и тоже ничего.
Очень смущает, что:
1. В других средах работает нормально (Cinnamon вообще без проблем, KDE — тупо не получается настроить HiDPI, но бага с цветами нет);

2. Если включить разрешение FullHD — проблемы нет;
3. В Ubuntu работает нормально вообще в любой среде (кроме KDE — но это уже традиционно :) );
4. В Windows работает нормально.
Правил профиль цвета в настройках NVIDIA — тоже без результатов.

Короче, походу косяк только в Manjaro GNOME, но почему — не ясно.

UPD: От безысходности решил проверить и понял, что если переключить монитор в режим 30 Гц, то проблема исчезает. т.е. проблема имеет место только на 60 Гц. Мистика! :)
Последний раз редактировалось
0
avatar
Однако, в настройках монитора ничего не нашел
а в этом направлении смотрели
Спойлер!
Эксплуатация монитора  37
Зонирование
цветового
пространства
Данная функция позволяет отображать
различные цветовые пространства в левой
и правой половине экрана. При включении
функции Зонирование цветового
пространства в правой половине отображается
текущее выбранное цветовое пространство.
Цветовое пространство для отображения в левой
половине экрана можно выбрать из списка.
Руководство
?
p5ql/epu q9300 hackintosh,mint,arch,manjaro,clover
0
avatar
Спасибо за ответ и за уделенное время!

Зонирование отключено — я проверил (я его вообще не включал даже ни разу, если честно :) ), более того: я даже сбрасывал монитор к заводским настройкам и ничего не изменилось.

Повторюсь: меня смущает, что этот же самый монитор, на этом же компьютере, на тех же настройках нормально работает в других средах и в Windows (более того — он даже в этой версии GNOME нормально показывает изображение на 30 Гц, а вот на 60 Гц начинается такой цирк). Мне чисто по-дилетантски (я здраво оцениваю свои знания среды GNOME :) ) кажется, что проблема именно в настройках среды, но вот где именно — тут моих скудных познаний не хватает.
0
avatar
В жноме сессия на X11 или на вялом? Можно попробовать поменять тип.
0
avatar
Насколько я понимаю, Wayland мне не светит, т.к. видеокарта NVIDIA и на ней будут адские глюки :)
0
avatar
Так у нас же тема как раз про них!
0
avatar
Попробовать взять свежий образ гнома Здесь загрузиться в лайв со свободными потом с не свободными драйверами если выше означенный эффект проявится, остается подождать пока гном исправит поддержку данной модели монитора, а пока есть же другие DE без глюков Пример кстати на свободных драйверах попробуете и вяленого
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,manjaro,clover
0
avatar
Согласен! Собственно Cinnamon как раз нормально работает.
Просто хотелось понять почему именно в GNOME от Manjaro такая проблема.
Но походу я решил проблему более кардинально — так вышло, что я поменял монитор и теперь все отлично! :)

Всем большое спасибо за советы и уделенное время! Очень приятно, что в сообществе Manjaro есть люди, которые помогают новичкам!
0
avatar
Если не затруднит моник определялся правильно и
echo $XDG_SESSION_TYPE
проверяли
Последний раз редактировалось
?
p5ql/epu q9300 hackintosh,mint,arch,manjaro,clover
0
avatar
Да, монитор определялся верно. Собственно была мысль, что цветовой профиль для монитора чуть кривой был, но как его заменить / обновить я так и не понял.
Сессия была только X11, Wayland даже нет возможности включить на моей видеокарте (1080Ti).
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.