Уголок новичка
   526

Проблема с отображением Java-апплетов в браузерах.

Всем доброго дня!
Вопрос к знающим людям. Ну и незнающие тоже могут поделиться своими мыслями и идеями.
(Заранее прошу простить если не верно оперирую терминами)
По работе приходится часто заходить на разное оборудование через web-интерфейс.
Коварные разработчики данного оборудования понапихали в web-интерфейс устройств java-апплетов, за выполнение и отображение которых отвечает модуль NPAPI. Поддержка и функционирование которого в большинстве современных браузеров не то что выключена, а просто упразднена как я понял.
На Windows данная проблема решалась использованием IE+нужная версия Java. В Manjaro хотелось бы обойтись без IE и прочих костылей с вайном.
Все написанное на данную тему в интернете устарело года на 1.5-2 и в текущих условиях не работает. Chrome, Firefox и все что на них основано отказывается отображать java-апплеты. Раньше в Windows спасал Seamonkey, но тут он уже не работает. Видимо после очередного обновления NPAPI тоже вырезали.
Удалось частично решить проблему связкой Midori+java-8-jdk (AUR)
Midori даже смог преодолеть проверку на сайте java java.com/en/download/testjava.jsp (чего до этого не проходило ни с одним из установленных браузеров), но универсальным решением это не стало, так как работает только на парочке типов устройств.
Еще была надежда на Epiphany, но он вместо отрисовывания апплетов выдает сообщение «missing plugin».
Также при копании в интернете нашел информацию, что в последний раз Firefox с работающим NPAPI видели в версии 52.0 ESR. Данная сборка присутствует в AUR, но после получасового пыхтения и зависания установщик выдает ошибку и предлагает перезапустить сборку пакета firefox. Моих знаний на это пока не хватает.
Хотел бы поинтересоваться как знающие люди обходят данные ограничения в Manjaro.
Может быть есть какой то браузер из официального репозитория или на крайний случай из AUR в котором NPAPI будет работать стабильней чем в Midori?
Либо есть способ заставить отображать и обрабатывать java-апплеты в стандартных браузерах типа Chrom или Firefox?
Может я подхожу к решению проблемы не с той стороны?
В общем, прошу совета, в какую сторону копать.

7 комментариев

avatar
opera-legacy, waterfox…
Страница для тестов java
Последний раз редактировалось
?
Правильные ответы начинаются с правильных вопросов.
0
avatar
opera-legacy и waterfox с задачей не справились.
Попробую собрать Firefox esr 52.0
О результатах отпишусь.
Последний раз редактировалось
0
avatar
Можно скачать старую лису https://ftp.mozilla.org/pub/firefox/releases/, еще с поддержкой npapi (до 52 версии) и юзайте, для работы с оборудованием, именно ее. Для остального юзайте текущий браузер.
Последний раз редактировалось
0
avatar
на ubuntugeeks пишут:

0
avatar
Pale Moon
Konqueror
SeaMonkey
Уже не поддерживают. Проверено.
Midori поддерживает, но работает кривовато.
Gnome Web (Epiphany) требует колдунства с плагином конкретно под себя. Пока не смог решить эту задачу.
Safari это танцы с вайном. Тут я могу и к IE вернуться если прижмет.
Сейчас Uzbl пытаюсь установить из AUR, но надежды мало на него.
Подозреваю что все таки нужно ориентироваться на самостоятельную сборку Firefox esr 52.0
0
avatar
Safari для Windows уже давно не поддерживается.
0
avatar
Привет всем. Если я правильно понял, то java в браузере x64 работать в принципе не будет.
Соответственно, нужно ставить x32 версии. OpengJDK в себе не содержит .so для браузера. Подходит только oracle jdk/jre.
Вот с этим скриптом у меня заработало. Только не запускайте его в тупую. Там надо линкануть so в папку с плагинами mazilla. jre нужно предварительно скачать с сайта oracle.
gist.github.com/logikv/a762400ba98a6bd9fb3fa7ee72d1e7e5
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.