Уголок новичка
   598

Проблемы с тирингом | Arch i3wm

Здравствуйте, впервые сталкиваюсь с такой проблемой, тиринг… Проблема в том, что после добавление xorg конфига система не стартует. GPU: AMD ATI Radeon HD 8550G, недавно переустанавливал систему, до этого все работало нормально
/etc/X11/xorg.conf.d/20-radeon.conf


Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
EndSection

9 комментариев

avatar
Может amdgpu поставить?
0
avatar
всегда работала radeon, а при amdgpu черный экран и курсор
0
avatar
Попробуйте так.

Section "Device"
	Identifier  "Device0"
	Driver      "radeon"
	BusID       "PCI:1:0:0"
	Option      "DRI3"	"1"
	Option      "DRI"	"3"
	Option      "TearFree"	"true"
EndSection

Последний раз редактировалось
0
avatar
все также не стартует, зависает на
Starting 249-1-0.arch или что-то подобное
я нашел файл
/usr/share/X11/xorg.conf.d/10-amdgpu.conf

в который решил добавить параметр отключения тиринга

Section "OutputClass"
	Identifier "AMDgpu"
	MatchDriver "amdgpu"
	Driver "amdgpu"
	Option "TearFree" "true"
EndSection

система стартанула, но эффекта никакого, все также экран разрывает
а еще после обновления параметров grub у меня выводятся ошибки с системными прерываниями
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor loglevel=0"
Последний раз редактировалось
0
avatar
Вполне логично. Дилемма трусов и крестика — либо amdgpu либо radeon.
В моем примере выше есть две опции DRI. Попробуйте их добавить.
+1
avatar
попробуйте ка arcolinux, там и i3, и awesome весьма вкусно приготовлены
0
avatar
и поверьте, осом интереснее и пошустрее будет. до него пользовал i3 манжаро, так что сравнить есть с чем.
0
avatar
и кстати Gambit Вам верный совет дает
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.