Уголок новичка
   491

(РЕШЕНО) Не определяется wifi модуль и низкая скорость проводного соединения Manjaro + Lenovo.

Доброго времени суток, уважаемые.
Столкнулся с проблемой, которая поставила меня в тупик.
Имеем ноутбук Lenovo 15ACH6A (82nw001ark) с установленным на него Manjaro, ядро 5.15. Роутер Netgear WNR 2200 (Прошивка DD-WRT).
Симптомы: Не определяется родной встроенный wifi модуль.
При подключении с проводного соединения с роутера интернет есть, но крайне низкая скорость (порядка 100-300 Кб/сек. Подключая кабель напрямую в течении 1-2 минут соединение выдает полную скорость (8-10 Мб\Сек), после чего стремительно падает до уровня в 100-300 Кб\Сек.
Пробовал подключение через адаптер TP-Link — WN722N, результат примерно такой же 100-300 Кб\Сек.
Роутер исправен (другие устройства таких проблем со связью на этом роутере не имеют)
При запуске Manjaro в лайве, проблемы точно такие же. Ноутбук исправен (ради эксперимента запускал под виндой, подобного не наблюдалось).
Подозреваю проблема с драйверами, прошу помочь в решении.

8 комментариев

avatar
в свойствах проводного соединения установлен полный дуплекс?
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Да
0
avatar
еще можно отключить поддержку протокола ipv6 как в свойствах соединения, так и на роутере
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Отключено
0
avatar
я тебе что, гадалка? расскажи, какие еще настройки сделаны для оптимизации скорости, а я добавлю чего тебе не хватает)
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
вот тебе чек настроек сети тыц
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
в части вифи рекомендую начать со статьи в вики тыц, а то ваще непонятно, какой у тебя модуль, какие дрова. прочитай статью полность и начни анализ с начала статьи, там все по русски
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Решено
Чтобы заработал wifi:
Ставим ядро 5.15 или выше
Ставим Linux-firmware (Соответствующий версии ядра)
Ставим rtw89-dkms-git (Есть на AUR)
Перезагружем, должно работать.
Скорость соединения:
Если неиспользуется, то отключить IPv6
Обратить внимание и хорошенько проверить /etc/resolv.conf В моем случае при автоматическом получении адресов в настройках Network Manager подтягивался некорректный лишний адрес с роутера, который и замедлял работу.
Итог: полноценно работает проводное соединение, беспроводное появилось и работает, но имеет скорость на 10-20% меньше чем при тестировании в винде (возможно что-то недоглядел и косяк мой или же косяк драйвера, если найду причину, то дополню информацию).
Надеюсь кому-нибудь поможет это решение, всем удачи и никогда не опускайте руки :)
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.