Уголок новичка
   508

[РЕШЕНО] Wireguard-соединение не хочет запускаться через GUI

Всем привет! Чуть больше месяца назад начал мигрировать с винды на Манджаро. В Линуксе новичок, учусь по ходу. Сейчас дошла очередь до установки Wireguard-клиента. Настроил, все работает, скорость не режется, но есть одно НО. Если запускаю через терминал командой

sudo wg-quick up wg0

то никаких проблем. А если кнопкой через Параметры системы\Соединения, то ни одна страница в браузере не открывается, пишет «Попытка соединения не удалась». Пинг есть, в systemd висит точно такой же юнит, всё то же самое. Только сайты не грузятся.
Единственное объяснение, которое мне приходит на ум – в консоли я ввожу пароль, а в «Соединениях» — нет. Если дело в этом, то нет ли способа заставить систему запускать процесс через кнопку? Да, я знаю, что кнопки для слабаков, а правильные юзеры используют терминал, но я линуксоид начинающий, и сама мысль что придётся каждый раз лезть в консоль и вспоминать\искать все эти команды, вызывает (пока что) у меня боль и страдание.

9 комментариев

avatar
конечно есть, пишешь скрипт, в который включаешь те команды, что запускаешь в терминале. а скрипт вешаешь на кнопку
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
Хм… Я наверное не так выразился. Я имел в виду кнопку в «Сетевых подключениях», в трее. Может нужны какие-то логи или скрины? Я просто не знаю что в данном случае может прояснить ситуацию.
0
avatar
ты как настраивал Wireguard? какие мануалы использовал?
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
avatar
mascloud.ru/wireguard-za-10-minut-na-arch-linux/

Потом скопировал конфиг из /etc/wireguard/ в «Загрузки», зашёл в Параметры системы\Соединения, нажал Добавить новое соединение, выбрал Импортировать VPN-соединение (последний пункт) и указал скопированный конфиг. Все создалось, никаких ошибок. В «Сетевых соединениях» появилась кнопка wg0, при нажатии соединяется мгновенно, но сайты не грузит.
0
avatar
в телеграм чате t.me/manjarolinux есть автор статьи @stezkoy, рекомендую обратиться к нему за разъяснениями. или сделать все по рекомендациям в арч-вики тыц
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
+1
avatar
GUI то откуда взялся? нетворкманагер давно не работает с гуи вангуарда
+2
avatar
Погуглил. Действительно, WG из манагера выпилили. Тогда извиняюсь за беспокойство. Буду привыкать к консоли, надо же когда-то начинать. Всем спасибо за помощь. Тему можно закрывать, или как у вас принято?
0
avatar
у нас принято помечать тему [РЕШЕНО], кроме тебя это ни кто не сделает))
?
Всегда есть быстрое простое неправильное решение.
быстрые простые правильные (иногда) ответы здесь t.me/manjarolinux
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.