Уголок новичка
   532

Решено.Manjaro(xfce) dropbox ОШИБКА: Исходные файлы не прошли проверку целостности!

Уважаемые форумчане! При очередном обновлении дистрибутива два файла: dropbox и python-pyside-common не прошли проверку целостности: «ОШИБКА: Исходные файлы не прошли проверку целостности!». Поиски в Интернете и блогах сообщества Manjaro Linux не дали результатов по выходу из возникшей ситуации. Была ссылка на блог «Manjaro Other» на точное совпадение вопроса, но я её не нашел в блоге. Если кто знает где можно почитать или что можно сделать для устранения данной ошибки, то поделитесь, пожалуйста, своими знаниями — я буду Вам очень благодарен.

21 комментарий

avatar
чем устанавливаешь? дай вывод терминала
yay -S dropbox

yay -S python-pyside-common
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Спасибо за сочувствие и отклик! Я не устанавливаю дистрибутив: он установлен и работает. А при очередном обновлении пакетов появилось сообщение: «ОШИБКА: Исходные файлы не прошли проверку целостности!». Вышел из создавшейся ситуации откатом к ранее сохраненной версии Manjaro.
0
avatar
Я не устанавливаю дистрибутив: он установлен и работает
А я про установку дистрибутива и не спрашивал
Вышел из создавшейся ситуации откатом к ранее сохраненной версии Manjaro.
это не решение
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый, Agafron! Ещё раз спасибо за подсказку. Но откат дистрибутива к ранее сохраненной версии помог только для пакета dropbox. А вот с пакетом python-pyside-common ситуация следующая. Он у меня остается не обновлЯемым (после пришедшего очередного обновления пакетов дистрибутива Manjaro xfce) сколько бы я не пытался его обновить. Результат один:
make: *** [Makefile:130: all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Прерывание…
В спойлере я представляю конец информации, которая выдавалась по ходу обновления пакета python-pyside-common и некоторую другую информацию («Подробности», «Зависимости. Создание зависимостей», «Сборочные файлы. PKGBUILD»), которую можно было получить из pacman после клика на ярлык «Обновить». Не знаю насколько она полна по содержанию, но я готов выполнить все твои указания. И касательно твоих команд:
$ yay -S python-pyside-common
bash: yay: команда не найдена
$ sudo yay -S python-pyside-common
[sudo] пароль для zib:
sudo: yay: command not found
Видимо мне нужно читать и учить yaour.
К своему стыду: я не вижу spoiler, чтобы положить туда файл.
Последний раз редактировалось
0
avatar
для начала надо установить yay
sudo pacman -S yay
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
К своему стыду: я не вижу spoiler, чтобы положить туда файл.
Спойлер!

?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый, Agafron! Извини меня дурака, что я напрягаю тебя!
Я видел его, но не могу вставить туда файл. Спасибо тебе за yay!
Я установил yay и получил распечатку команды. Но как положить
файл в спойлер?
0
avatar
да как-нибудь уже вставь или сделай скриншот и вставь картинку
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый Agafron! Когда я кликаю ярлык «Обновление программ» на мониторе появляется: python-pyside-common 1.2.4-10 (1.2.4-9) ✔Обновить
Т.е. система хочет заменить версию 1.2.4-9 на 1.2.4-10 А в AUR`e ТО версия не 9, а 10!!! (См. ниже) Может быть в этом причина???

Просмотреть информацию о пакете в AUR или официальных репозиториях.
yay -Si python-pyside-common
:: Querying AUR…
Repository: aur
Name: python-pyside-common
Keywords: None
Version: 1.2.4-10!!! И на входе пришедшая версия 1.2.4-10 Может быть поэтому и не обновляется???
Description: Provides LGPL Qt bindings for Python and related tools for binding generation (Common Files)
URL: wiki.qt.io/PySide
AUR URL: aur.archlinux.org/packages/python-pyside-common
Groups: None
Licenses: LGPL
Provides: None
Depends On: None
Make Deps: python-setuptools python2-setuptools python-shiboken python2-shiboken phonon-qt4 cmake
Check Deps: None
Optional Deps: None
Conflicts With: None
Maintainer: adsun
Votes: 4
Popularity: 0.005008
First Submitted: Tue 21 Aug 2018 01:43:29 PM MSK
Last Modified: Sat 16 Nov 2019 06:09:29 PM MSK
Out-of-date: No

Вроде я созрел для использования spoiler`a. Буду пробовать.
Спасибо уважаемый GURU! За помощь, терпение и обучение!!!
Общение с тобой мне пошли на пользу: «… теперь я знаю, что мало чего знаю».
Я с Linux`ом давно, люблю его и стараюсь познать глубже.
Вышеприведенный текст я поместил в ответ на твое последнее сообщение. Затем кликнул «spoiler», набрал: Спойлерсюда я положил распечатку
и кликнул «Добавить». Но не сработало. Что я сделал неправильно?
Последний раз редактировалось
0
avatar
Пишу ответ тебе 3-й раз, но он не уходит от меня. Не могу отправить тебе распечатку команды: yay -S python-pyside-common См.Конец распечатки:…
make[2]: *** [shibokenmodule/CMakeFiles/shibokenmodule.dir/build.make:62: shibokenmodule/shiboken/shiboken_module_wrapper.cpp] Ошибка сегментирования (сделан дамп памяти)
make[1]: *** [CMakeFiles/Makefile2:323: shibokenmodule/CMakeFiles/shibokenmodule.dir/all] Ошибка 2
make: *** [Makefile:130: all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Прерывание…
[sudo] пароль для zib:
ошибка: не найдена цель: shiboken
ошибка: не найдена цель: python-shiboken
ошибка: не найдена цель: python2-shiboken
ошибка: не найдена цель: phonon-qt4
<spoiler
Спойлер
Spoiler работает, так как в предыдущем моем послании я объясняя тебе правильность моих действий напечатал ВСЕ атрибуты Spoiler`a, которые ты мне рекомендовал. Где между ними я поместил слова:«сюда я положил распечатку». Имя spoiler`a — Спойлер. И эти слова появились в моем ответе:… Спойлер сюда я положил распечатку. Может быть есть ограничения на размер отправляемого текста? Попробую отправить часть этого текста через Spoiler.
t=«Спойлер!»>Spoiler работает, так как в предыдущем моем послании я объясняя тебе правильность моих действий напечатал ВСЕ атрибуты Spoiler`a, которые ты мне рекомендовал. Где между ними я поместил слова:«сюда я положил распечатку». Имя spoiler`a — Спойлер. И эти слова появились в моем ответе:… Спойлер сюда я положил распечатку. Может быть есть ограничения на размер отправляемого текста? Попробую отправить часть этого текста через Spoiler.
0
avatar
ошибка: не найдена цель: shiboken
ошибка: не найдена цель: python-shiboken
ошибка: не найдена цель: python2-shiboken
ошибка: не найдена цель: phonon-qt4
странно, а что говорит
yay shiboken

и
yay phonon-qt4

?
PS УМВР
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Не могу отправить тебе распечатку команды: yay -S python-pyside-common См.Конец распечатки:…
make[2]: *** [shibokenmodule/CMakeFiles/shibokenmodule.dir/build.make:62: shibokenmodule/shiboken/shiboken_module_wrapper.cpp] Ошибка сегментирования (сделан дамп памяти)
make[1]: *** [CMakeFiles/Makefile2:323: shibokenmodule/CMakeFiles/shibokenmodule.dir/all] Ошибка 2
make: *** [Makefile:130: all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
если сильно большой объем вывода, лучше выложи его на pastebin и дай на него ссылку, у python-pyside-common несколько зависимостей, и где возникла ошибка(какой зависимости) непонятно
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый Agafron! Перед демонстрацией результатов заданных тобой команд хочу высказать предположение, что в AUR НЕТ файла
python-pyside-common (скорее всего я его удалил (из-за кривизны мозгов) Как говорится: «Тебе навредит не то, что ты чего-то не знаешь, а то, что ты думаешь, что знаешь — а на самом деле не знаешь». Я при очередном обновлении вместо того, чтобы просто кликнуть «Обновить», по глупости решил испробовать команду: pamac upgrade. И не зная как ответить на очередной вопрос команды — грубо прервал её выполнение.

[zib@zib-pc ~]$ sudo pacman -S python-pyside-common
[sudo] пароль для zib:
ошибка: не найдена цель: python-pyside-common
Опция -S говорит Pacman найти сжатый тарбол (файл tar.xz) с именем «хххх». Если будет найдена более новая версия,
чем установлена на этот компьютер, то тогда Pacman предложит установить новый пакет.

$ yay shiboken
7 aur/python-shiboken2-git r6554.6eb583d7-1 (+2 0.91%)
Generates bindings for C++ libraries using CPython source code (git version)
6 aur/shiboken2-git r6554.6eb583d7-1 (+2 0.91%)
Generates bindings for C++ libraries using CPython source code (git version)
5 aur/shiboken 1.2.4-7 (+8 0.87%)
CPython bindings generator for C++ libraries
4 aur/python-shiboken 1.2.4-7 (+8 0.87%)
Support library for Python bindings
3 aur/python2-shiboken 1.2.4-7 (+8 0.87%)
Support library for Python2 bindings
2 extra/shiboken2 5.13.2-1 (626.1 KiB 1.9 MiB)
Generates bindings for C++ libraries using CPython source code
1 extra/python-shiboken2 5.13.2-1 (139.8 KiB 374.6 KiB)
Generates bindings for C++ libraries using CPython source code
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==>
There is nothing to do

$ yay phonon-qt4
4 aur/phonon-qt4-mplayer-git 20120714.7217499-1 (+0 0.00%)
Mplayer backend for phonon, the multimedia API of KDE. (Qt4 only) GIT version)
3 aur/phonon-qt4-vlc 0.10.2-1 (+3 0.01%)
Phonon VLC backend for Qt4
2 aur/phonon-qt4-gstreamer 4.9.0-1 (+11 0.10%)
Phonon GStreamer backend for Qt4
1 aur/phonon-qt4 4.10.2-5 (+50 1.33%)
The multimedia framework for KDE4
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==>
There is nothing to do

А что такое: PS УМВР?

pastebin.com — пользуюсь первый раз. После подтверждения капчи я не увидел появившейся ссылки, чтобы отправить тебе(как пишут в интернете)
Отправляю адрес сайта. Жалко, что ты связался с тупым пользователем. Спасибо тебе за учёбу и бескорыстное желание помочь нуждающемуся.
Ссылка на pastebin: pastebin.com/DpzHxVh4
С уважением Борис.
0
avatar
тобой команд хочу высказать предположение, что в AUR НЕТ файла
python-pyside-common
есть
sudo pacman -S python-pyside-common
из АУР надо устанавливать с помощью Аурхелпера(в данном случае yay),
А что такое: PS УМВР?
тыц, кстати я ошибся, у меня тоже не собирается(
Ссылка на pastebin: pastebin.com/DpzHxVh4
ошибка происходит при установке пакета shiboken
в чем причина понять не смог, написал майнтейнеру вопрос, возможно скоро ответит, подождем-с
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Борис, а зачем тебе именно python-pyside-common, он уже 3 года как не поддерживается, в репах есть pyside2 или тебе именно под qt4 надо?
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый Agafron! Я совершенно не привязан к пакету python-pyside-common. Так как я не знаю его функций, то я не могу от него просто отказаться: раз он был — значит кому-то нужен. Хотя после всех этих мучений я готов вообще удалить это обновление. Мне кажется, что это застрявшее обновление перекрыло поступление новых обновлений, которые ранее шли довольно часто, а сейчас их не видно. Как его удалить?
0
avatar
а он установлен?
Как его удалить?
yay -Rscn python-pyside-common

здесь внимательно смотри, что предложит удалить, команда может быть опасной, либо используй ключ -R либо -Rsn вместо -Rscn
Мне кажется, что это застрявшее обновление перекрыло поступление новых обновлений, которые ранее шли довольно часто
а какая версия дистрибутива?
cat /etc/lsb-release

чтобы просто обновить систему достаточно дать команду
sudo pacman -Syyu
или
sudo pacman -Syyuu

вторая обновит систему и откатит версии пакетов которые отличаются от тех которые находятся в репах, но новее(иногда такое случается)
раз он был — значит кому-то нужен
не исключено, но этот пакет находится в АУР и на работоспособность системы повлиять не должен, если ты не используешь его для каких-либо экзотических творений, то конечно же удаляй
Последний раз редактировалось
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Уважаемый Agafro! Большое спасибо за терпение и советы. DISTRIB_RELEASE= Manjaro Linux 18.1.3 xfce. Зависшее обновление удалил
командой yay -R python-pyside-common --noconfirm Всё ОК!!! У меня 2 вопроса. Вчера когда ты меня толкал вперед я наткнулся на интересную информацию: «Yay — Еще один надежный помощник AUR, написанный на GO». Я спокойно зашел на сайт и почитал об YAY, скопировал адрес сайта: clck.ru/KWHKk (сокращенный вид) = itisgood.ru/2018/07/12/.... и продолжил дальнейшие поиски. А сегодня я не могу зайти на него, так как он требует авторизации. Вообще не могу зайти на itisgood.ru/. Непонятно почему. Хотелось бы вернуться к этой статье. В ней была приведена команда по проверке нежелательных зависимостей: yay -Yc. Она бы у меня освободила 1644,74 MiB. В этот блок входили и все файлы моего кеша (var > cache = 757 Mb). Можно ли мне воспользоваться этой командой, предварительно сохранив систему на случай краха. Еще раз большое тебе спасибо за твое терпение, советы и обучение. Ты много уделил мне времени и внимания!!! Ты хороший наставник!
0
avatar
yay -Yc
не рекомендую, чтобы очистить кэш используй
yay -Sc

чтобы очистить весь кэш(не рекомендуется)
yay -Scc

Непонятно почему. Хотелось бы вернуться к этой статье.
кэш гугл в помощь, я открыл. из полезного там одна фраза
Более подробную информацию о yay см. В справочных страницах.

$ man yay
или
man pacman
основные действия похожи
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
avatar
Спасибо, уважаемый Agafron! Я послушаюсь твоих советов. Кстати, я сегодня спокойно зашел на сайт itisgood.ru/2018/07/12/yay-eshhe-odin-nadezhnyj-pomoshhnik-aur-napisannyj-na-go/ «Yay — Еще один надежный помощник AUR, написанный на GO». Чудеса!
0
avatar
Чудеса!
О, да!)
?
Отправка специалистом технической поддержки ссылки на руководство по эксплуатации и другую документацию, не является отказом в предоставлении поддержки.
bash.org
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.