Уголок новичка
   1196

Установить СБИС Плагин

Необходимо установить СБИС Плагин. Делаю, как указано на сайте: sbis.ru/help/plugin/sbis3plugin/install?tb=tab2. Получаю ответ:
~/Downloads sudo -E ./sbis3plugin-setup                                                                                                      
Current download url: https://update.sbis.ru/Sbis3Plugin/master/linux
Unknown OS. Install failed.

Понимаю, что моя ОС не указана в списке операционных систем на сайте, но может быть есть какой-то способ установить плагин?

16 комментариев

avatar
?
p5ql/epu q9300 hackintosh,mint,arch,cinnamon,clover
+1
avatar
Это расширение для плагина. Оно установлено в первую очередь. Нужно установить сам плагин.
0
avatar
Думаю, придется идти по пути калькулейтовцев.
Как вариант качать deb-пакет и конвертить его в арчевский формат. С помощью debtap собирается, но работает ли я не знаю.

Можно еще попробовать написать СБИСовцам, но есть подозрение что в лучших традициях Вам скажут «не поддерживается, жрите что дают». На это намекает мудацкое опакечивание, например:
замучил этот СБИС выкладывать пакеты с обновлениями без номера версии только указывая число на странице закачки. Получается дуратская ситуация что изменения пакетов можно увидеть только при установке когда emerge выругается на несоответствие чек сумм
Но если вдруг нет — респект им.
Последний раз редактировалось
+1
avatar
Сорри за некропостинг, но оставлю тут для истории, потому что в гугле больше обсуждений по этой теме нет: вполне успешно сконвертировал и поставил deb-пакеты (sbis3plugin-22.4100-1-x86_64.pkg.tar.zst и sbis-libstdc++-9.1.1-1-x86_64.pkg.tar.zst в моем случае), СБИС нормально запустился, подписал отчётность, всё хорошо.

Короткий мануал:
— Ставим себе debtap
— Выкачиваем deb-пакеты sbis-libstdc++.deb и sbis3plugin.deb
— Конвертим пакеты. sbis-libstdc++ конвертится as-is, а вот с sbis3plugin надо будет повозиться
— В .PKGINFO меняем зависимость gdk-pixbuf>=2.31.1 на gdk-pixbuf2>=2.31.1
— В .INSTALL надо поменять обращения к service на systemctl, сдвинуть все EOF в начало строки (иначе heredoc ругается) и в одном месте там лишняя двойная кавычка (если подсветка синтаксиса есть — сразу увидите)

Ну и всё, ставим пакеты, ставим расширение для хрома, ставим криптопро и прочие приблуды и пользуемся
+3
avatar
Приветствую! Можете подсказать как что сделать наглядно далеких от этого всего) только начинаю изучать линукс, но большее предпочтение к манжаро, арче подобным системам. Система сложнее много нюансов.
0
avatar
Привет! А в чем конкретно затык?
По debtap вот неплохая статья, я по ней смотрел ostechnix.com/convert-deb-packages-arch-linux-packages/
0
avatar
я про файл .install
0
avatar
Там при запуске debtap он вас поведет по мастеру — сначала спросит про имя пакета и всё такое, а потом предложит отредактировать файлы .PKGINFO и .INSTALL. Вот их и надо отредактировать. Это можно сделать как в консоли, так и в любом другом редакторе (они в поддиректории где вы всё это делаете появятся).

Что именно надо редактировать:
`.INSTALL` — это фактически большой BASH-скрипт, проблема в том, что он создан автоматически на основе скриптов из исходного deb-пакета и в данном конкретном случае он создан с некоторыми ошибками
— В Arch и Manjaro нет утилиты service, она окончательно заменена systemctl, поэтому вам надо найти все вызовы утилиты service и заменить ее вызовы на systemctl. Синтаксис у команд почти одинаковый, за исключением того, что аргументы надо поменять местами, например `service SERVICE_NAME stop` должно превратиться в `systemctl stop SERVICE_NAME`
— Плюс там в одном месте появились пустые кавычки, их тоже надо удалить. Не помню, двойные или одинарные, правда. Надо просто поиском найти пару кавычек подряд, они там будут одни в строке посреди скрипта
— Ну и последнее — есть такая штука как heredoc (https://ru.wikipedia.org/wiki/Heredoc-%D1%81%D0%B8%D0%BD%D1%82%D0%B0%D0%BA%D1%81%D0%B8%D1%81), это способ положить контент куда-нибудь в файл. У него есть такая штука как идентификатор (в случае нашего скрипта — EOF). Так вот, этот идентификатор конца скрипта должен обязательно быть в самом начале строки, безо всяких пробелов и табуляций. Вам надо найти все строчки, в которых есть только EOF и сдвинуть этот EOF в самое начало строки, удалив пробелы и табуляции.
+2
avatar
Спс! Вроде получилось первый раз не понял где эти ковычки) а потом бац строка и там только " ппц) плагин запускается, на сайте авторизуется, норм

мучение будет только постоянно обновлять более чем на 10 пк(
Последний раз редактировалось
0
avatar
Чтобы мучений не было надо поместить в AUR либо вообще делать свою репу.
0
avatar
Можете подсказать в чем проблема? на 2 пк все установилось с некоторыми ошибками, но работает. Сейчас начал устанавливать на третий пк и фиг не хочет работать:
Подготовка…
Разрешение зависимостей…
Проверка на взаимные конфликты…
Внимание: обнаружена циклическая зависимость:
Внимание: aarch64-linux-gnu-glibc будет установлен перед aarch64-linux-gnu-gcc, как зависимость
Проверка связки ключей…
Проверка целостности…
Загрузка файлов пакетов…
Проверка файлов на конфликты…
Проверка доступного дискового пространства…
Установка aarch64-linux-gnu-binutils (2.39-1)…
Установка aarch64-linux-gnu-linux-api-headers (5.18-1)…
Установка aarch64-linux-gnu-glibc (2.35-1)…
Установка aarch64-linux-gnu-gcc (12.1.0-1)…
mkdir: невозможно создать каталог «»: Нет такого файла или каталога
— Installer Value: 22.4100-1
Установка приложения СБИС Плагин 22.4100.360 версии
ОС определена как arch
os. Корректная работа приложения в данной ОС не гарантирована.
Остановка сервиса
Failed to stop SBIS3Plugin.service: Unit SBIS3Plugin.service not loaded.
Не удалось остановить сервис.
Остановка приложения
sbis3plugin: процесс не найден
— Настройка sbis3plugin…
mkdir: невозможно создать каталог «»: Нет такого файла или каталога
— Installer Value: 22.4100-1
mv: невозможно переместить '/opt/sbis3plugin/temp/22.4100.360' в '/opt/sbis3plugin/22.4100.360': Каталог не пуст
mv: невозможно переместить '/opt/sbis3plugin/temp/icons' в '/opt/sbis3plugin/icons': Каталог не пуст
Регистрация автозапуска
Регистрация Chrome NMH и SbisPluginConnector, проверка признака RC версии
terminate called without an active exception
/usr/bin/sbis3plugin-install.common.sh: строка 7: 32579 Аварийный останов (стек памяти сброшен на диск) "/opt/sbis3plugin/22.4100.360/service/components-registrator" installActions locale=ru-RU 2>&1
32580 Завершён | tee -a "/2022-08-11_.log"
Не удалось выполнить регистрацию дополнительных компонентов. Установка не завершена.
Ошибка: sbis3plugin: не удалось корректно выполнить команду
Выполняются обработчики post-transaction…
Arming ConditionNeedsUpdate…
Транзакция успешно завершена.

Или скиньте свой сконфигурированный файл я его посмотрю
Последний раз редактировалось
0
avatar
где пишет каталог не пуст я уже все подчистил этих ошибок не должно быть
0
avatar
Не, там важнее строчки

Регистрация Chrome NMH и SbisPluginConnector, проверка признака RC версии
terminate called without an active exception
/usr/bin/sbis3plugin-install.common.sh: строка 7: 32579 Аварийный останов (стек памяти сброшен на диск) "/opt/sbis3plugin/22.4100.360/service/components-registrator" installActions locale=ru-RU 2>&1
32580 Завершён | tee -a "/2022-08-11_.log"
Не удалось выполнить регистрацию дополнительных компонентов. Установка не завершена.


Не может почему-то плагин в хром подсунуть (а он установлен вообще?). Почему — не знаю, не сталкивался. Там вот логфайл какой-то есть — /2022-08-11_.log, может там что-то подробное будет
Последний раз редактировалось
0
avatar
Так на пк где работает сбис хрома тоже нет) Есть же способ через PKGBUILD еще компилировать через него не пробовали?
0
avatar
Не, я завёл всю шарманку, сдал нулёвку после закрытия ИП и забыл как страшный сон :)
0
avatar
Смотрел как в Fedore плагин устанавливается чем то даже похожи ошибки, systemctl так же как на arch, зависимости другие
Проверка транзакции
Проверка транзакции успешно завершена.
Идет проверка транзакции
Тест транзакции проведен успешно.
Выполнение транзакции
Подготовка: 1/1
Установка: libnsl-2.35-14.fc36.x86_64 1/3
Установка: libatomic-12.1.1-1.fc36.x86_64 2/3
Запуск скриптлета: sbis3plugin-22.4100-343.x86_64 3/3
— Preinstall script
Installer Value: 1
Установка приложения СБИС Плагин 22.4100.343 версии
ОС определена как fedora. Корректная работа приложения в данной ОС не гарантирована.
Остановка сервиса
Redirecting to /bin/systemctl stop SBIS3Plugin.service
Failed to stop SBIS3Plugin.service: Unit SBIS3Plugin.service not loaded.
Не удалось остановить сервис.
Остановка приложения
sbis3plugin: процесс не найден
— Установка: sbis3plugin-22.4100-343.x86_64 3/3
Запуск скриптлета: sbis3plugin-22.4100-343.x86_64 3/3
— Postinstall script
Installer Value: 1
Регистрация автозапуска
Регистрация Chrome NMH и SbisPluginConnector, проверка признака RC версии
Обновление версии CromeNmhTransport
ChromeNmhTransport: процесс не найден
mkdir: невозможно создать каталог «/usr/share/Sbis3Plugin»: Файл существует
Регистрация демона
Демон «SBIS3Plugin» не установлен в системе
=====================================
Registering daemon «SBIS3Plugin»
— directory: /opt/sbis3plugin
user: root
library: auto
entry point: auto
autorun: true
=====================================
Created symlink /etc/systemd/system/multi-user.target.wants/SBIS3Plugin.service → /usr/lib/systemd/system/SBIS3Plugin.service.
OK
Adding restart
Старт демона
Redirecting to /bin/systemctl start SBIS3Plugin.service
Выполнение afterInstall успешно завершено
/usr/bin/update-ca-trust
Создание иконки на рабочем столе
/usr/bin/gio
/usr/bin/dbus-launch
gio: Установка атрибута metadata::trusted не поддерживается
Установка завершена.
-------------
Последний раз редактировалось
0
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.